Weird interaction latte dock and background on startup

The Issue:

hi guys :slight_smile:
since i changed the background of garuda dragonized when i boot the system the latte dock does this weird thing, (a glitch?) i cannot better explain it rather than linking a photo of it

then after a few seconds all seems to be normal again

i know its not a major issue but it still bothers me xD

the photos are taken with my phone, they are not screenshots.

What i tried:

I tried all these things without much success

  • disabling latte on startup and running it manually
  • trying delaying latte adding a splash screen on startup
  • trying some dock settings

i hope someone could help me with this
thank u all in advance :blush:

output of inxi Faz:

inxi -Faz

System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=500b18d4-94f8-4dca-b600-8c1bdeec5717 rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux  
base: Arch Linux  
Machine:   Type: Laptop System: HP product: HP Pavilion Power Laptop 15-cb0xx v: Type1ProductConfigId serial: <filter>  
Chassis: type: 10 serial: <filter>  
Mobo: HP model: 836B v: 46.21 serial: <filter> UEFI: Insyde v: F.10 date: 07/28/2017  
Battery:   ID-1: BAT0 charge: 45.8 Wh (83.7%) condition: 54.7/54.7 Wh (100.0%) volts: 16.6 min: 15.4 model: HP Primary  
type: Li-ion serial: N/A status: Unknown  
CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158)  
stepping: 9 microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798  
Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b
class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0300
Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo bus-ID: 1-4:2 chip-ID: 04f2:b5d6
class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
chip-ID: 8086:a171 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9
class-ID: 0403
Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 bus-ID: 04:00.0 chip-ID: 8086:095a
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 8087:0a2a
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:    Local Storage: total: 1.03 TiB used: 9.92 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 5KHA4102 temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3T0 scheme: GPT
Partition: ID-1: / raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 9.91 GiB (8.3%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 9.91 GiB (8.3%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 9.91 GiB (8.3%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 9.91 GiB (8.3%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 293 Uptime: 2m wakeups: 1 Memory: 15.51 GiB used: 2.6 GiB (16.8%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1378 lib: 335 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.06

I've noticed this on 3 different machines. Very minor bug, and from what I can tell it doesn't have long term effects so I wouldn't worry too much. Might get fixed with all these KDE updates happening lately, but who knows.

1 Like
Off topic.

Never touch a running system :smiley:


right click on desktop > configure desktop and wallpaper > add image> selected the image i had downloaded :slight_smile:

Fine, no problem here, how that will break latte?
Maybe changing wallpaper has nothing to do with latte bugs?

pretty sure it has nothing to do with changing background as I've noticed it on the default background. Pressing alt+shift+F12 once, then once again to toggle the compositor back on gives similar effects, so I'm pretty sure its a tiny bug having to do with initial screen drawing with the compositor for the latte dock.

Maybe after Nvidia and KDE finish their work improving Wayland support this tiny bug might go away after changing to a Wayland session?

Have you followed the few steps from the Latte developer on how to properly start Latte Dock?



disabling latte in plasma restore session did the trick :smiley: tysm guys!!


Oh, all right, look at me. I think this is my first "Solution" on Garuda. I will be waiting by the pipes for that forum badge to come rolling out. :laughing:

I also want to collect my prize, the Garuda Dragon action figure from the bottom shelf with all the dust on it. When you pull its string it fires out choice @c00ter sayings, like....

If a 10-year old beginner can do it, surely these astute personages can.

Those that do, don't dual-boot (for long).

And my personal favorite....

Read before posting. Saves making an ass of yourself.

Guaranteed to send them running for the reddit forum to complain. :rofl:


I wish we had a quote of the week badge as you'd for sure win that honour with all those prime c00terisms you quoted.

Thanks for helping out on the forum Rodney. The reward is simply gaining good Karma. Of course for some people this may be essential to offset all the sh1tty things you did when you were younger. I suspect that innocent looking Avatar of yours is only there to disguise your true nature and avoid prosecution from a stack of heinous war crimes from your past. You're not fooling anyone, you can run, but you can't hide, (at least not from baseless accusations). :rofl:

Thanks again @RodneyCK


I am copywriting this before he does.

Busted on a linux forum! You are incorrigible. :grin:


Ya, it's something I truly pride myself on. :rofl:


Just wanted to add real quick what on what I've mentioned before. What I noticed was just a few quick frames of the compositor starting and not "a few seconds of a latte visual glitch" since I already start with a blank session and there is only one startup instance of Latte Dock. It isn't always noticeable.

(Just wanted to add this in here on the chance somebody does a search on this and somehow thinks its the Latte Dock's fault.)

1 Like

You two are both incorrigibles. I just calls 'em as I sees 'em. That doesn't always earn me friends, so I would discourage any foray into that that realm. And I mean it. Sometimes my posts are influenced by pain, which tends to make me grumpy and my posts as short as my mood. And that's not a good thing.

Better to emulate some of the more helpful forum members. Come to think of it, you could emulate each other.

Harharhar! There's a thought. :slight_smile:


Well your c00terisms are keeping my back-alley t-shirt sweatshop running. Please keep them coming. :stuck_out_tongue_winking_eye:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.