Weird frameskipping in games after installing a new graphics card


Recently, I bought a new gpu and I noticed something weird while playing games. It seems to be frameskipping happening while gaming. It didn’t happen on my previous gpu. The frame rate is stable but the game is clearly not running smooth. It doesn’t happen all the time but it’s quite frequent. I’ve tried other distros but it keeps happening. I also tried running games on Windows and the issue is not present on that system. I post this thread in GNOME because that’s the desktop I wanna use.

Any idea how to fix this issue?

Could you please provide your


as per the forum template?


So this is a little bit of a problem as I’m not actually using Garuda right now. I was recently reinstalling the system because of the new gpu, hoping it would fix the issue, but for some reason I wasn’t able to update the system. I was getting a constant error whenever I tried to. I’ve installed whatever other Linux distro I had so I can keep working on my stuff.

Sorry. I know it’s a bit weird of me to ask for help on this forum even though I don’t have Garuda installed at the moment but I thought it’s still worth trying. I actually want to keep using Garuda but I just couldn’t update it. Maybe it’s fixed now.

Hello again. Sorry for this confusing post. I just wanted to say that I solved this issue. All I had to do was update the bios. It was the first time I ever did it and I’m happy to say it solved the issue.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.