Weird delay in launch of some apps

Greetings fellow Garudians!

The past week I’ve been trying to daily drive Garuda Hyprland and I generally love the experience so far (thank you so much for creating this awesome flavour of Garuda) - with one bummer:
Although some applications launch blazingly fast compared to my previous daily driver Garuda KDE- Dragonized - terminal, file explorer, firefox, thunderbird, libreoffice, gimp etc. These apps launch almost immediately which I was not used to on the Dragonized version, it always took a few seconds.
But - other apps launch very slowly (but then run great).
Spotify: I launch it, grey empty window appears, after ~10s it launches
Obsidian, Discord, Mattermost, VS Code (or VS Codium): I launch it, for about 10s nothing happens and then it is launched.

Note 1: if I already have an instance running, for example one window with obsidian, and launch another instance of obsidian, it launches immediately.

Note 2: when launching the app from terminal, no errors are displayed.

Hypothesis: It almost seems like it always takes very close to 1O seconds - as if there was some timeout for waiting on some service? Aren’t all those apps somehow linked with chromium/based on it? Chromium does the same 10s delay (although it creates a transparent empty window and after 10s is correctly displayed).

I tried:

  1. adding this to my hyprland config
# from hyprland wiki - should speed up launches of apps
exec-once=dbus-update-activation-environment --systemd WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
exec-once=systemctl --user import-environment WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
  1. trying alternative or open source versions of the apps - vs codium and various other versions of VS code (including vs codium wayland), webcord, discord_arch_electron etc. - with no change at all

  2. launching these apps with --enable-features=UseOzonePlatform --ozone-platform=wayland - with no change at all

I am currently out of ideas as to what more to try. Do you have any ideas?
Thanks for your assistance!

garuda-inxi: (I am currently triple booting - Win10, Garuda Dragonized, Garuda Hyprland)

  Kernel: 6.8.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=24b1e4f2-5eb6-4805-ace8-c016087c9c6c rw rootflags=subvol=@
    loglevel=3 ibt=off
  Desktop: Hyprland v: 0.39.1-1-ge8e02e81 with: waybar tools: swayidle
    avail: swaylock vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
  Type: Laptop System: Dell product: XPS 13 9305 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0PPYW4 v: A02 serial: <superuser required> part-nu: 0A5C
    uuid: <superuser required> UEFI: Dell v: 1.20.0 date: 02/01/2024
  ID-1: BAT0 charge: 10.3 Wh (30.1%) condition: 34.2/52.0 Wh (65.8%)
    volts: 7.3 min: 7.6 model: SMP DELL G8VCF6C type: Li-poly serial: <filter>
    status: discharging
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 781 high: 1225 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 1225 3: 400
    4: 1153 5: 400 6: 1159 7: 400 8: 1117 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
    driver: i915 v: kernel alternate: xe arch: Gen-12.1 process: Intel 10nm
    built: 2020-21 ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1,
    HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 0c45:6723
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: Hyprland v: 0.39.1-1-ge8e02e81 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: AU Optronics 0x5b2d built: 2018 res: 1920x1080
    hz: 60 dpi: 166 gamma: 1.2 scale: 1 size: 293x162mm (11.54x6.38")
    diag: 335mm (13.2") ratio: 16:9 modes: 1920x1080
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
    Xe Graphics (TGL GT2) driver: mesa intel v: 24.0.5-arch1.1
    device-ID: 8086:9a49 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.5-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
  API: ALSA v: k6.8.6-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: a5:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp165s0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1:2 chip-ID: 8087:0029
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 476.94 GiB used: 19.63 GiB (4.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNS512G
    NVMe KIOXIA 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 10410106 temp: 33.9 C scheme: GPT
  ID-1: / raw-size: 50.63 GiB size: 50.63 GiB (100.00%)
    used: 19.53 GiB (38.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: /boot/efi raw-size: 190 MiB size: 186 MiB (97.89%)
    used: 94.2 MiB (50.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 50.63 GiB size: 50.63 GiB (100.00%)
    used: 19.53 GiB (38.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-4: /var/log raw-size: 50.63 GiB size: 50.63 GiB (100.00%)
    used: 19.53 GiB (38.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-5: /var/tmp raw-size: 50.63 GiB size: 50.63 GiB (100.00%)
    used: 19.53 GiB (38.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.35 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 15.35 GiB used: 5.05 GiB (32.9%)
  Processes: 264 Power: uptime: 7m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 6.1 GiB Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1465 libs: 431 tools: pacseek,paru Compilers:
    gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26 running-in: foot
    inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-04-09
  Last full system update: 2024-04-17
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Not sure if I can help you , but I had the same issue as well on Kernel Zen . Perhaps try out the vanilla Arch Kernel :
sudo pacman -S linux linux-headers

Then boot into the Linux kernel (the name will only mention Linux and nothing else) from the grub menu. See if that performs stable.

1 Like

Thanks for your suggestion - I tried a couple of different kernels and it clearly is the differentiator - with other kernels than zen the fast loads are a little slower, but the slow ones were much faster - very interesting for me.

Update: today I updated to latest Zen (6.8.7) and the issue got resolved. Everything runs great now.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.