Webcam issue in FireDragon | Apple product: MacBookPro12,1

I have an issue with my webcam on FireDragon. Might be a setting, im not sure, but would like to see if I can get some assistance.

I have a 1080p USB webcam hooked up to my laptop, and when I open up FireDragon and try to use the webcam on a site, it will initialize it and pull and image, but thats it. It will not continue with the feed, it pulls the initial image and stops. I tested this in Firefox ESR and it works just fine.

ixni posted below.

System:    Kernel: 5.13.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
           root=UUID=a192f795-0935-4190-909b-7bed960ef2ed rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           resume=UUID=fe026fba-e046-400a-aead-15e86956c80e loglevel=3 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0 serial: <filter> Chassis: 
           type: 9 v: Mac-E43C1C25D4880AD6 serial: <filter> 
           Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1 serial: <filter> 
           UEFI: Apple v: MBP121.88Z.0177.B00.1806051659 date: 06/05/2018 
Battery:   ID-1: BAT0 charge: 39.1 Wh (54.4%) condition: 71.9/74.8 Wh (96.2%) volts: 11.3 
           min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A status: Discharging cycles: 47 
CPU:       Info: Dual Core model: Intel Core i5-5257U bits: 64 type: MT MCP arch: Broadwell 
           family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 2701 MHz min/max: 500/3100 MHz Core speeds (MHz): 1: 2701 2: 2701 3: 2700 
           4: 2701 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:162b class-ID: 0300 
           Device-2: Realtek FULL HD 1080P Webcam type: USB driver: snd-usb-audio,uvcvideo 
           bus-ID: 1-2:2 chip-ID: 0bda:58b0 class-ID: 0102 serial: <filter> 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 507x317mm (20.0x12.5") 
           s-diag: 598mm (23.5") 
           Monitor-1: eDP1 res: 1920x1200 hz: 60 dpi: 168 size: 290x180mm (11.4x7.1") 
           diag: 341mm (13.4") 
           OpenGL: renderer: Mesa Intel Iris Graphics 6100 (BDW GT3) v: 4.6 Mesa 21.1.6 
           direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403 
           Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403 
           Device-3: Broadcom 720p FaceTime HD Camera driver: N/A bus-ID: 02:00.0 
           chip-ID: 14e4:1570 class-ID: 0480 
           Device-4: Realtek FULL HD 1080P Webcam type: USB driver: snd-usb-audio,uvcvideo 
           bus-ID: 1-2:2 chip-ID: 0bda:58b0 class-ID: 0102 serial: <filter> 
           Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple driver: brcmfmac 
           v: kernel port: efa0 bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280 
           IF: wlp3s0 state: up mac: <filter> 
Bluetooth: Device-1: Apple Bluetooth Host Controller type: USB driver: btusb,hid-generic,usbhid 
           bus-ID: 1-3:3 chip-ID: 05ac:8290 class-ID: fe01 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:    Local Storage: total: 113 GiB used: 11.79 GiB (10.4%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0128G size: 113 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD 
           serial: <filter> rev: PA0Q scheme: GPT 
Partition: ID-1: / raw-size: 110.51 GiB size: 110.51 GiB (100.00%) used: 11.79 GiB (10.7%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%) used: 576 KiB (0.1%) 
           fs: vfat dev: /dev/sda3 maj-min: 8:3 
           ID-3: /home raw-size: 110.51 GiB size: 110.51 GiB (100.00%) used: 11.79 GiB (10.7%) 
           fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-4: /var/log raw-size: 110.51 GiB size: 110.51 GiB (100.00%) 
           used: 11.79 GiB (10.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw-size: 110.51 GiB size: 110.51 GiB (100.00%) 
           used: 11.79 GiB (10.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2 
           dev: /dev/sda1 maj-min: 8:1 
           ID-2: swap-2 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100 
           dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 71.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 209 Uptime: 26m wakeups: 2 Memory: 7.67 GiB used: 3.39 GiB (44.1%) 
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 
           pacman: 1253 lib: 311 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 
           running-in: alacritty inxi: 3.3.06

If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look
greetings :slight_smile:

and
:slight_smile:

Sorry about that. I was just about to edit the post and do that but you did it for me :slight_smile:

1 Like

On Garuda?
Post logs from when this was working fine.
Also post logs from when it was not (with FireDragon).
Have you tested any other application using this camera? OBS?

Sites are very much dependent on their web developers, when it comes to functionality and especially multimedia. It's not the best method to check if your camera is well functioning.

Anyway, if there is a bug, we need info/logs to bring it up. :man_shrugging:

https://wiki.archlinux.org/title/Webcam_setup

1 Like

I actually encounter the same issue, but the person on the other end can see me fine. Try removing all of your extensions and try again

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.