Web video playback isn't working,and no sound

Pulse and PipeWire are both running. Go to Garuda Welcome → Garuda Assistant → System Components tab. Uncheck PulseAudio. Hit Apply. Reboot.

If that doesn’t work by itself, try reinstalling Pipewire using the Garuda Assistant (which I am thinking you will have to do because I don’t see Pipewire using pipewire-pulse in your inxi).
Uncheck Pipewire, hit apply. Then check Pipewire, hit apply. Then reboot.

Issues with sound can stop videos from loading, so hopefully this will clear up both your issues.