Wayland issues, what should I do?

I really WANT to finally trash windows for good.
For my work I use only linux, fortunally.
For my private life I actually can’t migrate yet, because of must-use non wayland compatible apps, and would really like to use Garuda. It is 2-3 months I’m trying to solve my issues that doesn’t allow me to definitely trash windows. I have a second work and I really need to use these:

  1. XP-Pen tablet - Because of wayland it is impossible to make it works and have the pen actually writing in the screen it is replicating.
  2. Mouse and Keybaord sharing. I need other machines on my desk to be used with the same mouse and keyboard (and clipboard sharing is actually useful). Now I’m using Synergy, and it is not compatible with wayland.

For both I tried xwayland, and failed miserably.
This is the Garuda inxi:

System:
Kernel: 6.9.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ffb10ea5-9e25-414f-b929-bca6809908c1 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: Vector GP68HX 13VI v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-15M1 v: REV:1.0 serial: <superuser required>
part-nu: 15M1.3 uuid: <superuser required> UEFI: American Megatrends LLC.
v: E15M1IMS.308 date: 07/18/2023
Battery:
ID-1: BAT1 charge: 83.3 Wh (98.0%) condition: 85.0/87.4 Wh (97.3%)
volts: 17.3 min: 15.4 model: MSI BIF0_9 type: Li-ion serial: N/A
status: not charging
ID-2: hidpp_battery_0 charge: 66% condition: N/A volts: 3.9 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
CPU:
Info: model: 13th Gen Intel Core i9-13950HX bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
microcode: 0x123
Topology: cpus: 1x cores: 24 mt: 8 tpc: 2 st: 16 threads: 32 smt: enabled
cache: L1: 2.1 MiB desc: d-16x32 KiB, 8x48 KiB; i-8x32 KiB, 16x64 KiB
L2: 32 MiB desc: 8x2 MiB, 4x4 MiB L3: 36 MiB desc: 1x36 MiB
Speed (MHz): avg: 1459 high: 5488 min/max: 800/5300:5500:4000 scaling:
driver: intel_pstate governor: performance cores: 1: 800 2: 800 3: 800
4: 801 5: 800 6: 1983 7: 800 8: 800 9: 2262 10: 800 11: 5488 12: 800
13: 1368 14: 800 15: 1181 16: 5300 17: 800 18: 800 19: 800 20: 798
21: 2301 22: 800 23: 800 24: 800 25: 800 26: 800 27: 800 28: 3397 29: 800
30: 2156 31: 3668 32: 800 bogomips: 154828
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Raptor Lake-S UHD Graphics vendor: Micro-Star MSI
driver: i915 v: kernel alternate: xe arch: Gen-13 process: Intel 7 (10nm)
built: 2022+ ports: active: eDP-2 empty: DP-3, DP-4, HDMI-A-2, HDMI-A-3
bus-ID: 0000:00:02.0 chip-ID: 8086:a788 class-ID: 0300
Device-2: NVIDIA GN21-X11 [GeForce RTX 4090 Laptop GPU]
vendor: Micro-Star MSI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ ports: active: none off: HDMI-A-1
empty: DP-1,DP-2,eDP-1 bus-ID: 0000:01:00.0 chip-ID: 10de:2717
class-ID: 0300
Device-3: Bison HD Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 5986:116f
class-ID: fe01 serial: <filter>
Device-4: SHENZHEN AONI NexiGo N930AF FHD Webcam
driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 1-8.2:8 chip-ID: 3443:930f class-ID: 0102
serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia d-rect: 1920x2280 display-ID: 0
Monitor-1: HDMI-A-1 pos: primary,top res: 1920x1080 size: N/A modes: N/A
Monitor-2: eDP-2 pos: bottom res: 1920x1200 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (RPL-S)
device-ID: 8086:a788 memory: 30.52 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 10 device: 0 type: integrated-gpu
name: Intel Graphics (RPL-S) driver: mesa intel v: 24.1.1-arch1.1
device-ID: 8086:a788 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 4090 Laptop GPU driver: nvidia
v: 550.78 device-ID: 10de:2717 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.1.1-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Raptor Lake High Definition Audio vendor: Micro-Star MSI
driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel, snd_soc_avs,
snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:7a50
class-ID: 0401
Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:22bb class-ID: 0403
Device-3: SHENZHEN AONI NexiGo N930AF FHD Webcam
driver: snd-usb-audio,uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 1-8.2:8 chip-ID: 3443:930f class-ID: 0102
serial: <filter>
Device-4: Logitech G635 Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-8.3:9 chip-ID: 046d:0a89 class-ID: 0300
serial: <filter>
API: ALSA v: k6.9.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Raptor Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:7a70 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel port: 4000 bus-ID: 0000:3a:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp58s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Drives:
Local Storage: total: 4.58 TiB used: 92.6 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
SN560 SDDPNQE-1T00-1032 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 74104000 temp: 57.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:9 vendor: Crucial model: CT4000P3PSSD8
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR40A temp: 59.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Lexar model: USB Flash Drive
size: 7.32 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 1100
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 388.62 GiB size: 388.62 GiB (100.00%)
used: 33.29 GiB (8.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
used: 92.4 MiB (9.0%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 388.62 GiB size: 388.62 GiB (100.00%)
used: 33.29 GiB (8.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-4: /var/log raw-size: 388.62 GiB size: 388.62 GiB (100.00%)
used: 33.29 GiB (8.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
ID-5: /var/tmp raw-size: 388.62 GiB size: 388.62 GiB (100.00%)
used: 33.29 GiB (8.6%) fs: btrfs dev: /dev/nvme0n1p8 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.5 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 64 GiB note: est. available: 62.5 GiB used: 8.55 GiB (13.7%)
Processes: 587 Power: uptime: 50m states: freeze,mem,disk suspend: s2idle
avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 24.96 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 2024 pm: pacman pkgs: 2016 libs: 583 tools: octopi,paru
pm: flatpak pkgs: 8 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-15
Last full system update: 2024-06-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I use personal pc for (in order of priority)

  • Teaching Online using Zoom meetings, OBS, Xournal, Synergy and XP-Pen tablet.
  • Gaming (World of Warcraft) mostly, I’m waiting to test this part until I solve the above. Also steam, that is actually more compatible.
  • Coding (rust, python, angular, C, assembler, etc etc) This is actually already working very good, and better than windows!
  • Some AI projects.

I could find the best drawing tablet compatible with Linux and wayland, to solve this problem with some $$, but the sharing part is there.
I tried Barrier and input-lean, both not working. I tried a rust project ‘lan-mouse’ that is really promising, but for now I have more issues than solutions.

What would you suggest? Should I use X11 by default on all system? How many problem could arise from this choice? Should I use another Arch distro (yes, arch is the only fixed thing in my mind!)?

Thanks

Hi,
I am just a user and much more technical people will be able to reply but have you tried a windows 10 VM? Running on top of your garuda install.
your specs will handle it and for the couple of things that are not yet compatible.
you can use the vm until you save for another tablet or Wayland becomes ubiquitous.
Ive been doing it for years now , I had the dual boot problem years ago and decided to never dual boot again. you can set up usb forwarding etc for the VM.
It is getting better al the time.
Hope this helps , thinking in a slightly less technical way.

1 Like

This is what I would do.
There shouldn’t be any drawbacks. Anyway, test it for a while.
Probably the use of Wayland by default in KDE 6 uncovered many application issue (in addition to the well known Nvidia ones), which will be fixed over time.

5 Likes

As for the clipboard setting up kde connect on all systems an linking them will do that.

The other thing to test is if the pen works in x11? you’ll be fine with x11 for the next few years. In that time maybe wayland devs will make the pen work. Maybe the best way is to file a feature request for it? but im just guessing on that one.

You can try gnome but if it wont work there its unlikely to work anywhere else. As the distros themselves have to build there own “wayland” being on garuda or fedora or suse wont change it.

4 Likes

KDE comes with a KCM that detects drawing tablets. I just tried mine Huion and it is working. If you don’t have KDE version of Garuda, did you try OpenTabletDrivers?

The VM could solve the tablet problem maybe, if the input is sent correctly.
Bu the keyboard and mouse sharing would not, since going over the border of a VM would go to host instead, otherwise, I lose totally mouse and keybaord? I just decide to apss to office 365 via browser but this could help with that too :smiley:
Thanks for advice

I’m doing it right now and as a first, the table finally works fine. input is where I expect it to be!
Since I switched to Plasma X11, I have an issue with full screen windows in external screens (or simply, not main screen). When maximized I cannot access the toolbar to minimize, resize, and all the options I should have in top bar (such as ‘file’, ‘edit’ etc…).
Is it something I cannot see somewhere or is it broken?

Thanks

1 Like

Yes, and it is even worst, the touch is not even noticed by the system at all :frowning:
With X11 it is now working fine.

1 Like

There’s the answer. Wayland is still getting better (or being worked on depending on your feelings towards it). Just stick to x11 until the things you need are working. x11 will likely be around for a very long time still, I don’t think you need to worry about that.

2 Likes

You can restore the border with this fix, if you hit F11 to maximize theirs no buttons or bar. Why? Not sure that’s a question for kde an gnome haha.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.