Wayland doesn't work under GNOME

I would like to use Wayland under GNOME, but it only allows X11.
I also tried editing the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub. All I did was add nvidia-drm.modeset=1.
Then, I attempted to change the #WaylandEnable=false line to #WaylandEnable=true in /etc/gdm/custom.conf. However, neither of these solutions helped. Does anyone have any ideas?
I've been using Linux for a week, so I'm still learning, and I'm hesitant to make changes to the system without guidance. That's why I'm seeking help here.

I don’t use gnome but I believe you need to remove the # before the WaylandEnable option to un-comment it and hence for it to work.

Also this is the script available on garuda’s repos to enable wayland, so you can just run this too.

Finally once you have made all the necessary configs you need to choose weather you want X11 or wayland session when you are booting into your device right from the sddm login screen where you enter password. There would be a small gear shaped icon/list which you can click to switch from x11 to wayland.

Also please post your garuda-inxi in future whenever asking for assistance even if you feel it’s un-needed. It’s template for a reason.


Thank you very much, I tried. But this didn't help either. However, I have a new option that wasn't there before - Plasma X11 :smiley:

Can you please provide your


as per the forum template

1 Like

Please provide your garuda-inxi. Also try clicking on that option and choose wayland to login.

1 Like
  Kernel: 6.4.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d003498c-6393-40ea-a9ca-a1f966f550f7 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=46ee983d-fb68-412e-a982-d3432cbe9970 loglevel=3 ibt=off
  Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: B85M-G v: Rev X.0x serial: <superuser required>
    BIOS: American Megatrends v: 2501 date: 07/22/2015
  Info: model: Intel Core i5-4690K bits: 64 type: MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 4300 min/max: 800/4300 scaling: driver: intel_cpufreq
    governor: performance cores: 1: 4300 2: 4300 3: 4300 4: 4300 bogomips: 28000
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: ASUSTeK driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm
    built: 2013 ports: active: none empty: HDMI-A-1,HDMI-A-2,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0380
  Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK
    driver: nvidia v: 535.98 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: gnome-shell driver: X: loaded: nvidia gpu: i915,nvidia
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 95 s-size: 1027x286mm (40.43x11.26")
    s-diag: 1066mm (41.97")
  Monitor-1: DVI-D-0 pos: right res: 1280x1024 dpi: 96
    size: 338x270mm (13.31x10.63") diag: 433mm (17.03") modes: N/A
  Monitor-2: HDMI-0 pos: primary,left res: 2560x1080 hz: 60 dpi: 97
    size: 673x284mm (26.5x11.18") diag: 730mm (28.76") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.98 renderer: NVIDIA GeForce GTX 1050
    Ti/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: ASUSTeK 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-3: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k6.4.10-zen2-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.77 status: active with: 1: wireplumber
    status: active 2: pipewire-alsa type: plugin 3: pw-jack type: plugin
    tools: pw-cat,pw-cli,wpctl
  Server-2: PulseAudio v: 16.1 status: active with: pulseaudio-jack
    type: module tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: enp0s20u8 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Samsung GT-I9070 (network tethering USB debugging enabled)
    driver: rndis_host v: kernel type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    mode: 2.0 bus-ID: 3-8:8 chip-ID: 04e8:6864 class-ID: 0a00 serial: <filter>
  Report: bt-service: enabled,stopped note: tool can't run
  Local Storage: total: 1.58 TiB used: 30.69 GiB (1.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5003AZEX-00K1GA0 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: 0A80
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: SSD serial: <filter> fw-rev: T1.3 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: DT01ACA100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A750 scheme: GPT
  ID-1: / raw-size: 210.85 GiB size: 210.85 GiB (100.00%)
    used: 30.69 GiB (14.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 210.85 GiB size: 210.85 GiB (100.00%)
    used: 30.69 GiB (14.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 210.85 GiB size: 210.85 GiB (100.00%)
    used: 30.69 GiB (14.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 210.85 GiB size: 210.85 GiB (100.00%)
    used: 30.69 GiB (14.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.56 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 12.72 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb2 maj-min: 8:18
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 242 Uptime: 15m wakeups: 0 Memory: total: 12 GiB
  available: 11.56 GiB used: 2.95 GiB (25.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: 1555 pm: pacman pkgs: 1529 libs: 405
  tools: gnome-software,pamac,paru,yay pm: flatpak pkgs: 26 Shell: fish
  v: 3.6.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-08-12
  Last full system update: 2023-08-13
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       <superuser required>
  Failed units:            

If I try to log in under Plasma X11, after entering the password, I encounter a black screen.

As a suggestion, go to Garuda Welcome > Garuda Assistant > Settings and check Enable GDM Wayland:

1 Like

It is turned on.

Just a couple of ideas searching in the forum (I’m not a Gnome user).


The solution was relatively simple; I just didn't notice that there was no space between the # and WaylandEnable=false in the etc/gdm/custom.conf file.
However, I'm not sure if this is what really helped, or if it was adding the nvidia_drm.modeset=1 line to /etc/default/grub. I'll try to find out later, but for now, everything is working perfectly.
Thank you to everyone for the help!! :smiling_face_with_three_hearts: :smiling_face:

I tried out this as well, which was mentioned here:

There is no difference between

#commented text
# commented text

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.