Wayfire Login Loop with Nouveau After Installation

I’m going a little crazy over here, long time linux user, although this is my first experience with a distro that uses pacman. I’ve installed Garuda about a dozen times, and can’t manage to get to a desktop. When I try using the NVIDIA Proprietary version of the Live Installer, it just goes to a black screen and no further, so I’ve been using nouveau. I can install just fine, then when I reboot, I get to the login screen, login, the screen goes black, then gray, then flashes a black screen with the text “Kernel driver in use: nouveau” for a split second before popping the login screen back up. I am able to use ctrl-alt-Fx to get to a TTY, but then what? Ive tried using garuda-update, that threw a whole bunch of questions about conflicting packages (side-note, how are there conflicting packages directly after installation?!) that I had to manually resolve (no big deal, but I feel like this shouldn’t be required to update from a fresh installation), and also tried installing nvidia-dkms and removing nouveau with mhdw or whatever it’s called, that just led to the same problem I was having with the live installer after a reboot, didn’t even get to the login screen.
I’ve already tried using “nvidia-drm.modeset=1” in the grub options, and I was able to use the same iso to setup a working VM (in Windows) using both Proprietary and open source drivers for the installer.
I’m just trying to experience Wayland/Wayfire and this distro looks really awesome, but the amount of work I’ve put in to just get the thing to a desktop feels like a punch in the face coming from Debian.
Any help is appreciated!
(sorry for no inxi output, it’s a fresh install, I haven’t touched anything)

Try Hyprland, please. :slight_smile:
Uhm, Nvidia, need also some work, maybe Sway.

Or just KDE :smiley:

Have you tried launching Wayfire from the TTY?


No need to be sorry, you should be able to grab it from the TTY with Termbin. Try this:

garuda-inxi | tb

That should give you a relatively short URL you can type into the forum for the inxi.

That’s a good thought. Try installing the LTS kernel as well.

garuda-update nvidia-lts nvidia-lts-headers

You can choose the LTS kernel in the advanced boot options of the Grub menu.

This probably succeeded because the VM can’t actually use your dGPU (unless you have two GPUs and set up GPU passthrough on the VM). If you can remove the dGPU from the equation for the metal install (for example, disconnect it), it would likely succeed as well.

It sounds like your issue is related to your GPU, but it is possible there are issues with the Wayfire spin as well. Unfortunately the maintainer of the Wayfire spin stepped back a while ago to focus on their career, and so far no one has stepped up to take over its maintenance. I’m not sure, but perhaps it has gone to seed a bit in the meanwhile. The team has been discussing dropping it for the next release.

If you specifically want to try Garuda Wayfire, other than the LTS kernel I would say try another ISO before you give up. Here are some more recent builds: https://iso.builds.garudalinux.org/iso/garuda/wayfire/. Technically those are still “testing” ISOs, but since the one you are trying to use is completely broken I’d say you’ve got nothing to lose.

If you just want to try Wayland in general and aren’t married to Wayfire, the KDE and Gnome DEs also offer very mature Wayland implementations and you may have better luck with that.

1 Like

How did you write the ISO to USB? What tool did you use? Arch-based distributions tend to be picky.

Thanks for the response! I will give this stuff a try shortly. Can’t remove the dGPU, running a Ryzen 3800X, no integrated gfx here =[
All great info, thank you so much! I definitely wanted to give wayfire a go, but if that’s the level of stability it’s at right now, duly noted, I will continue to follow it and try it every once in a while. Totally understandable of the maintainer, careers are important! Will have to give those other ISO builds and then KDE/Gnome with wayland after that. wayfire was the main thing that drew me in, but I’m always down to learn something new!

Thanks for the reply. I used balena etcher from Windows 10 onto a 32GB USB3.0 flash drive.

1 Like

Cool. That’s one less variable to ponder. :slight_smile:

Wayfire kinda works with proprietary driver on my notebook. Though it’s not always stable(for me it often crashes if I try to do something in remmina forwarded by ssh -Y from VM, even if it as simple as double click, but it’s not reproducable and needs further investigation). (Also make sure to install wf-shell or you will be greeted by empty screen and only tapping on windows key will work - it’ll activate grid view, made me puzzled for a while)

I had the same issue fixed them by using ibt=off kernel parameter during the boot,

1 Like

Good to know. That was the other kernel option I tried, the ibt=off one. I knew there was one other thing that I had tried. No luck for me though =[
I just burned the latest test build to a usb drive, and will try that shortly. if that doesn’t work, I also got the latest build (lts) for hyprland as well, so we’ll give that one a shot too.

Don’t forget this stuff:

I’m curious if Wayfire will launch from the TTY, and if not the error message may be a good clue.

Switching to the LTS kernel resolves many issues and is always worth a shot.

Don’t forget to send the inxi output. :wink:


Thank you for the reminder, i tried the latest build of the Wayfire iso, with the exact same results. However, i tried launching wayfire from the TTY and think i acheived success in getting to the desktop, but why? How can i fix this, and what should my next steps be? Im running garuda-update from the gui this time but running into the same conflicts (amtk vs libgedit-amtk and kvantum vs kvantum5 required by wayfire-desktop. I usually try avoiding removing the -desktop packages because it always seems to break something (or many things)

This would indicate an issue with the display manager, or perhaps with the way the display manager is launching the session. If you would like to troubleshoot the issue, examining the journal would be a good place to start.

systemctl status display-manager

In general I think that is a good idea! In this case however, you might not have a choice. The ideal fix would be for the dependencies to be updated on that meta package, but as I mentioned the Wayfire spin has been out of maintainership for a while so i don’t think anyone is working on that unfortunately.

To move past this obstacle, I would remove the package but do not remove the dependencies (ignore the dependency check).

sudo pacman -Rdd wayfire-desktop

Unfortunately all the dependencies of this package will now be orphans, but you can mark them as explicitly installed easily enough like so:

sudo pacman -D --asexplicit wayfire  wf-config  wf-shell  wcm  wf-recorder  wf-osk-git  waybar  mako polkit-gnome  gnome-keyring  swaylock  swayidle  grim  slurp  wcm  kanshi gammastep  qt5-wayland  qt5ct  kvantum-qt5  clipman  wl-clipboard brightnessctl  playerctl  wayvnc  wtype  wlogout  wofi  nwg-drawer nwg-look  bemenu-wlroots  dex  perl-file-mimeinfo  xdg-user-dirs-gtk xdg-utils  xdg-desktop-portal-wlr

I got that package list from running pacman -Sii wayfire-desktop. If you get errors on any of those packages I would just take them out, because I know for a fact some of those packages don’t exist anymore–for example, kvantum-qt5 has been gone from the repos for some time now.

From there I would do your best to get the package conflicts resolved so you can take a proper update. Be sure to take a look at this thread because there have recently been a lot of package name changes which have been complicating things a bit:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.