Wayfire keyboard layout

So 1st off, Dvorak is life. Though this system will not keep it so.

every new tab and window reverts back to qwerty and its driving me nuts.

I am using wayfire and I upgraded it to the ultamunt addition. If that matters,

The usb had a error on the load in stage, were every things is like ok, ok, ok, then pamac was all like error... Some one mentioned it might be simmiler issue some one had with a virtual machine?

I7 3820, 5600xt GPU by amd. 12 gigs of ram. Those are my specs encase this can help, ether me, or the devs.

6 posts were split to a new topic: Wayfire keyboard layout thread cleaning

What is this, is this related to my issue, what the hell dose this mean?

Note: Fcitx/IBus users may find these methods not work, or just work for a while, since they will try to control keyboard layout. Fcitx users need to set the first input method to be Keyboard - layout. See Fcitx#Input methods configuration. IBus users need to enable "Use system keyboard layout" option in Preference -> Advanced if using X configuration files, or manually specify the layout if using setxkbmap. See IBus#Non US keyboards[broken link: invalid section]

Wayfire is a rather new window manager that will very likely require some specific configuration. Check its documentation for details.

If you don't want to manually configure your WM then you might consider using an edition with a more standard DE like KDE or GNOME.

This is not a productive way to get help, as the first response from most people will be "that's fine, you do that".

5 Likes

Yah, sure. This thing needs to be put with bare bones if there are issues like this in it.

I tend to avoid cation signs, why I never looked at barebones longer then a second.

Well not like I dont have a iso waiting to be put to usb in case this just ended in vodka and frustrations.

Sad I seem to be out of vodka.

Is this a for-sure issue with the de?

Garuda isn't intended as a "gamer OS" or for "consumers". If there's a bug then you can help fix it. If you can't or don't want to do that then use something that works.

I don't understand the general viewpoint that because something doesn't work for one person then it's entirely broken and worthless.

You tell us. You're the one having the issue and have the non-QWERTY keyboard etc. in front of you.

2 Likes

I am just a basic user dude, As far as I can tell, it dont seem like a issue with my de. I ant ever had issues like this with compaq.

Also never said it is worthless, just said that this flavor at the very least is broken.

If it weren't for the fact that I cant find pamac or keep my layout as I want it, this might very well be up there with mint.

Also its a lie to say that this is not intended as a gaming distro, it made the top ten on gaming distros, and has flavors that directly support the thought in title and function. The gaming tab in the welcome menu only enforces that.

Besides those two issues, this might very well be a nice os in summery.

Ps. The iso in back up is also garuda, just with a different de.

No, I said it's not a "gamer OS", i.e. something for people who are used to games consoles. Anyone thinking that Garuda operates like an XBOX is going to find things difficult.

Not sure how that's related to the keyboard layout, but you can always try running pamac from a terminal. It's probably under a menu as "Add/Remove Software" or something similar.

* for you, when trying to set a Dvorak keyboard layout. You also haven't said how you tried to set the layout in the first place.

It might be worth booting the live installer environment again to make sure whether that works as expected, and whether some changes you made since installation have made a difference.

4 Likes

garuda settings keybored, also trued to mess with the language packages, but no luck.

In the boot usb the Dvorak did not work at all. Figured it was a quirk with the installer, have seen similure stuff that fixed itself after install.

1 Like

OK, so for Wayfire it does look like you'll have to configure the keyboard layout manually, e.g.:

Keep in mind Wayfire is a window manager, not a desktop environment, so "global settings" aren't configured or picked up in the same way.

3 Likes

So the arch wiki was the wrong place to send me after all... huh.

Well I will annoy myself with this for a bit, will send updates as I work on this.

Anyway I can ask the team to make gui for this, seems like some users might benit not fishing in a console for something this simple. Though i dont code, so I might be asking them to solve pi with a stick or somthing.

Meh, eather way thanks.

So umm this is what happen when I did that

First, please post text output as text.

Second, read all of the page I linked to find out where the configuration file is.

1 Like

funny you think that i did not do that.

Also copy and past dont work with me.

and lastly I gave up on this crap.

Used a diffrent flavor and now have new issuse that I need help with.

I was only going by the fact you typed the configuration file lines into the terminal. :man_shrugging:

3 Likes