Warning: config file /etc/pacman.conf option not recognized

I just updated my system and pacman was updated alongside it however in the installation lines and every pacman output since contains the line:

warning: config file /etc/pacman.conf, line 34: directive 'TotalDownload' in section 'options' not recognized.

Searching archlinux forums it seems this is an issue with pacman.conf itself however I cannot find anything wrong with my pacman.conf file:

pacman.conf
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc garuda-system
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
TotalDownload <== This fella here is apparently the problem. But its under the options section.
CheckSpace
ILoveCandy
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

[chaotic-aur]
#SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist

I read something about uncommenting lines but the posts I found involved a mirrorlist error and my error is with TotalDownload so I can still update but I get the warning. Both pacman-key --init and pacman-key --populate archlinux still give the warning. However the latter will download/update the keyrings.

inxi
System:    Kernel: 5.10.41-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=6bffdc79-d9cf-4de9-a3aa-58bbfb0e7a9c rw 
rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 intel_iommu=on i915.enable_gvt=1 kvm.ignore_msrs=1 
intel_pstate=disable 
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Laptop System: Dell product: G3 3590 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: Dell model: 0DKM3T v: A00 serial: <filter> UEFI: Dell v: 1.8.0 date: 11/11/2019 
Battery:   ID-1: BAT0 charge: 42.2 Wh (100.0%) condition: 42.2/51.0 Wh (82.8%) volts: 12.6 min: 11.4 model: BYD DELL M4GWP98 
type: Li-poly serial: <filter> status: Full 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
model-id: 9E (158) stepping: A (10) microcode: DE cache: L2: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399 
Speed: 800 MHz min/max: 800/2601 MHz boost: enabled Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b
class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Dell driver: nvidia v: 465.27
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191 class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:5521 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.1 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0401
Device-2: NVIDIA TU116 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 01:00.1
chip-ID: 10de:1aeb class-ID: 0403
Sound Server-1: ALSA v: k5.10.41-1-lts running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.28 running: no
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 3000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel
port: 3000 bus-ID: 04:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 0cf3:e009 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 1.12 TiB (81.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 NVMe WDC 512GB size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 rotation: SSD serial: <filter> rev: 20220012
temp: 44.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: ACM1 scheme: GPT
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 446.48 GiB (93.7%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 568 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 446.48 GiB (93.7%) fs: btrfs dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 446.48 GiB (93.7%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 446.48 GiB (93.7%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 297 Uptime: 17m wakeups: 3254 Memory: 15.43 GiB used: 3.47 GiB (22.5%) Init: systemd v: 248
tool: systemctl Compilers: gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1795 lib: 552 Shell: fish v: 3.2.2
running-in: konsole inxi: 3.3.04
1 Like

Well, pacman 6 got released into core Arch repos today, the option in question has been removed as pacman displays a progress bar by default now. You probably have some .pacnew/.pacsave in /etc which need to be processed.
Pacman-key has nothing to do with this so it cant fix the issue :wink:

4 Likes

I thought pacman took care of pacnew files automatically. I figured since pacman updated I needed a restart to fix the problem but it didn't.

Anyways I looked at the log and found a line that said pacman.conf installed as pacman.conf.pacnew. And the wiki says these files require manual intervention.

So I went into /etc and just removed the old conf and renamed the pacnew to just conf.

/etc/pacman.conf.pacnew => /etc/pacman..conf

3 Likes

Thats the correct way. Merging these files is usually the users responsibility as the config might have been changed (like in our case). Now make sure to include chaotic-aur in pacman.conf so you can use the repo, it misses in the default config :eyes:

1 Like

I deleted the old conf file. What is the chaotic-aur link again?

Just append this line:

[chaotic-aur]
Include = /etc/pacman.d/chaotic-mirrorlist
2 Likes

I also had this issue and did same as you but did not reboot yet lol. Thx for posting and will add the chaotic/aur line too thx to @dr460nf1r3 suggestion! Thanks all~

1 Like

Sorry noob here, I got as far as deleting the old one and renaming the new one, and I'm currently sudo nano'd into the new pacman.conf. Before I save it I want to confirm, should I just add those lines (chaotic mirror) to the bottom of the file, or does it go in a certain spot? Apologies if the answer is obvious this is my first time every doing something like this, I want to make sure I do it right :slightly_smiling_face:

Yes :slight_smile: :slight_smile:

1 Like

Running "sudo pacman -Syy" upon reboot crashed my system, as soon as it reached the "chaotic-aur" part my whole system desktop including the cursor froze for about 5 seconds then an infinite black screen. Had to turn it off and on again manually..I've had a similar issue using Manjaro but it was when opening the settings app- poof, instant crash.

I restarted again and ran "sudo pacman -Syy" and it worked fine this time. I'm glad it is ok now but I hope to god that is a singular issue and not a sign that I'm doing something wrong...just for a peace of mind, is this OS stable enough for a daily driver? I was excited for days now as I had the perfect setup with no crashes, now here I am a little paranoid :frowning_face_with_open_mouth: I love this distro so much however that I will exclude it from my "as soon as it breaks, next distro" rule. I'll give it a little more time as the games just run too good on this distribution.

Expect erratic behaviour if you updated recently but not rebooted yet as the new packages may not be in memory yet. Or if you've been running long enough and the package was one being actively used the issue might arise purely from the memory instance loading from the now updated pacakge and something going wrong. IMO garuda is the most stable arch based distro out here. I am talking about dragonized edition here as thats the one with the most packages. I attribute the instability I found in the other distros to the simple fact that they were missing packages I had no idea about causing behaviour I did not desire.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.