Want to disable and change latte elements [New to linux]

How do i go by disabling the side gesture thing that zooms out all my windows
seems to be one on the left side and in the top left corner that do similar things.

would also like to change the taskbar to be a more traditional one so i can remove the dock at the bottom of the screen.

Please follow the template and post your

garuda-inxi

Check the manuals of your desktop enviroment and the arch wiki in the internet.

2 Likes

The thing is i don't know what it's from... KDE? latte? something else? i have no idea where to look and start (referring to the side bar thing)

System:
Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bb85ff93-2aa3-435c-a0ff-49f612c25894 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=cca77cc5-c9e1-4835-9a8b-4793e6225f6f loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: MSI model: Z170A GAMING PRO CARBON (MS-7A12) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.A0
date: 07/04/2018
CPU:
Info: model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4327 high: 4400 min/max: 800/4400 scaling:
driver: intel_pstate governor: performance cores: 1: 4400 2: 4400 3: 4400
4: 4398 5: 4032 6: 4189 7: 4400 8: 4400 bogomips: 63999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915
v: kernel arch: Gen9 process: Intel 14n built: 2015-16 ports: active: none
empty: DP-1, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:1912 class-ID: 0380
Device-2: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: Gigabyte
driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1b82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 97 s-size: 1341x377mm (52.80x14.84")
s-diag: 1393mm (54.84")
Monitor-1: DP-0 pos: primary,left res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
Monitor-2: HDMI-0 pos: right res: 2560x1080 hz: 60 dpi: 97
size: 673x284mm (26.5x11.18") diag: 730mm (28.76") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
Audio:
Device-1: Intel 100 Series/C230 Series Family HD Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 3-2:2
bus-ID: 00:1f.3 chip-ID: 1532:1004 chip-ID: 8086:a170 class-ID: 0300
class-ID: 0403 serial: <filter>
Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
Device-3: Razer USA Gaming Controller [Raiju Ultimate Wired] type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp7s0 state: down mac: <filter>
Drives:
Local Storage: total: 8.9 TiB used: 26.61 GiB (0.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 960 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B7QCXE7 temp: 31.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung
model: SSD 970 EVO 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 1B2QEXE7 temp: 41.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWE150
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: FP2A scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 870 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 type: USB vendor: Generic
model: SD MMC MS PRO size: 29.28 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 26.61 GiB (1.5%)
fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 26.61 GiB (1.5%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-4: /var/log raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 26.61 GiB (1.5%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
used: 26.61 GiB (1.5%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.32 GiB used: 1.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 33.35 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdc3 maj-min: 8:35
Sensors:
System Temperatures: cpu: 43.0 C pch: 44.0 C mobo: N/A gpu: nvidia
temp: 53 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 19%
Info:
Processes: 285 Uptime: 14m wakeups: 0 Memory: 30.32 GiB
used: 3.84 GiB (12.7%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1991
lib: 554 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-06-26
Last full system update: 2022-06-26
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Latte-Dock

all i see is source code? they don't seem to even have a wiki... think i'll try linux again in the future, thanks anyway.

Most of the time you can right click on the dock to edit settings.

That's all I can say about KDE.

@malfestio Welcome to the Forum! :smiley:

It's not latte-dock, it's KDE settings.

Go to KDE System Settings.
Then Workspace Behavior > Screen Edges and remove the TOGGLE OVERVIEW from the left side screen action.

EDIT: Also, if you have more than one issue, plz open a help request for each one of them so things don't get mixed up within one thread.

3 Likes
sudo pacman -Rsu latte-dock

Then reboot. To install a "traditional one", right click on the desktop -> add panel -> Default Panel.

I think you are describing the "hot corners" feature.

System Settings -> Workspace Behavior -> Screen Edges. Tick the corner that is causing problems and choose "no action" for the hot corner.

1 Like

Ahh yeah that removed the screen edge thing tyty, just gotta sort out the taskbar now, i've made a default one and it's okay but needs some tweaking so it looks better.

other issue is now i've made a default taskbar, other windows like dolphin for example has it's titlebar removed as it's being merged with the latte taskbar that is now removed, if i maximise something i can't shrink the window again haha.

Could be related to the Window App Menu widget or Window Buttons (the widget!).
Remove those.

But again it's better to open a different thread, one for each of your issues. :slight_smile:
This thread is solved as your 2 issues from OP are solved.

not solved the title bar thing but doesn't matter, i won't be sticking with this i don't think and If you want me opening a post for every issue i've got with linux, i'd probably get banned for spamming lol

surround sound not working
mouse after reboot stops working
Bluetooth issues
DE feels like it's running at fluctuating frame paces / fps
can't remove some things i've installed via yay
dragging icon from taskbar to desktop (steam) crashes kde / DE
wallpapers gets removed after reboot
applying other themes just doesn't work / apply everything even after reboot (especially transparency)
log in screen on my other monitor is a graphical mess

i could go on haha

thanks for the help though but this isn't for me not yet anyway.

Actually yes, these are all worth specific threads. :slight_smile:
Sorry you have so many, it's not supposed to be like that.

However, since this is a Forum and not a chat, it's important that every thread hosts one issue so that people focus on one thing, don't get side tracked and future people searching for the same issues are able to find something.

If we were to discuss 20 issues in one thread, no one would find anything and everyone would get confused. :slight_smile: Besides, it would be impossible to write a topic subject that would identify all 20 issues...

EDIT: Tip: Some of your issues in the above list are known and googling for them will yield you to solutions.

2 Likes

Try some other distos before you give up on Linux, like Pop_OS or Linux Mint. Those two in particular are meant to work well out of the box, and not require as much "tinkering".

2 Likes

Drivers and the acompanying software are all written specifically for Windows by hardware manufacturers. For most manufacturers Linux isn't even a consideration, or at best an afterthought. That Linux even works at all without proper support from most manufacturers is a minor miracle.

My experience with Windows over the years was that it was a very buggy OS in many ways. The major difference being when you encounter bugs with Windows the user rarely has the ability to correct these bugs themselves due to Windows proprietary locked down nature.

From the tone of the OP's posts on this thread, I'd expect what they are looking for is a smart appliance such as the new TV's that respond to voice commands and eavesdrop on every word spoken in the household. This is what the world is heading towards, because that is exactly what the average user wants these days. Users expect to have no hands on interactivity with technology. The average user today simply wants to tell their smart appliance what they want served to them on a daily basis without having to get their hands dirty.

This is what today's masses want.

This is not what Linux is about.

Linux is not for you.

Buy a smart appliance if you don't want to tinker with your computer's OS.

The topic is marked solved, so I guess we can close it out now. :wave:

3 Likes