Wallpaper is displayed incorrectly and "Desktopverwalting ist nicht aktiv" when opening desktop settings

I installed the Garuda Qtile version with Variety today. I am using two monitors, one smaller and my main monitor. The resolution on them differs and my smaller monitor is always considered the primary monitor. I already fixed that problem since I am already used to it, but the wallpapers are still displayed incorrectly. My main monitor (1920x1080) tries to display the wallpaper for the smaller one and my other monitor (1440x900) tries to display to wallpaper for the primary monitor which looks very broken.

When trying to start the desktop settings I get Desktopverwalting ist nicht aktiv. I don't know what it is in english (probably something like Desktop manager is not active) so I can't really google my problem. Does someone know how to fix this issue? I probably just need to switch the order of the monitors somewhere somehow.

Maybe you can start here, the app that changed the wallpaper.

and welcome to the forum :slight_smile:


Thank you for your answer. I looked it up and found ~/.config/qtile/scripts/autostart.sh. When I comment out the line saying feh, there is no wallpaper anymore which makes sense. If I then use feh manually the wallpaper gets set correctly. Which means that something after autostart.sh changes the alignement of the monitors. Is there a way to execute feh after that?

This still wouldn't solve the issue with variety, but it would be a nice start.

I don't have multi monitor setup so I can't really help but you can try putting feh on last line of ~/.config/qtile/scripts/autostart.sh to executive it after everything. If it's not help you can try creating a new autostart file to executive feh seperately.

1 Like

you can try putting feh on last line of ~/.config/qtile/scripts/autostart.sh to executive it after everything

I actually already tried that, but it changes nothing. The program which also handles the monitor settings is probably configuring xrandr. So it would be necessary to run feh after that configuration, since feh works completely fine when I execute it manually after booting.

I didn't really fix that issue, but when I comment out the line with feh and add run variety & at the end. It works completely fine. There is still the Desktopverwaltung ist nicht aktiv message when I try to open the desktop settings. But as long as I don't use them everything works fine.

So if you have the same issue: download variety and add run variety & to ~/.config/qtile/scripts/autostart.sh

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.