Wallpaper Engine Error KDE

When I set the wallpaper engine de scence type as wallpaper, the background is only black, how can I fix it?

System:
  Kernel: 5.15.75-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=0b228500-941e-42be-8895-b8d0589c5140
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 45.3 Wh (100.0%) condition: 45.3/47.2 Wh (96.0%) volts: 16.4 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    level: v4 note: check built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
    microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3717 high: 4162 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3357 2: 3593 3: 4162 4: 3878 5: 3994 6: 4078 7: 3869 8: 3710
    9: 3504 10: 3646 11: 3486 12: 3329 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of 2022-10)
    arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1
    bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:3 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144 dpi: 128
    gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound API: ALSA v: k5.15.75-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iw
lwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 70.72 GiB (15.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P2CR048 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 70.68 GiB (29.6%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 43.8 MiB (45.7%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 70.68 GiB (29.6%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 70.68 GiB (29.6%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 70.68 GiB (29.6%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 1.69 GiB (11.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 60.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 438 Uptime: 27m wakeups: 1 Memory: 15.41 GiB used: 12.59 GiB (81.7%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1712
  libs: 406 tools: gnome-software,octopi,pamac,paru Client: shell wrapper v: 5.1.16-release
  inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2022-09-08
  Last full system update: 2022-10-29
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            dev-binderfs.mount systemd-networkd-wait-online.service 

PLASMASHELL REPLACE ->

kf.plasma.quick: Applet preload policy set to 1
qml: JSON.parse: Parse error
qml: load backend: backend/Scene.qml
INFO main looper started
INFO render looper started
INFO source: /home/muktesit/.local/share/Steam/steamapps/workshop/content/431960/1552273169/scene.json
file:///home/muktesit/.local/share/plasma/wallpapers/com.github.casout.wallpaperEngineKde/contents/ui/backend/
Scene.qml:37:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this s
yntax instead: function onFoo(<arguments>) { ... }
qml: JSON.parse: Parse error
qml: PlasmaExtras.ScrollArea is deprecated. Use PlasmaComponents3.ScrollView instead.
INFO gl: OpenGL version 4.6 loaded
INFO gl: OpenGL vendor string: Intel
INFO gl: external tex using optimal tiling
INFO set swapchain image size: 1920x1080
qml: JSON.parse: Parse error
org.kde.plasma.containmentlayoutmanager: Error: cannot change the containment to AppletsLayout
QProcess: Destroyed while process ("/bin/sh") is still running.
qml: ----python helper connected----
INFO vulkan device: Intel(R) UHD Graphics (TGL GT1)
INFO new buffer block(0x7f4838398f40), size: 2097152, index: 0 / 1
INFO new buffer block(0x7f4838399030), size: 2097152, index: 0 / 1
INFO loading scene: /home/muktesit/.local/share/Steam/steamapps/workshop/content/431960/1552273169/scene.json
INFO muted, not init sound device
ERROR PhysicalFs.h:46 "/home/muktesit/.local/share/Steam/steamapps/common/wallpaper_engine/assets" not exists
ERROR SceneWallpaper.cpp:389 Mount assets dir failed
qml: QQuickGridView_QML_225(0x561d0fc3def0)```

Check the path

For app bugs open issue on

2 Likes

Will "video" type wallpapers work if the path is not correct?

Lol no, no wallpaper can work if path is incorrect.

You should copy the required video wallpaper to ~/Videos or say, Desktop and then choose it as wallpaper.

Also, can you please tell us what exactly are you trying to do, if the above thing doesn't work for you?

2 Likes

I installed Wallpaper engine with proton and now there is no problem. Settings - > Steam Play -> Check 'Enable Steam Play for all other Title', then select the last version of proton. Press 'Ok' button, restart your steam and there you go, you are now enabled to install wallpaper engine.

(I don't know if this feature has on every single linux version. but on ubuntu it works well.)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.