Wake On Lan doesn't work

Hi guys, I have an Asus laptop in which the WOL function does not work, having obviously already enabled it in the Bios, currently I am dual boot with Windows, thanks in advance.

Not anywhere near enough info to even take a wild guess.

Please post:

inxi -SMa; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" && echo "System install date $(head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11)" 

Plesae do not post pictures for terminal outputs.

Pictures instead of text on technical help threads is not the preferred way to post logs or command outputs. Pics are often hard to read, and you can’t copy the output into an internet search engine to find answers to an issue. Pictures also waste bandwidth and storage space on the forums servers unnecessarily. All outputs should be posted on the forum as text, (unless there is absolutely no other way of capturing the text). This makes it far easier to get your technical issue resolved.

``` <=here
three backticks before and after command output
``` <=here

Please post all requested outputs and answer all questions if you desire assistance.

Have you used this computer with Linux before?

Was WOL working on any version of Linux before?

If yes on which distros, which kernels, and how long ago?

Have you performed any searches online regarding your issue?

What information have you found out about your issue?

I await your answers, so that I may be able to give you more information than you provided me with.

1 Like
    System:    Host: hydra Kernel: 5.9.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e467a017-ceaf-4bf3-8ee0-5e3793756a5c 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: ASUSTeK product: P552LA v: 1.0 serial: <superuser/root required> 
           Mobo: ASUSTeK model: P552LA v: 1.0 serial: <superuser/root required> UEFI: American Megatrends 
           v: P552LA.204 date: 08/11/2015 
  Model: "Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter"
  Driver: "rtl8821ae"
  Device File: wlp3s0
  Link detected: yes
    Driver Status: rtl8821ae is active
    Driver Activation Cmd: "modprobe rtl8821ae"
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8169"
  Device File: enp2s0
  Link detected: yes
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Model: "Realtek Bluetooth Radio"
  Hotplug: USB
  Driver: "btusb"
  Speed: 12 Mbps
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
System install date 2020-11-11

Yes, with Arch
No
Yes, only things related with systemd

It is possible that a power saving configuration utility (such as tlp or another) is causing this problem. If the power saving utility is misconfigured it can disable Wake On LAN. The easiest way to troubleshoot this is to temporarily disable whichever power saving utility you are using and then reboot and test for functionality improvement. You can uninstall your power saving utility, but on a laptop it is better to try to find the configuration setting that is causing the problem and change it.

If a power saving misconfiguration is not causing your problem then refer to the documentation on the Archwiki and implement the methods recommended there:

Have you also tested out both the r8168 and r8169 drivers to see if things improve. Generally (but not always) the r8169 kernel module is the better choice for this adapter. As the r8169 driver is included in the kernel, it would also be a good choice to test various different kernels (starting with the LTS kernel}

There is also always the possibility that Windows is messing things up for your Linux install. Windoze has the nasty habit of disabling network stuff on the hardware level that persists even after a shut down. Bad Windows.

Oh ya, I forgot there is a WOL package in the AUR. You could test it out. It's never worked for anyone on any of the WOL help request threads I've responded to, but I guess there's always a chance you'll be the first. :smile:

Good luck with your issue.

1 Like