W3m image doesn't support konsole

as far as i know konsole supports images on w3m. today i tried w3m google.com/images but i see no pictures. there were black spaces.
tried on xterm everything was fine. as i am on qtile, do i have to install extra packages to work in konsole ?

garuda-inxi

System:
Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b8a56a97-7db6-4f32-97d0-f9e7113dada4 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: Qtile v: 0.21.0 wm: LG3D dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Vmware System: VMware product: VMware Virtual Platform v: N/A
serial: Chassis: No Enclosure type: 1 serial: N/A
Mobo: Intel model: 440BX Desktop Reference Platform serial: N/A
BIOS: Phoenix v: 6.00 date: 05/19/2017
CPU:
Info: model: AMD Ryzen 3 3100 bits: 64 type: MCP SMP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 2x cores: 2 smt: cache:
L1: 2x 128 KiB (256 KiB) desc: d-2x32 KiB; i-2x32 KiB
L2: 2x 1024 KiB (2 MiB) desc: 2x512 KiB L3: 2x 16 MiB (32 MiB)
desc: 1x16 MiB
Speed (MHz): avg: 3593 min/max: N/A base/boost: 3600/30000 volts: 3.3 V
cores: 1: 3593 2: 3593 3: 3593 4: 3593 bogomips: 28746
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.20.0.0 ports:
active: Virtual-1 empty: Virtual-2, Virtual-3, Virtual-4, Virtual-5,
Virtual-6, Virtual-7, Virtual-8
bus-ID: 00:0f.0 chip-ID: 15ad:0405 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 compositor: Picom v: git-c4107
driver: X: loaded: vmware unloaded: modesetting alternate: fbdev,vesa
gpu: vmwgfx display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
s-diag: 583mm (22.95")
Monitor-1: Virtual-1 mapped: Virtual1 res: 1920x1080 hz: 60 size: N/A
modes: max: 1920x1080 min: 640x480
Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371
v: kernel bus-ID: 02:02.0 chip-ID: 1274:1371 class-ID: 0401
Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine
type: network bridge driver: N/A modules: i2c_piix4 port: N/A
bus-ID: 00:07.3 chip-ID: 8086:7113 class-ID: 0680
Device-2: Intel 82545EM Gigabit Ethernet
vendor: VMware PRO/1000 MT Single Port driver: e1000 v: kernel port: 2000
bus-ID: 02:01.0 chip-ID: 8086:100f class-ID: 0200
IF: ens33 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 50 GiB used: 9.29 GiB (18.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: VMware model: Virtual S size: 50 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: N/A rev: 1.0
scheme: MBR
Partition:
ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 9.29 GiB (18.6%)
fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 50 GiB size: 50 GiB (100.00%)
used: 9.29 GiB (18.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
ID-3: /var/log raw-size: 50 GiB size: 50 GiB (100.00%)
used: 9.29 GiB (18.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
ID-4: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%)
used: 9.29 GiB (18.6%) fs: btrfs block-size: 4096 B dev: /dev/sda1
maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.73 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 209 Uptime: 13m wakeups: 1198 Memory: 7.73 GiB
used: 1.03 GiB (13.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1170 lib: 306
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date: 2022-06-29
Last full system update: 2022-06-29
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: No/Undetected
Snapshots: Snapper
Failed units: bluetooth-autoconnect.service

How do you know it is supported if it didn't work when you tried it?

What requirements does w3m have?

1 Like

i used garuda dragonized before so i had konsole pre installed. there i used w3, i remember it worked. again from neofetch wiki it is said that konsole supports w3m-img.