W key not working while yakuake active

Hey,

I'm unable to type a w in any application while yakuake is on, regardless of whether it's open. The keypress does register in "Keyboard Visualizer" and works fine if I kill yakuake.

I've looked at yakuakes shortcuts and can't find any that should stop the key.

Any help is greatly appreciated!

Obligatory garuda-inxi

System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=593ea6ed-5a5a-4c63-8805-c504826e92b7 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: TravelMate P214-52G v: V1.27
serial: <superuser required>
Mobo: CML model: Timpani_CM v: V1.27 serial: <superuser required>
UEFI: INSYDE v: 1.27 date: 05/26/2021
Battery:
ID-1: BAT1 charge: 12.9 Wh (35.5%) condition: 36.3/53.0 Wh (68.6%)
volts: 13.6 min: 15.4 model: PANASONIC AP19B5L type: Li-ion
serial: <filter> status: discharging
CPU:
Info: model: Intel Core i7-10510U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3148 high: 4681 min/max: 400/4900 scaling:
driver: intel_pstate governor: performance cores: 1: 4001 2: 4449 3: 4395
4: 4102 5: 722 6: 1238 7: 4681 8: 1596 bogomips: 36799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics]
vendor: Acer Incorporated ALI driver: i915 v: kernel ports: active: eDP-1
empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9b41
class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX230] vendor: Acer Incorporated ALI
driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 1
speed: 2.5 GT/s lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 02:00.0
chip-ID: 10de:1d11 class-ID: 0302
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:2
chip-ID: 04f2:b64f class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x14d4 built: 2016 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.0.2
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-10:5 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 16.52 GiB (3.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN520 SDAPNUW-512G-1014 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20110000 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 270.23 GiB size: 270.23 GiB (100.00%)
used: 16.23 GiB (6.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%)
used: 24.6 MiB (4.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 150.54 GiB size: 150.54 GiB (100.00%)
used: 280 MiB (0.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 270.23 GiB size: 270.23 GiB (100.00%)
used: 16.23 GiB (6.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 270.23 GiB size: 270.23 GiB (100.00%)
used: 16.23 GiB (6.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C pch: 55.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 286 Uptime: 10m wakeups: 2 Memory: 15.46 GiB
used: 2.63 GiB (17.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1705 lib: 512 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-02
Last full system update: 2022-05-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome to the Forums!

That's a weird issue.
Was it working fine before or as soon as you installed Yakuake the W stopped working?
I use Yakuake for years all the time and never had such issues.
What about KDE Global Shortcuts? Through System Settings.... you could check if you have it set somewhere.

1 Like

Thanks,

Yeah, it's a weird issue, I've used yakuake in the past as well without any problems. I've checked my global shortcuts as well, couldn't find anything strange. And it should be yakuake since it goes away if I quit it.

I installed Garuda just a few hours ago and after a full system update installed yakuake, well reinstalled, since apparently it comes with.

I doubt Garuda comes with Yakuake I have to install it all the time.

Are you using Wayland or X11?
EDIT: X11, I can see above, sorry.

Huh, well, it was preinstalled, at least if I didn't misread. I should be using X11, I've got the latest "KDE Dragonized Gaming Edition", installed from garuda-dr460nized-gaming-linux-zen-220428.iso.

Edit: No worry (:

Ok maybe for the Gaming Edition it comes pre-installed.

If that's the case, then my question is for Garuda Team or someone else who would know the answer: If Yakuake is pre-installed on Gaming Edition, is there any custom settings applied to it by Garuda?

It's got a fancy theme, I can say that at least. And on top of the default-default Default [Read-only] profile, there's an additional "default" Garuda (default) profile. The issue occurs regardless of which I use.

Edit: It looks to be a profile most likely shared between kconsole and yakuake, and possibly more.

Have you defined a specific key to show/hide Yakuake?
I use it with the default F12 and I'm sure it works normally, but I don't have access to my personal laptop at the moment to test any different configuration.
The reason I'm askng is only due to this strange but somewhat similar KDE bug report:
https://bugs.kde.org/show_bug.cgi?id=448311

I have changed the keybind to §. And now that I try resetting to defaults, w works again. Leading me to think that I accidentally changed some other keybinding that I missed, however, if I again change the open/close keybind to §, w seizes to work.

I'd safely say that having the open/close keybind as § is what's causing the problem.

Could be another Yakuake bug? Either way you know what to do, glad it works. :slight_smile:

Yeah, sad that I can't have it as such, and I'd say it's a pretty strange bug.

Thanks to the both of you!

2 Likes

Check your keyboard layout(s) in use, in case a wrong keyboard is set and creates this.

locale
localectl
grep . "$HOME/.config/kxkbrc"
2 Likes

Fyi, it comes preinstalled on default non-gaming Dragonised edition

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.