Vscode Bug Dragonized Edition

When Ever I try to use any Vs code I can not access the menu bar in the top panel .

Have Tried Reinstalling libdbusmenu-glib as specified on Arch Wiki But to no avail .

It is Still Not Working Kindly Assist me on the same .
Sorry For the bad English and the errors

Its working for me, which version are you using? There are quite a few (im using visual-studio-code-insiders) :smiley:

2 Likes

Im using the bin release from aur.

Try installing the mentioned version. If it works correctly this is specific to this particular -bin package.

1 Like

Still No Luck . This one was from the chaotic AUR .

Tried visual-studio-code-insiders (1605526631-1)

1 Like

Did you already reboot? I was experiencing this 1-2 times in the last weeks too (for another app tho), a quick reboot fixed it. Didnt find out why this happened until now. Very random occurance :roll_eyes:

2 Likes

I Just Did :sob: but it's still the same . I can't figure out a fix .

Have you tweaked your latte dock somehow or it's the stock that came out of the box with garuda ?

1 Like

Did a quick search, gconf is mentioned as dependency, you might check if thats installed too.

Another thing to do which might give hints is running

code --verbose 

and pasting the output to bin.garudalinux.org.

2 Likes

I Tried Installing gconf . But still no use . I did run code --verbose but the output is like really huge ..

Wait until it stops spilling out log messages and just copy the whole thing to our privatebin, its there for this exact reason :stuck_out_tongue:

1 Like

Yeah I'm kind of new to the forums . Where do I save to submit the logs ?
:sweat_smile: :sweat_smile: :sweat_smile: :sweat_smile:

Sent it to private bins :slight_smile:

Once you save the output to the website you get a link which you need to share here, sorry shouldve mentioned that too :smiley:

1 Like

Here It Is :slight_smile:

Well I looked at the output but couldnt really find anything useful :neutral_face:
Apart from removing / adding the window menu plasmoid to latte again & restarting the appmenu service in Plasma settings Im quite out of ideas, hopefully someone else knows what to do :slight_smile:

1 Like

I'll Try to do that. It's my first time on KDE . I've been on gnome and awesome mostly so it's kind of difficult to wrap my head around all this :frowning:

1 Like

:wave:

On the login screen, change desktop seesion from wayland to plasma. (Xorg)
Wayland is a bit buggy right now.

Sorry for inconvenience.

4 Likes

Thanks a Lot !!
IT WORKED !!!

3 Likes

Oh well. LOL :joy:
I have added plasma-wayland-session to package conflicts in garuda-dr460nized-settings so people will be forced to uninstall this when updating. Waaay to many bugs caused by this. :sweat_smile:
Im still wondering why Wayland seems to be the default for many people, just did an installation on my old T430 which loads Xorg just fine :thinking:

4 Likes