VR not working | Oculus Quest 2

Hi there,
I find myself in the same boat. I installed Garuda a few weeks ago and love it except for my VR not working (Oculus Quest 2). I use ALVR and successfully connect to my computer. My headset and controllers show up in SteamVR. When I try to start a game, my headset does the pop-up that it's loading the game, but never loads on the headset. The game starts on the computer though. If I tell my Quest 2 to exit the game, nothing happens. I am using Proton experimental, but I've also tried Proton GE-Custom. Does anyone have any ideas?


```text
System:
  Kernel: 5.18.15-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=55d89f94-c77c-4b29-859f-89be7108e791
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=ced131ae-8a3c-4c49-9437-fa820b4f634f loglevel=3
  Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z490-P v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 0605 date: 04/13/2020
CPU:
  Info: model: Intel Core i5-10600K bits: 64 type: MT MCP arch: Comet Lake gen: core 10
    built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB desc: d-6x32
    KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4603 high: 4617 min/max: 800/4800 scaling: driver: intel_pstate
    governor: performance cores: 1: 4600 2: 4600 3: 4600 4: 4600 5: 4614 6: 4604 7: 4602 8: 4600
    9: 4617 10: 4600 11: 4600 12: 4606 bogomips: 98397
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Gigabyte driver: nvidia v: 515.57
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of 2022-07) arch: Turing
    code: TUxxx process: TSMC 12nm built: 2018-22 bus-ID: 0000:01:00.0 chip-ID: 10de:1f06
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 5760x2160 s-dpi: 94 s-size: 1557x584mm (61.30x22.99")
    s-diag: 1663mm (65.47")
  Monitor-1: DP-2 pos: bottom-r res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.04x11.26")
    diag: 584mm (22.99") modes: N/A
  Monitor-2: DP-5 pos: primary,top-left res: 3840x2160 hz: 30 dpi: 85
    size: 1150x650mm (45.28x25.59") diag: 1321mm (52.01") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 515.57
    direct render: Yes
Audio:
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:06c8
    class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.15-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A
    driver: r8169 v: kernel port: 3000 bus-ID: 0000:03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8
    bus-ID: 1-2:2 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
  Hardware-1: Intel Comet Lake PCH-H RAID driv
er: intel_nvme_remap v: N/A port: 5020
    bus-ID: 0000:00:17.0 chip-ID: 8086:06d6 rev: class-ID: 0104
Drives:
  Local Storage: total: 7.3 TiB used: 292.12 GiB (3.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 004C temp: 43.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Hitachi model: HDT721010SLA360 size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: A39D scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: CC26 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD20EZAZ-00GGJB0 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A80 scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 919.21 GiB size: 919.21 GiB (100.00%) used: 292.12 GiB (31.8%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 919.21 GiB size: 919.21 GiB (100.00%) used: 292.12 GiB (31.8%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 919.21 GiB size: 919.21 GiB (100.00%) used: 292.12 GiB (31.8%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 919.21 GiB size: 919.21 GiB (100.00%) used: 292.12 GiB (31.8%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.24 GiB used: 1.8 MiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 34.36 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nvidia temp: 51 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 289 Uptime: 6m wakeups: 0 Memory: 31.24 GiB used: 2.78 GiB (8.9%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages:
  pacman: 1964 lib: 545 Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.5-1):
  System install date:     2022-07-18
  Last full system update: 2022-08-01
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            
```

Which one? Only one particular game or any game you try?

I just move it :slight_smile:

And

:slight_smile:

2 Likes

I've tried SuperhotVR and Ultrawings so far

UPDATE: I found a solution. Right click the game in Steam, Properties, in the General tab under Launch Options type -vrmode oculus

Thank you all for a great distro.

1 Like

Not to be a Debbie-downer...I always find self-solves interesting. Especially on posts with few responses. I'm glad the OP found the answer as quickly as it happened.

These type posts may indicate a perceived short-lived "panic" mode. Or maybe not. That's alright. I often find the solution to my problems--Linux or IRL--by writing them down. It's as if the written form is made more viable. (And then I go do something else--anything else.) It is as if the act allows the brain to focus. I'm not a psychologist, though it has been a life-long practice in another realm.

OP has done nothing wrong. They found the solution. This is just a late night respective.
:smiley: :smiley: :smiley:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.