Volume up, Down and mute stopped working

Hi there, I am fairly new to linux, I am using Garuda KDE Dr460nized.

So, Volume down, up and mute keys aren't working anymore, they used to be working and suddenly stopped (Fn + F1,F2,F3 keys).

The rest of the function keys works normally, and these three used to work but suddenly they just stopped.

how can I solve this?

Here is my terminal output.

System:    Kernel: 5.13.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5a31376c-873a-4e8e-bc94-fc848ec1ba42 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=937e0c91-c630-428c-b79a-269814b701cb loglevel=3 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506LI_FX506LI v: 1.0 
serial: <filter> 
Mobo: ASUSTeK model: FX506LI v: 1.0 serial: <filter> UEFI: American Megatrends v: FX506LI.309 
date: 02/02/2021 
Battery:   ID-1: BAT1 charge: 16.9 Wh (39.6%) condition: 42.7/48.2 Wh (88.7%) volts: 10.7 min: 11.9 
model: ASUS A32-K55 type: Li-ion serial: N/A status: Discharging 
CPU:       Info: Quad Core model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake family: 6 
model-id: A5 (165) stepping: 2 microcode: EA cache: L2: 8 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39999 
Speed: 3399 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 3399 2: 4461 3: 3601 4: 3400 
5: 3402 6: 4232 7: 3833 8: 4163 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915 v: kernel 
bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300 
Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK driver: nvidia 
v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300 
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 1-7:2 
chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Sound Server-1: ALSA v: k5.13.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus-ID: 00:14.3
chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 89.95 GiB (7.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-256G-1002
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21106000 temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-22Z10T1 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A04 scheme: MBR
Partition: ID-1: / raw-size: 70 GiB size: 70 GiB (100.00%) used: 17.79 GiB (25.4%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
ID-2: /boot/efi raw-size: 512.7 MiB size: 511.7 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 72.15 GiB (72.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 70 GiB size: 70 GiB (100.00%) used: 17.79 GiB (25.4%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
ID-5: /var/tmp raw-size: 70 GiB size: 70 GiB (100.00%) used: 17.79 GiB (25.4%) fs: btrfs
dev: /dev/nvme0n1p8 maj-min: 259:8
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: swap-2 type: zram size: 7.61 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 60.0 C mobo: 27.8 C
Fan Speeds (RPM): cpu: 0
Info:      Processes: 302 Uptime: 21m wakeups: 1 Memory: 7.61 GiB used: 3.65 GiB (48.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1368 lib: 339
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I would think testing alternate kernels would be your best bet.

I'd start with the following kernels in this order:

linux-lts 
linux 
linux-mainline
linux-hardened
linux-next-git  

Welcome to the forum.

3 Likes

First off, thanks for the reply.

Secondly, I changed kernel to linux-lts and while doing that, I noticed that the audio volume entry of the system tray was missing.

When i re-enabled it (for some reason it was disabled), the keys worked on both kernels (zen and lts).

Didn't see this one coming...

How did you do it?

1 Like

There is a little arrow next to the icons in the top dock, click it, The notification and status menu will appear, click in the little icon next to the title (If you hover over it with the mouse it will say configure system tray settings )

System tray settings window will appear, select entries from the column on the left side, this is where you can enable or disable any icon in the latte dock.

Strange thing that this happened suddenly. This setting does not make H/W function keys to work, while they don't. It's a GUI tool to change volume. H/W function keys act also as a tool. They can't work if the real controller doesn't.

But as you said. Strange things and I didn't see that coming... :laughing:
It could be the kernel change that woke up a sleeping device.
If that's correct, you should prepare yourself with some reading on PM and how to fix/workaround waking up (not letting sleep) some device.

I hope you won't need it :grinning_face_with_smiling_eyes:

3 Likes

To be honest, the only logical explanation I have is, while I was enabling another icon and scrolling up and down, I accidentally scrolled through the options,choose disabled and didn't even notice it.

Yeah, I thought so too, but here is the thing, on changing the kernel, I did try the keys multiple times and the didn't work same as with the default zen kernel. They only worked when I enabled the icon back again, which makes no sense since it's a gui tool.

Anyways, it's working fine up till now and not like it's the first random strange tech shenanigans I witnessed through the years :laughing:, but so far I am enjoying my time with garuda so much.

if that happens again I will take a look at the power management topic in the wiki, but I hope it won't.

1 Like