VLC always defaults to 100% volume

My volume in VLC is always defaulting to 100% no matter what I do with pavucontrol. I have read many posts on how to get the default to be something like 70% but I haven't been able to get it to work. Any suggestions are welcome.

It seems to be that pulseaudio is supposed to set the default for VLC but it isn't working for me.

System:
  Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=746085a3-1efd-44d0-9e3f-bea3af666d4d rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 nvidia-drm.modeset=1
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: X470 AORUS ULTRA GAMING v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: X470 AORUS ULTRA GAMING-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F3
    date: 08/08/2018
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 2671 high: 3906 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3901 2: 3903
    3: 3904 4: 3906 5: 1856 6: 1752 7: 2155 8: 2015 9: 2365 10: 2195 11: 1916
    12: 2184 bogomips: 86399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI
    driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
    chip-ID: 10de:1f02 class-ID: 0300
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-10:7 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Display: wayland server: X.Org 1.21.1.4 compositor: gnome-shell driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x2520 s-dpi: 96 s-size: 910x667mm (35.8x26.3")
    s-diag: 1128mm (44.4")
  Monitor-1: XWAYLAND0 res: 3440x1440 hz: 60 dpi: 109
    size: 800x340mm (31.5x13.4") diag: 869mm (34.2")
  Monitor-2: XWAYLAND1 res: 1920x1080 hz: 60 dpi: 47
    size: 1040x590mm (40.9x23.2") diag: 1196mm (47.1")
  OpenGL: renderer: NVIDIA GeForce RTX 2070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.47.03 direct render: Yes
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-10:7 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    port: f000 bus-ID: 06:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.75 TiB used: 37.66 GiB (1.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 PRO 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B2QEXP7
    temp: 51.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 2T00
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 00RL scheme: GPT
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 37.66 GiB (2.0%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 580 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 37.66 GiB (2.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 37.66 GiB (2.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 37.66 GiB (2.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 62.81 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 379 Uptime: 20h 18m wakeups: 1 Memory: 62.86 GiB
  used: 10.69 GiB (17.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1544 lib: 398 Shell: fish v: 3.3.1
  running-in: tmux: inxi: 3.3.12
e[1;34mGaruda (2.5.4-1):e[0m
e[1;34m  System install date:e[0m     2021-12-26
e[1;34m  Last full system update:e[0m 2022-02-02
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m bluetooth-autoconnect.service 

Firstly, check which output VLC is set to use.

Secondly, I seem to remember that the VLC volume control is independent of the system settings, so adjust it via the VLC GUI.

2 Likes

In case it may help you to troubleshoot, my vlc always defaults to 0% volume.
Similarly, volume set in pavucontrol is not remembered.
Nothing relevant found in ~/.config/pulseaudio-ctl/config, ~/.config/pavucontrol.ini, ~/.config/vlc/vlcrc, nor (as far as I can tell) anywhere, but I just run rg over /etc and /home skimming results at light speed so I may have missed it.
I see in vlc preferences, "audio" tab, there is "Volume"/"Always reset audio start level to" set at 100% but unchecked and disabled (cannot be toggled).
Note, my system is Sway not Gnome.
edit: I have two possible outputs, the laptop speakers and those of the TV I use as external monitor on HDMI. The output is remembered, but the volume level is not, for neither of the two.

3 Likes

It should be as simple as setting volume in vlc media player itself. You can simply use up and down keys to adjust volume in vlc, and it should save it for next time by default, unless you do some configurations yourself

Also, in preferences>audio, there should be an option to adjust default audio level.

That's what I thought too but it seems not to be the case.
Only perhaps relevant thing I found online is this reddit thread which refers to an older vlc version.
edit: vlc does not remember the volume, and the volume slider moves in sync with pavucontrol's.

1 Like

Use mpv :slight_smile:

Summary
mpv 0.34.1-dirty Copyright © 2000-2021 mpv/MPlayer/mplayer2 projects
 built on UNKNOWN
FFmpeg library versions:
   libavutil       56.70.100
   libavcodec      58.134.100
   libavformat     58.76.100
   libswscale      5.9.100
   libavfilter     7.110.100
   libswresample   3.9.100
FFmpeg version: n4.4.1

image

1 Like

Better yet, use Smplayer with MPV as the back end. While VLC is super popular in the Windows world, it tends to have a lot of bugs from my experience in comparison to Smplayer.

3 Likes

mpv works fine but I like to use vlc for albums because it lists the tracks the way I like it.

The cli version of mpv isn't bad though.

EDIT: Changing to ALSA output does work. I just tried it again. I had to restart VLC to see that it worked as expected. See screenshot.

Original comment: Changing the volume in vlc doesn't help me. Even when I change the output with ALSA which does allow changing the default volume. Even with ALSA the volume default doesn't work. VLC always defaults to 100%.

2 Likes

I also have multiple possible outputs.

I was able to find a solution for me, although I don't understand why just using "Automatic" output module doesn't work.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.