VivoBook (ASUS) can not for some reason get my RGD going?

Hi everyone…

Garuda is doing great just have a minor issue of not having my keyboard backlight going…which isn’t massive but would be nice to see…

Does anyone have a fix for this…?
Tried most of the ones in the add and remove (Including AUR) ASUS say they don’t support or have a driver for it…

Help if possible.


Advise you post your ‘garuda-inxi’ output before @SGS disposes of your post. Them’s the rules. :slight_smile:


Sorry if not on par with the rules and Reg first-time I’ve posted here…

Not sure how to actually do what you suggested…

Thanks tho.

garuda-inxi is used to provide your system specs.
Just open a terminal, type garuda-inxi, press enter, copy (Ctrl+Shift+C) the output and paste it here in this topic formatted
like this
If you prefer, the same information is provided in the Garuda Assistant / System specs tab.


Hello. I’ve moved your post to Issues & Assistance where it belongs (again) as you are asking for assistance. Please keep it there and do not move it back again. Thank you. Also please do not remove tags put in unless they are no longer relevant!


You got the rules when you open a help request :smiley:

For you :slight_smile:

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed


The keyboard backlight is normally controlled via the firmware and the operating system is not aware of it.
That’s why it works on most laptops without a suitable driver using the Fn key, in your case that should be “Fn + F7”.

There is open source software for Asus laptops, for example asusctl, but that mainly only supports TUF/ROG models. If your keyboard is connected internally via USB, then it could probably work with a VivoBook - you can check this with:


If something like “asus n-key” or similar is displayed, then the keyboard is connected via USB and you might be lucky that it works.

If you use KDE Plasma: in the system settings you can set a shortcut to activate/deactivate the keyboard backlight. But that only works if a corresponding driver is installed, which is probably not the case with Asus. If there is nothing called ‘asus::kbd_backlight’ under /sys/class/leds/, then a shortcut will not work.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.