Virtual Box blur screen on full-screen mode

when switching to full-screen mode on virtualBox

give me blur screen

How to solve this issue?


inxi -Faz


System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2da9e79d-6e5d-49cd-850a-8ce0674aaa20
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Predator PH315-52 v: V1.12 serial: <superuser required>
Chassis: type: 10 serial: <superuser required>
Mobo: CFL model: Covini_CFS v: V1.12 serial: <superuser required> UEFI: Insyde v: 1.12
date: 07/28/2020
Battery:   ID-1: BAT0 charge: 42.5 Wh (99.1%) condition: 42.9/42.9 Wh (100.0%) volts: 16.6 min: 15.4
model: SMP KT00407009 AP18E7M type: Li-ion serial: <filter> status: Charging
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L1: 384 KiB L2: 1.5 MiB
L3: 12 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399
Speed: 1120 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 1400 2: 1400 3: 1169 4: 1213
5: 1128 6: 1255 7: 1371 8: 1223 9: 1338 10: 1400 11: 1400 12: 1400
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Acer Incorporated ALI driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Acer Incorporated ALI
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191
class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3 chip-ID: 04f2:b64f
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") s-diag: 1052mm (41.4")
Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
Monitor-2: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8")
diag: 609mm (24")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348
class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.41 running: yes
Network:   Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI
driver: alx v: kernel port: 3000 bus-ID: 07:00.0 chip-ID: 1969:e0b1 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™ driver: iwlwifi v: kernel
bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
IF-ID-1: vboxnet0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:5
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 1.38 TiB used: 818.62 GiB (58.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB512HBJQ-00007 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EXF7102Q temp: 46.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-00Z10T0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A01 scheme: GPT
Partition: ID-1: / raw-size: 365.45 GiB size: 365.45 GiB (100.00%) used: 138.52 GiB (37.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.6 MiB (26.6%) fs: vfat
dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 365.45 GiB size: 365.45 GiB (100.00%) used: 138.52 GiB (37.9%) fs: btrfs
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/log raw-size: 365.45 GiB size: 365.45 GiB (100.00%) used: 138.52 GiB (37.9%)
fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-5: /var/tmp raw-size: 365.45 GiB size: 365.45 GiB (100.00%) used: 138.52 GiB (37.9%)
fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.46 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 55.0 C pch: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 364 Uptime: 2h 46m wakeups: 1 Memory: 15.46 GiB used: 4.75 GiB (30.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1408 lib: 315
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

1 Like

From homepage.

Installing in virtual machines is not recommended as it might result in a bad experience! (eg. setup assistant not working)

1 Like

garuda installed on a physical machine
host OS Garuda guest OS Parrot OS
I wanna get the solution for this issue

How did you install virtual box? You should install it from setup assistant.

3 Likes

from Octopi

Which packages did you install from octopi? Also to know how to set up virtual box correctly, see
https://wiki.archlinux.org/title/VirtualBox

Also, if you don't wanna read, you should simply reinstall from Garuda setup assistant.

4 Likes

I installed it again from setup assistant nothing changed

Than read the manual.

2 Likes

ok, I'll try it

Hi did you find a solution?

I got the exact same problem. I've never seen this before. After more research look like a problem with KDE and Wayland.

1 Like

till now I didn't find any solution

Hmm, I have installed virtual box from Pamac and the problem is from force blur effects

OR
In advance try Kwin script debug console & Add a new window rule for Virtual box

Try disabling Kwin scripts
Force blur option

It works in Dr460nized edition that I'm using

Please again enable those effects after using Virtual Box to enhance looks

2 Likes

this link requires access

  1. do not trust google.
  2. do not open every link
  3. can you trust all hackers :smiley:

Why can't you post that here or in PrivatBin to if there are more than 32000 chars?

7 Likes

here's the solution
disable Blur effect from system Settings
system Settings > Workspace Behavior > Desktop Effects > Blur
thanks, @virat_17 for the hint
@DerpFox check this solution

2 Likes

you're right
How Could I miss that :sweat_smile:?

2 Likes

Ya, I can insert image directly here and I'm not allowed to da that bcz I'm new user and it's my own personal account and not a random link

Sorry about that, stupid Google services works like that and I don't have much time to do stuffs

We like terminal in and out puts as text, pictures in technical forums are useless, they can't be copy and paste, and they are not searchable by the forum search engine, so we stop new users to post pictures.

Whether this is your account or not is irrelevant.

Is it safe because it is your account?

Hey, I mean no offense to you, but in general.

But I don't trust a nickname that contains hackers any more than I trust anyone else who sends me a google link :smiley:

and
:slight_smile:

2 Likes

On GUI follow these Steps

Search for Kwin Script

Step 1 :

Step 2 :

Solved :

1 Like