Videos not playing after latest update

I've been hunting for the solution for this for a while now and could use some advice. Looking at the hardware list, I only have the Generic Video drive now, but FireDragon no longer plays videos of any type (News feed, Youtube, etc.) I'm hoping that someone could point me in the right direction for fixing this aside from rolling back to a snapshot everytime I want to watch something.

Kernel: 6.2.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=98658550-e380-4c26-9f42-8cb7b8b99c65 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Apple product: MacBookPro9,2 v: 1.0
serial: Chassis: type: 10 v: Mac-6F01561E16C75D06
Mobo: Apple model: Mac-6F01561E16C75D06 v: MacBookPro9,2
serial: UEFI: Apple v: 429. date: 03/18/2022
ID-1: BAT0 charge: 43.9 Wh (95.0%) condition: 46.2/62.9 Wh (73.5%)
volts: 12.3 min: 10.9 model: SMP bq20z451 type: Li-ion serial: N/A
status: full cycles: 440
Info: model: Intel Core i7-3520M bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2893 high: 2894 min/max: 1200/3600 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2894 2: 2893 3: 2892
4: 2894 bogomips: 23148
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: LVDS-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3,
VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo
bus-ID: 2-1.1:3 chip-ID: 05ac:8509 class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
s-diag: 398mm (15.69")
Monitor-1: LVDS-1 model: Apple Color LCD built: 2009 res: 1280x800 hz: 60
dpi: 114 gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3")
ratio: 16:10 modes: 1280x800
API: OpenGL v: 4.2 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 4000 (IVB
GT2) direct-render: Yes
Device-1: Intel 7 Series/C216 Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Sound API: ALSA v: k6.2.2-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 01:00.0
chip-ID: 14e4:16b4 class-ID: 0200
IF: enp1s0f0 state: down mac:
Device-2: Broadcom BCM4331 802.11a/b/g/n driver: wl v: kernel
modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
chip-ID: 14e4:4331 class-ID: 0280
IF: wlp2s0 state: up mac:
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
bus-ID: 1- chip-ID: 05ac:821d class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Local Storage: total: 698.64 GiB used: 84.43 GiB (12.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: HDD HTS541075A9E662
size: 698.64 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: rev: B5D0 scheme: GPT
ID-1: / raw-size: 698.34 GiB size: 698.34 GiB (100.00%)
used: 84.43 GiB (12.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 698.34 GiB size: 698.34 GiB (100.00%)
used: 84.43 GiB (12.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 698.34 GiB size: 698.34 GiB (100.00%)
used: 84.43 GiB (12.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 698.34 GiB size: 698.34 GiB (100.00%)
used: 84.43 GiB (12.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 90.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 232 Uptime: 22h 10m wakeups: 2 Memory: 7.67 GiB
used: 3.28 GiB (42.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1446
libs: 452 tools: gnome-software,octopi,pamac,paru Shell: fish v: 3.6.0
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date: 2023-03-10
Last full system update: 2023-03-12 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot: No/Undetected
Failed units: nmb.service


what went wrong I don't know, I also have both ffmpeg and ffmpeg4.4 installed for whatever reason and it works here.


Don't forget to reboot also.


That worked!!! Thanks!!!

It seems as if this is a common problem as I was also struck with it across all of the firefox based browsers I have installed (Pale Moon, Waterfox & Firedragon), and the above resolved the issue across the board.

Could this post remain on the front page for a few days to inform people what to do if they encounter this issue?

The best thing is that more users learn to use the search functions on the Internet or here in the forum than to pin every problem somewhere at the top. :slight_smile:

I am new linux user I am also facing video +lectures is not playing in my firedragon but my friends firefox(flatpak)vesion without any problem how can solve my this issue
what the command to install all free+properitery multimedia codecs

For you the long answer, in terminal

update -- ffmpeg4.4

just copy and paste

it shows this-
find-the-command: "ffmpeg4.4" is not found locally, searching in repositories...
find-the-command: command not found: "ffmpeg4.4"

[🔍] × upd -- ffmpeg4.4
:: Paketdatenbanken werden synchronisiert …
 garuda ist aktuell
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
 chaotic-aur ist aktuell
:: Starting full system upgrade...
warning: virt-install-git: local (4.1.0.r32.g33ff193ee-1) is newer than chaotic-aur (4.1.0.r32.g33ff193e-1)
warning: virt-manager-git: local (4.1.0.r32.g33ff193ee-1) is newer than chaotic-aur (4.1.0.r32.g33ff193e-1)
resolving dependencies...
looking for conflicting packages...

Packages (1) ffmpeg4.4-4.4.3-1

Total Download Size:    8.54 MiB
Total Installed Size:  24.15 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 ffmpeg4.4-4.4.3-1-x86_64       8.5 MiB  14.6 MiB/s 00:01 [------------------------------] 100%
1 Like

It is not a command, it is a package you need to install.

1 Like

ohhh okk i installed it and reboot also
but when i play video in firedragon say the clearkey plugin is crashed
DRM is also enabled

Open new thread, please, and follow the template, this thread is solved.

1 Like