Video Problems, but not systemwide

Hello
first:

garuda-inxi  
System:
Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=04f2b34d-95b5-4428-aa90-76b0aa6844b9 rw [email protected]
rd.udev.log_priority=3 resume=UUID=732f1b04-1f2b-43a2-8b9c-9ff4724690ec
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: Acer product: TravelMate Spin B311RN-31 v: V1.18
serial: <superuser required> Chassis: type: 31 serial: <superuser required>
Mobo: GLK model: Maracas_GL v: V1.18 serial: <superuser required>
UEFI: Insyde v: 1.18 date: 08/26/2021
Battery:
ID-1: BAT0 charge: 40.3 Wh (79.5%) condition: 50.7/48.0 Wh (105.6%)
volts: 12.0 min: 11.2 model: 30G020 AP18C8K type: Li-ion serial: <filter>
status: discharging cycles: 17
Device-1: hid-0018:04F3:2B9C.0001-battery model: ELAN9004:00 04F3:2B9C
serial: N/A charge: N/A status: N/A
CPU:
Info: model: Intel Pentium Silver N5030 bits: 64 type: MCP
arch: Goldmont Plus family: 6 model-id: 0x7A (122) stepping: 8
microcode: 0x1C
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
desc: d-4x24 KiB; i-4x32 KiB L2: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1570 high: 2064 min/max: 800/3100 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1571 2: 2064 3: 1457
4: 1190 bogomips: 8755
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel GeminiLake [UHD Graphics 605] vendor: Acer Incorporated ALI
driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:3184 class-ID: 0300
Device-2: Chicony 5MP World Facing type: USB driver: uvcvideo
bus-ID: 1-2:2 chip-ID: 04f2:b6fe class-ID: 0e02 serial: <filter>
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0xea8c built: 2019 res: 1920x1080
hz: 60 dpi: 190 gamma: 1.2 size: 256x144mm (10.08x5.67")
diag: 294mm (11.6") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 605 (GLK 3) v: 4.6 Mesa 22.0.1
direct render: Yes
Audio:
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
chip-ID: 8086:3198 class-ID: 0403
Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:0c.0 chip-ID: 8086:31dc class-ID: 0280
IF: wlp0s12f0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 02:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-9:5 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 357.99 GiB used: 255.95 GiB (71.5%)
ID-1: /dev/mmcblk1 maj-min: 179:0 type: USB model: GE4S5 size: 238.75 GiB
block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston
model: RBUSNS8154P3128GJ1 size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: E8FK12.3 temp: 24.9 C scheme: GPT
Partition:
ID-1: / raw-size: 110.94 GiB size: 110.94 GiB (100.00%)
used: 36.96 GiB (33.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 110.94 GiB size: 110.94 GiB (100.00%)
used: 36.96 GiB (33.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 110.94 GiB size: 110.94 GiB (100.00%)
used: 36.96 GiB (33.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 110.94 GiB size: 110.94 GiB (100.00%)
used: 36.96 GiB (33.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 3.64 GiB used: 974.2 MiB (26.2%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 271 Uptime: 2h 11m wakeups: 12 Memory: 3.64 GiB
used: 2.09 GiB (57.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1634 lib: 400 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-3):
System install date:     2022-02-13
Last full system update: 2022-04-19 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Hello to all!

I have Garuda KDE installed on 2 low spec Intel devices (1 Laptop and 1 Mini PC) just for consuming media or playing with Geforce Now.

On booth PCs i have problems playing video. It's more like a 1-3 sec slideshow than a smooth video playback. But related on which player i am using. Kodi, VLC or MPV just run fine. But with Dragon Player i get a frame every 1 or 2 seconds while audio is playing fine from the same video. Also when i'm using minitube. Then i tried freetube und there all is fine again.

When i try to play with geforce now, it's even getting worse, i have video lags around 5-7 seconds. But you can hear in the audio, that my input from my mouse or controller is right there. For example, if i play a race game, i can hear the motor if i hit the throttle, but the car is moving in around 5-7 seconds visually. Same behaviour here, audio is fine, video shows a frame every few seconds.

I'm using Linux for a year now , for me it seems that Geforce Now and Dragon Player is not using hardware acceleration or someting similar, and when it is fixed, booth will work. But i may be wrong. I know it can work on these PCs, because before Garuda i had Xubuntu installed, and no problems using geforce now.

It doesn't matter if i use Geforce Now in a supported browser like Chrome or MS Edge, or i use the electron app provided by the AUR.

I have no ideas where to look to fix this. Anyone any ideas?

Welcome :slight_smile:

???

You read the minimum specs on Garuda download page?


If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.
Please edit your post.

2 Likes

Dragon player is one of the more obscure KDE projects, and I don't think very many people actually use it day-to-day. I've run KDE for the better part of 20 years and never used it, other than possibly trying & saying 'meh' and moving on. There have 'always' been better players.

Your concerns may be better addressed by the author: The Dragon Player Handbook

or here

Otherwise, I'd not expect much response. It is not very widely used.

Did you check for bug reports?

1 Like

My first thought was that Nico made it, just like FireDragon, so you can be wrong.

Sorry.

1 Like

i opened this topic because i was thinking there is some kind of system video playback, that dragon player and geforce now is using. And which is not working properly. I'm not using the Dragon Player often, i just want to provide this information in the hope, to get help.

You think that the PC is not matching minimal requirements?
It's strange because this is the only problem i facing with Garuda. And i'm wondering why VLC, MPV and Kodi is playing every media i throw at it without problems. Also video in browser is no problem. But Geforce Now is really not working well.
Geforce Now even worked well with Windows 10, Xubuntu and Chrome on the same computer, but sadly not with Garuda.
Tought it's just a configuration issue.

???

I know nvidia geforce, but I cant see it in your garuda-inxi.
Same like Dragon Player, IDK what you mean.

On the other side use what work :slight_smile: or post the problem to Dragon Player developer. Please.

I would imagine this is a codecs issue rather than a problem with Dragon Player. The reason why VLC is so good (and imho why you would never need anything else) is because it has every codec ever created baked into it.

Sounds like dragon player is either mis-identifying your media container/codec or it doesn't recognize it and is having a best guess.

What you could do is open your media with VLC, press CTRL+I to open the info pane and then click on the codec tab. VLC will tell you what it's using eg MPEG-H/HEVC (H.265) for video and E-AC3 for audio.

I'm not familiar with dragon player but if it has an option to inspect the played media, try that and see if it matches, or lookup supported codecs on the Dragon Media website.

(or just use vlc, it really is the last media player you'll ever need)

SF

2 Likes

Geforce NOW is a streaming service, not a GPU :sweat_smile:

1 Like

A crappy name, in my opinion, like using fruit names for computer hardware.
A link from you could have saved us guessing and asking.
As I said, use what works or contact Nvidia or/and KDE.

2 Likes

RaspberryPi: I'm a joke to you?

2 Likes

No, never. I wasn't thinking of raspberry pie, but of this bitten fruit.

</offtopic>

3 Likes