Video playback not working in all browsers and all players


several days ago when I updated some packages, i found when loading a video on Youtube or other online video sites it loads the first frame but video doesn’t play. If I hit different parts on the timeline frame changes but doesn’t play either. As well play local video , I'v tried SMPlayer and mpv.

inxi -Faz

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5a8ba462-233f-420d-b79d-f5fd7733f2f9 rw
           rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 82DM v: Lenovo XiaoXinPro-13ARE 2020 serial: <filter> Chassis: type: 10
           v: Lenovo XiaoXinPro-13ARE 2020 serial: <filter>
           Mobo: LENOVO model: LNVNB161216 v: SDK0L77769WIN serial: <filter> UEFI: LENOVO v: F0CN18WW date: 07/07/2020
Battery:   ID-1: BAT0 charge: 52.2 Wh (97.0%) condition: 53.8/56.6 Wh (95.0%) volts: 12.8 min: 11.5 model: Sunwoda L19D3PD3
           type: Li-poly serial: <filter> status: Unknown cycles: 33
           Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse serial: <filter>
           charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 4600U with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23)
           model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 50306
           Speed: 1460 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1460 2: 2311 3: 1579 4: 1460 5: 2321
           6: 1396 7: 1397 8: 1497 9: 1937 10: 1598 11: 1397 12: 1642
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 03:00.0
           chip-ID: 1002:1636 class-ID: 0300
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 3-2:3 chip-ID: 04f2:b67c class-ID: 0e02
           serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 5120x1600 s-dpi: 96 s-size: 1354x423mm (53.3x16.7") s-diag: 1419mm (55.8")
           Monitor-1: eDP res: 2560x1600 hz: 60 dpi: 227 size: 286x179mm (11.3x7.0") diag: 337mm (13.3")
           Monitor-2: DisplayPort-1 res: 2560x1440 hz: 60 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27")
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.14-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 03:00.1
           chip-ID: 1002:1637 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo driver: N/A
           alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Device-4: JMTek LLC. USB PnP Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.3.1:8
           chip-ID: 0c76:153f class-ID: 0300
           Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8822ce v: N/A
           modules: rtw88_8822ce port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:c822 class-ID: 0280
           IF: wlp1s0 state: up mac: <filter>
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.1:3 chip-ID: 0bda:8153
           class-ID: 0000 serial: <filter>
           IF: enp3s0f4u1u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 4-1.2.3:6 chip-ID: 0bda:8153
           class-ID: 0000 serial: <filter>
           IF: enp3s0f4u1u2u3 state: down mac: <filter>
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 0bda:c123 class-ID: e001
           serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 3 state: down bt-service: enabled,running rfk-block: hardware: no software: no
           address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 118.11 GiB (24.8%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730 SDBPNTY-512G-1101 size: 476.94 GiB
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 11130001
           temp: 32.9 C scheme: GPT
Partition: ID-1: / raw-size: 275.69 GiB size: 275.69 GiB (100.00%) used: 118.08 GiB (42.8%) fs: btrfs dev: /dev/nvme0n1p6
           maj-min: 259:6
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 33.2 MiB (13.0%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 275.69 GiB size: 275.69 GiB (100.00%) used: 118.08 GiB (42.8%) fs: btrfs dev: /dev/nvme0n1p6
           maj-min: 259:6
           ID-4: /var/log raw-size: 275.69 GiB size: 275.69 GiB (100.00%) used: 118.08 GiB (42.8%) fs: btrfs
           dev: /dev/nvme0n1p6 maj-min: 259:6
           ID-5: /var/tmp raw-size: 275.69 GiB size: 275.69 GiB (100.00%) used: 118.08 GiB (42.8%) fs: btrfs
           dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 15 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 42.8 C mobo: N/A gpu: amdgpu temp: 38.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 371 Uptime: 16m wakeups: 3 Memory: 15 GiB used: 6.48 GiB (43.2%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1355 lib: 311 Shell: fish v: 3.3.1 running-in: alacritty
           inxi: 3.3.08

In browser, if, which one? Define all, please :slight_smile:

Direct in app, then start app from terminal, post output as text, please.


after getting a pop-up telling me: "Manual intervention required] Package conflict between pipewire-media-session & wireplumber" i've had a simular problem when playing videos... in my browser (defining my browser: Firefox) the playback was very slow and in my players (defining my players: VLC, mplayer) i had no sound. So i searched the forum and found the post below that fixed my video playback problems: [Manual intervention required] Package conflict between pipewire-media-session & wireplumber

i followed the instructions and all video playback works okay again ... maybe it works for you too

1 Like

I posted this fix today for broken sound/youtube, etc. See if it works for you....

  1. Remove all the configuration files in /etc/pipewire (sudo mv /etc/pipewire /tmp)
  2. Reinstall pipewire, pipewire-pulse, and pipewire-media-session (sudo pacman -S pipewire pipewire-pulse pipewire-media-session)
  3. Enable and start the relevant services (systemctl --user enable pipewire pipewire-pulse pipewire-media-session) and (systemctl --user restart pipewire pipewire-pulse pipewire-media-session). After that, my devices appeared as usual and I was back in business.

it worked! thank you very very much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.