Very weird troubles with AMD and Virtualized Machines


I discovered garuda a few days ago when I accidentally been through a video from a certain DistroTube and after some googling found out the blackarch dr46onized version of Garuda which, as a cybersec professional , instantly caught my attention.

after download (garuda-dr460nized-blackarch-linux-zen-210720) I set a VM which sadly got stuck at :

a start job is running automatic driver installation via mhwd

and runs forever (stopped after few hours)

as I know some ARCH based distributions may be sensitive to virtualisation, I flashed a stick and tried a live boot, got the exact same situation stuck at the same point.

thought there's a conflict somewhere, so I downloaded the nude version of dr46onized garuda (garuda-dr460nized-linux-zen-210720) and went over the same situations precedently exposed.

googled a bit and found two major topics, one concluding that was because of bad hardware (not my case) and the other was a guy that have been into this problem after an update but his old version was still working (in a VM), after some waybacking I've been able to recover an old magnet link to an older version (garuda-dr460nized-gaming-linux-tkg-bmq-210107) that worked perfectly, both in VM and on a liveboot, sadly wasn't been able to update this version to the recent one and not even installing the blackarch repos (which is not my inquiry here as I stopped my digging in fixing that to post this here)

My question :
May any staff member be pleased to provide me a link to the blackarch version related to 210107 this update so I can pursue my troubleshooting?

Hopping this could help fixing the virtualization of the distro, I completely understand the fact you disapprove this way to use your distribution but as you're providing a pentesting version of it, the virtualization is ineluctable

Hardware :
CPU : Ryzen 7 5800x
GPU : R7 370 Strix 4Gb
RAM : 32Gb

VM :
RAM : 8Gb
CPU : 8 Cores
Storage : 50Gb
Accelerated graphics :white_check_mark:

1 Like

Out of curiosity, which virtualization solution are you using?

1 Like

And it is not supported. You are on your own.

1 Like

I am on VMware Workstation version 16

@elloquin then why there's a prebuilt version of it with the repos & tools ? blackarch aside even the nude light version is presenting the symptoms and the virtualization isn't less important, some of us are under MacOS and this distro could be a refreshing for them

Thats a known issue which is currently being investigated.

No official support for Barebones & BlackArch isos to help with floods of requests how to use it and no official support for VMs as a lot of people don't realize that performance will suck and Garuda applications not working (eg. Alacrity doesnt work without proper graphics card). Its rather tiring to deal with a high amount of people who complain as they can't adjust their expectations or skip the bare minimum of reading system requirements. :thinking:


well I am not complaining about anything, quite the contrary I am willing to help that's why I only requested matter to pursue my investigation on this.

I've got the same problem live booting the 210720 version, and this is not the first time I have this kind of troubles, 70% because of my AMD GPU, I remember the 2019.1 kali linux got me through some really bad time setting it up.

but thank you anyway, I'll just follow the gitlab issue resolution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.