Very low fps in cs go

I have really low fps in cs:go. In windows it is about 150 fps and here, in garuda linux, this is 30 fps. Is this normal fps for linux? Ask me all you need to help me solve this issue and I will post it here. Of course I tried googling, but after about 3 hours of trying it didn't give me anything meaningful. Thank you in adnvance

  Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=768379d5-879a-43fa-9c68-08812119bb91 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Acer product: Nitro AN515-54 v: V1.31
    serial: <superuser required>
  Mobo: CFL model: Octavia_CFS v: V1.31 serial: <superuser required>
    UEFI: Insyde v: 1.31 date: 06/29/2020
  ID-1: BAT1 charge: 39.5 Wh (99.5%) condition: 39.7/58.8 Wh (67.5%)
    volts: 16.2 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
    status: N/A
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4374 high: 4466 min/max: 800/4500 scaling:
    driver: intel_pstate governor: performance cores: 1: 4321 2: 4466 3: 4414
    4: 4377 5: 4402 6: 4401 7: 4440 8: 4401 9: 4299 10: 4246 11: 4426
    12: 4305 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
    vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 0000:00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
    vendor: Acer Incorporated ALI driver: nouveau v: kernel
    bus-ID: 0000:01:00.0 chip-ID: 10de:2191 class-ID: 0300
  Device-3: Quanta HD Webcam type: USB driver: uvcvideo bus-ID: 1-5:3
    chip-ID: 0408:a060 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: intel,modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143
    size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.5 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000
    bus-ID: 0000:06:00.0 chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0aaa class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
    driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
    chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 1.14 TiB used: 38.04 GiB (3.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM256GDJTNG-8310A size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 80002C00 temp: 30.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J scheme: GPT
  ID-1: / raw-size: 244.14 GiB size: 244.14 GiB (100.00%)
    used: 38.01 GiB (15.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.5 MiB (26.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 244.14 GiB size: 244.14 GiB (100.00%)
    used: 38.01 GiB (15.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 244.14 GiB size: 244.14 GiB (100.00%)
    used: 38.01 GiB (15.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 244.14 GiB size: 244.14 GiB (100.00%)
    used: 38.01 GiB (15.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.6 GiB used: 56 MiB (0.7%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 45.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 310 Uptime: 51m wakeups: 1 Memory: 7.6 GiB
  used: 3.02 GiB (39.7%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1491 lib: 368 Shell: fish
  v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
e[1;34mGaruda (2.5.4-2):e[0m
e[1;34m  System install date:e[0m     2022-02-13
e[1;34m  Last full system update:e[0m 2022-02-13
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m 

Are you using the dedicated GPU? That doesn't happen by default in Linux.

You also aren't using the proprietary nvidia drivers which will be required to get any kind of performance there.


5 sec I got

Welcome to the forum :slight_smile:


Yes, I have seen that thread :slight_smile: . Also I tried to look at arch linux forums and have looked also at youtube videos and some other websites like stack overflow, so that wasnt simple blind ordinary asking on the forum (I hope xd). As I have siad, I tried a little bit of googling, so of course, I have checked all the first links. Unfortunatelly, that thread havent helped me. I dont exclude also that posibility, that I didnt understand something from that thread and this could be the reason that I cant solve my problem by myself, but I think that this is unlikely probability.

With proprietary drivers garuda linux didnt start. I running pc, then it loads grub and I select garuda linux, then it goes loading garuda and then freezes on black screen where it says me that it tries to load linux kernel in z ram (or smth like that). But when I tried open-source drivers garuda linux have loaded normaly, so I can start to use that. My friend, which also is trying garuda linux with me, have loaded open-source drivers normally, but he also has very low fps. As well, internet suggestions didnt helped him :frowning: . Dedicated GPU? How can i do that? Do you mean "prime-run %command%" which I should paste into Launch Box in steam for cs:go? When I do this, cs:go simply dont run.

You will not get good performance until you get the proprietary drivers working and are using the nvidia gpu instead of the intel gpu.

If it didn't work the first time, you need to try to figure out how to get them working.

1 Like

Maybe this tutorial could help, after installing proprietary drivers (Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration), in case of black screen or similar:


I see you've tried to do a little research, but as i do not know what you've tried and not, ill just post what worked for me in the beginning.

The opensource drivers for Nvidia is unfortunately lacking in performance compared to the proprietary drivers. I'm a newbie myself, but from what i gather you're running a dgpu laptop, which means you might want to opt for video-nvidia-prime-render-offload, video-nvidia-dkms, video-modesetting, and video-linux in the Garuda settings manager > Hardware Configuration. Make sure you reboot after making changes.

After a successful driver setup is installed, you will use the command


when you want to launch applications using your graphics card.

I hope this helps. Ill download cs and see if i have any issues on my inferior dgpu.