Very Long Boot from USB


After flashing the Garuda iso using Etcher, I was presented with a boot screen with 2 options, boot using open source drivers or NVIDIA drivers. I tried both of them, both took more than 30 minutes and it's still on the Garuda Logo. Reflashed a couple of times, verifying the checksums, and tried again with no avail. I'm also using Windows 10 for the flashing. Pressing ESC works on the boot, and one of the message was:

ERROR: 'dev/disk/by-label/GARUDA_DR460NIZEDGAMING_SOARING_' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log off when you are finished
sh: can't access tty; job control turned off

System Information

Device: Lenovo Legion 5 15ARH05H
Processor: AMD Ryzen 7 4800H with Radeon Graphics, 2900 Mhz, 8 Core(s), 16 Logical Processor(s)
RAM: 16 GB

Hi dotd100,

Not sure , but if you run etcher by regular (simple double click), it's take so long and failed to write the ISO correctly.

  1. Format your usb flash drive
  2. Run etcher as Admin

In addition, there's a FAQ to help in most situations here - Installation instructions | Garuda Linux wiki


I tried every software I could, and they all seem to work in the virtual machine but not when I boot it after the bios. Currently trying to use dd from a Linux vm and see if that works instead.

Have you tried any suggestions from Garuda???


I did say I verified the checksum already even if I got it from torrent (since sourceforge mirror is broken), reverified in torrent, use etcher and dd for windows. I stated that I'm running this on windows, so stuff like lsblk didn't work. Also yes, I'm gonna try burn the iso to usb on a Linux VM instead and try again later.

You missed my point.
Read instructions carefully and slowly. Do not rush! Follow links.


My bad, after re-reading it for a couple of times, I think I may have figured out the problem. Will update again when it works.


Indeed - the more details you give, the more help to others experiencing similar you will provide. Thanks in advance. :slightly_smiling_face:


Ok I've finally got it to work after 4 sleepless nights, and it's as simple as going to a 4th usb... I used Etcher with admin mode to flash the iso into the usb and when booting, used open source drivers (using Nvidia driver Will hang the laptop for some reason.) Hope this can help others facing a similar issue of what I had and thanks to the bunch who helped me!

TL;DR: Keep trying different usb until it works. Use open source drivers first, if that doesn't work, try Nvidia.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.