Ventoy - Garuda : dracut problem

Hey all,

Trying to use garuda isos with Ventoy, to have a tool when having problems with my favorite distro.

Trying to launch dragonized or gnome iso, 230501 version, give me always the same error with dracut, in normal or grub2 mode.

Sorry for the image and the poor quality, but i cant export the text.

I try this with three different computers, but always the same…

her’s my inxi :

System:
Kernel: 6.5.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5a2ed686-9f3f-4d1c-a51e-41bbeea7c18c rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: LENOVO product: 20FRS08T00
v: ThinkPad X1 Carbon 4th serial: <superuser required> Chassis: type: 31
serial: <superuser required>
Mobo: LENOVO model: 20FRS08T00 v: SDK0J40697 WIN
serial: <superuser required> UEFI: LENOVO v: N1FET81W (1.55 )
date: 10/11/2022
Battery:
ID-1: BAT0 charge: 47.4 Wh (100.0%) condition: 47.4/47.4 Wh (100.0%)
volts: 16.6 min: 14.8 model: LGC 00HW028 type: Li-ion serial: <filter>
status: full
CPU:
Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake
gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
model-id: 0x4E (78) stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 425 high: 500 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 500 4: 400
bogomips: 22399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:5 chip-ID: 04f2:b531
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x04aa built: 2015 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.8-arch1.1 renderer: Mesa Intel HD Graphics
520 (SKL GT2) direct-render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
API: ALSA v: k6.5.5-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:4 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0000
Drives:
Local Storage: total: 1.15 TiB used: 101.33 GiB (8.6%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: SN01T size: 953.55 GiB
block-size: physical: 512 B logical: 512 B tech: SSD serial: <filter>
scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSCKGF240A5L
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: LV8i scheme: GPT
Partition:
ID-1: / raw-size: 104.65 GiB size: 104.65 GiB (100.00%)
used: 17.1 GiB (16.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 502 MiB size: 501 MiB (99.80%)
used: 596 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 104.65 GiB size: 104.65 GiB (100.00%)
used: 17.1 GiB (16.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 104.65 GiB size: 104.65 GiB (100.00%)
used: 17.1 GiB (16.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 104.65 GiB size: 104.65 GiB (100.00%)
used: 17.1 GiB (16.3%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.0 C pch: 38.0 C mobo: N/A
Fan Speeds (rpm): fan-1: 3205
Info:
Processes: 227 Uptime: 1m wakeups: 2 Memory: total: 8 GiB
available: 7.62 GiB used: 2.5 GiB (32.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1408
pm: pacman pkgs: 1405 libs: 395 tools: octopi,paru pm: rpm pkgs: 3
Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2022-12-02
Last full system update: 2023-10-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Hope you can find a solution for me… Did a lot of searches, but with no luks… :hugs:

have you checked the sha256sum of ISO after copying it to ventoy? I remember I had similar issues before because dolphin is not accurate with it’s %tage counter of copying files what would happen is there would still be dirty pages left in ram left to be flushed to the USB and I would unknowingly eject the USB thinking I was done and couldn’t boot with errors same as yours. Hence going on forum I came across this command (sorry I don’t remember who shared it but thankyou) to view dirty pages left in RAM

watch -n 1 -d grep -e Dirty: -e Writeback: /proc/meminfo

Once I am sure that all pages related to the ISO have been flushed (the number of dirty pages reduces drastically once the process is over) I would check it’s sha256sum to ensure that everything is in order.

4 Likes

:smiley:

4 Likes

Thankyou for linking that post SGS, I had saved this command as my alias

alias watch-usb='watch -n 1 -d grep -e Dirty: -e Writeback: /proc/meminfo'

since the incident I mentioned above. Really useful for ensuring I don’t preempt the process of data transfer and cause issues like before. Thankyou Technitium.

3 Likes

I ever just use “Safely remove” :slight_smile: or what is he original text for “Sicher entfernen” in English :smiley:

1 Like

Hey again,

You were right… Both checksums are invalid…

But i’m not sure to understand how to use this command before transfering the 2 isos in Ventoy…

maybe you should just try with one ISO first then second …
I don’t remember that whether the ventoy allows the multiple ISOs but if it allows and you’re doing something like then I would like to ask to avoid it :slightly_smiling_face:

and try with other USB flashers too

1 Like

It does.

ls /run/media/sgs/Ventoy/
drwxr-xr-x    - sgs  8 Jan 05:44  .Trash-1000
drwxr-xr-x    - sgs  7 Mär 03:44  System Volume Information
drwxr-xr-x    - sgs 30 Dez  2022  ventoy
.rwxr-xr-x 2,6G sgs  6 Sep 18:33  garuda-hyprland-linux-zen-230906.iso
.rwxr-xr-x 2,6G sgs 26 Sep 02:36  garuda-hyprland-linux-zen-230924.iso
.rwxr-xr-x 2,6G sgs 29 Sep 04:16  garuda-hyprland-linux-zen-230929.iso
.rwxr-xr-x 2,5G sgs 14 Sep 00:20  garuda-i3-linux-zen-230913.iso
.rwxr-xr-x 1,6G sgs  2 Sep 21:16  garuda-kde-lite-linux-zen-230822.iso
.rwxr-xr-x 2,3G sgs 28 Sep 01:33  garuda-qtile-linux-zen-230922.iso
2 Likes

I would just recommend Popsicle for the user for this time to try as an alternate of ventoy :slightly_smiling_face:
for this problem currently happening

1 Like

That actually just gets stuck and never completes when I have dirty pages left in ram. So not much useful.

That’s actually the selling point of ventoy, having multiple ISO’s to boot from.

This command is for monitoring purposes, it doesn’t directly interfere with the copy paste process, it simply monitors the number of dirty pages left in ram to be flushed to the local drive. The reason why I use this command is because the progress bar that indicates the amount of data written to your USB device is inaccurate. The progress bar finishes before all data has been flushed thus causing confusion.

when you launch the command it will start showing you the number of dirty pages you currently have. Once you start the process of copying the ISO from your system to the USB the number of dirty pages will increase, a lot and then once the process finishes the number of dirty pages will again decrease. And this change is going to be very steep.

I usually copy one ISO at a time and the number of dirty pages in my system go from (~1000-1400 kB) to (~100000-200000 kB) then back again to (~2000-1500 kB).

Or even better I just set the download path to my ventoy usb instead of downloading on my machine and then copy pasting it to my USB.

3 Likes

Hey again,

I tried with another usb stick, same problem…
I tried downloading again on my computer, checksum is ok, and i can use it in VirtualBox without any problem…

Tried to copy again from my pc to usb stick… Same problem…

Tried to download directly the iso to my usb stick and… IT WORKS !!!

Is Dolphin unable to write correctly on an usb stick ?
Do i have to use another file program ? Like Thunar for example or i could have the same problem ?

Don’t want to use Win**** just to copy two files… :rofl: :rofl: :rofl:

I did already mention the issue with it’s progress bar… Well anyway this issue only pops up on large files, for me at least.

2 Likes

Hey NaN,

You are right… You mentioned it.

Thanks to you, the solution was (at the time), to download the iso directly on the usb stick.

Thanks again :star_struck:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.