Variety and screen scale on KDE

Hi!, This is my garuda-inxi output:

╰─λ garuda-inxi
Kernel: 6.4.6-hardened1-2-hardened arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 parameters: pti=on page_alloc.shuffle=1
root=UUID=91e581b4-0a47-4ec7-9e8d-0df403d76616 rw rootflags=subvol=@
quiet rd.luks.uuid=ffc7ec5e-333c-49a3-9f60-43dedda2cd86 quiet
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=/dev/mapper/luks-297fbb15-68a1-417d-9ea5-e92a32dde56d loglevel=3
lsm=landlock,lockdown,yama,integrity,apparmor,bpf intel_pstate=no_hwp
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: LENOVO product: 90HU00FXIX v: ideacentre 510-15ICB
serial: <superuser required> Chassis: type: 3 serial: <superuser required>
Mobo: LENOVO model: 36EB v: SDK0J40700 WIN 3258137300085
serial: <superuser required> UEFI-[Legacy]: LENOVO v: O3QKT34A
date: 04/29/2019
Info: model: Intel Core i5-9400 bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF2
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 3900 high: 4100 min/max: 800/4100 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2900 2: 4100 3: 4100
4: 4100 5: 4100 6: 4100 bogomips: 34814
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Lenovo
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:3e92 class-ID: 0380
Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
vendor: Bitland Information driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
speed: 8 GT/s lanes: 8 ports: active: HDMI-A-3 empty: DP-2,DP-3
bus-ID: 01:00.0 chip-ID: 1002:699f class-ID: 0300 temp: 44.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting
alternate: fbdev,intel,vesa dri: radeonsi,iris gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-3 mapped: HDMI-A-2 model: Samsung LF24T35
serial: <filter> built: 2022 res: 1920x1080 dpi: 92 gamma: 1.2
size: 528x297mm (20.79x11.69") diag: 606mm (23.9") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: AMD Radeon RX 550 / 550 Series
(polaris12 LLVM 15.0.7 DRM 3.52 6.4.6-hardened1-2-hardened)
direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: Bitland Information driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 1002:aae0 class-ID: 0403
API: ALSA v: k6.4.6-hardened1-2-hardened status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 0bda:c024
class-ID: e001 serial: <filter>
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: see --recommends
Local Storage: total: 931.51 GiB used: 200.74 GiB (21.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: CC63 scheme: MBR
ID-1: / raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 200.74 GiB (21.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-ffc7ec5e-333c-49a3-9f60-43dedda2cd86
ID-2: /home raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 200.74 GiB (21.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-ffc7ec5e-333c-49a3-9f60-43dedda2cd86
ID-3: /var/log raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 200.74 GiB (21.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-ffc7ec5e-333c-49a3-9f60-43dedda2cd86
ID-4: /var/tmp raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 200.74 GiB (21.8%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-ffc7ec5e-333c-49a3-9f60-43dedda2cd86
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 254:1
mapped: luks-297fbb15-68a1-417d-9ea5-e92a32dde56d
ID-2: swap-2 type: zram size: 7.63 GiB used: 1.81 GiB (23.7%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 42.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 2257
Processes: 269 Uptime: 22m wakeups: 0 Memory: total: 8 GiB
available: 7.64 GiB used: 3.43 GiB (44.9%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1739 libs: 477 tools: octopi,pamac,paru,yay Shell: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-07
Last full system update: 2023-08-02 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:            systemd-hibernate-resume.service

Hi! I have two little problems with Garuda-dr460nized;

  1. I've installed veriety but there's no way I can get its management icon to appear on the panel. On the Garuda site it seems possible to activate variety with Garuda-Assistant, but on my system the option is absent. If variety is not supported on Garuda, which alternative do you recommend?

  2. On various systems that I used before Garuda (CachyOS, Fedora, etc.), on KDE settings, Hardware, Screen, it is possible to scale the screen of a value lower than 100%, for example 75%. On Garuda this is not possible at all or are there ways to achieve it?

Thank you so much!!!
With best regards.

Please one issue per topic.
This makes the forum useful for future users with the same problem (here maybe one could be solved but not the other).
As far as the scaling is concerned, I'd try with xrandr, e.g.

xrandr --output HDMI-A-3 --scale 1.25x1.25

(to be adapted, of course, and if working, you could create a systemd service)


Many thanks for your reply!
All the attempts I've made with xrandr, as well as the one you've proposed, show me a desktop smaller than the monitor, showing the areas not used by the desktop in black. So I just waste the space of the monitor. With KDE scale, where active, this does not happen: everything is reduced but NOT THE DESKTOP.

That indicates you need to reboot. Have you rebooted yet?


Yes! But no news related on this post...

1 Like

Very good, LOL! Oftentimes it is difficult to help someone diagnose a problem if a reboot is pending. KDE seems to be affected by this more than some other DEs. After that, the work can start with a little more assurance. Thanks for being cooperative. :smiley:


There may perhaps be a flaw in the Garuba upgrade. Several weeks ago, I had variety installed and there was no problem.
Now I found that Setup Assistant is able to install variety: I uninstalled variety and reinstalled it with Setup Assistant,
but nothing has changed - the management icon is not displayed!

Try switching to wayland.
Just install plasma-wayland-session and make sure to select Wayland in the login screen after you reboot.
I see I have the same issue with global scale in the x11 sessions but it works fine under wayland.


Thank you very much!!!

I installed wayland and rebooted. Now desktop scaling is present and active!!!
The variety management icon, on the other hand, still doesn't appear...

That’s strange. Works fine here.
I just installed it and the icon appears on the application luancher when I type that name, then I can drag it onto the dock/panel…


I don't quite understand how you do it. However, I don't see the management icon (which in my case should represent the displayed wallpaper) anywhere,,,

Probably I misunderstood the point.
I simply installed variety and so the icon, then dragged it.
Sorry, but I don't want to use it and have no time to go further.
As said, one issue per topic... At least for me.


What you show me is the launch icon. I speak of the management icon.
If you right click on the start icon you only have a few management possibilities (previous, next, pause, history and preferences)
but if you click on the management icon you have many more options.
The management icon appears only on the panel, inside the system tray.

I stay on one issue per topic. I referred to the other topic only because following your advice, I solved it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.