/var/lib/snapd/snap/bin was not found in your $PATH

Hey guys, i'm a complete noob in linux. So i have a lot issues while using Garuda Linux like:

  1. Installation of snap -
Warning: /var/lib/snapd/snap/bin was not found in your $PATH. If you've not
         restarted your session since you installed snapd, try doing that.
         Please see https://forum.snapcraft.io/t/9469 for more details.

Why is it showing like this when i install something using snap ???


  1. Flutter installation -
    I installed flutter sdk using snap and it showed that it is successfully installed, but after that when i run flutter commands it doesnt works. Why is that?

We do not recommend usage of Snap or Flatpak for software installation.
And welcome.

1 Like

From the wiki -

Again - welcome :wave: :slightly_smiling_face:

Check your /etc/os-release file to see if it includes the line


If not, add it. Then remove and rebuild snapd.

Basically, the snapd build process uses the ID and ID_LIKE values to determine aspects of the build/install process.

1 Like

fish_add_path /var/lib/snapd/snap/bin

worked for me


Hi there


Hello thank you for the Welcome!


thanks! worked for me too.

I use scidvspc to play chess and it's available in snap.
it should be in a wiki somewhere about snaps.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.