Using Lutris with Proton

I'm trying to get some game to run with Lutris. It only offers WINE 7.0-rc1 as the runner. It supports neither esync nor fsync, and the game crashes after the initial video.

How can I run Lutris with Proton? From Garuda Gamer, I installed proton-ge-custom, and I tried a few other approaches. Still, nothing shows up in Lutris.

I've successfully installed and run Steam Proton games.

There has to be an easy way to do it?

You need to install ProtonUp-QT in the repos. It will allow you to install different versions of Proton, GE, LutrisGE, Lutris Wine, etc and it puts them in the correct spots so you can find them in both Steam and in Lutris.

Lutris offers a lot of runners. Open up lutris on the left there is a tab with different runners. Next to Wine there is a "box" where you can download different runners for example Lutris 6.21 that offers everything you want.

Ah found the tiny button. What's the difference between 6.21-6 and fshack-6.21-6 ?

Proton isn't normally used with Lutris?

fshack is meant for up-scaling the games resolution to the native desktop so you don't have to mess with linux desktop settings, games that don't run at native resolutions, etc. It also prevents tearing.

Says who? There are several different versions you can use on Lutris, Proton Glorious Eggroll, etc. Lutris can even run Steam's experimental version. I have had many of games that would only run using experimental Proton. You can easily port it over to Lutris, just google how, or use the app I mentioned above to get other versions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.