Using an external usb adapter but not able to install the drivers pls help

Hi iam using an external usb adapter rtl8188ftv
but i dont know how to install the drivers

Welcome
Can you provide your

garuda-inxi

as per the forum template

3 Likes

should I type in the console

yes and enclose it in
.~~~ before
.~~~ after

2 Likes
Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0add137b-73ca-4063-bae5-d0be6cf66053 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: INTEL model: H61 serial: <superuser required>
UEFI: American Megatrends v: 4.6.5 date: 12/07/2020
CPU:
Info: model: Intel Core i5-3470S bits: 64 type: MCP arch: Ivy Bridge
gen: core 3 level: v3 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2668 high: 3600 min/max: 1600/3600 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1597 2: 3402 3: 3600
4: 2076 bogomips: 23148
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13
ports: active: none empty: DP-1,HDMI-A-2,VGA-2 bus-ID: 00:02.0
chip-ID: 8086:0152 class-ID: 0380
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nouveau
v: kernel alternate: nvidia_drm,nvidia non-free: series: 470.xx+
status: legacy-active (EOL~2023/24) arch: Fermi 2 code: GF119/GK208
process: TSMC 28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s lanes: 8
ports: active: VGA-1 empty: DVI-D-1,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:128b class-ID: 0300
Device-3: Microdia USB 2.0 Camera type: USB driver: uvcvideo
bus-ID: 1-1.4:3 chip-ID: 0c45:6367 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.48x10.91")
s-diag: 523mm (20.6")
Monitor-1: VGA-1 model: Dell P2213 serial: <filter> built: 2015
res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2 size: 473x296mm (18.62x11.65")
diag: 558mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.1.7 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 8 bus-ID: 01:00.1
chip-ID: 10de:0e0f class-ID: 0403
Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter type: USB
driver: N/A bus-ID: 2-1.4:4 chip-ID: 0bda:f179 class-ID: 0000
serial: <filter>
IF-ID-1: enp0s26u1u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Samsung Galaxy series misc. (tethering mode) type: USB
driver: rndis_host v: kernel bus-ID: 1-1.2:21 chip-ID: 04e8:6863
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 447.14 GiB used: 22.7 GiB (5.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HM160HI
size: 149.05 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
type: N/A serial: <filter> rev: 0-06 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD3200BEKT-08PVMT1 size: 298.09 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A02 scheme: GPT
Partition:
ID-1: / raw-size: 297.79 GiB size: 297.79 GiB (100.00%) used: 22.7 GiB
(7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 297.79 GiB size: 297.79 GiB (100.00%) used: 22.7
GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 297.79 GiB size: 297.79 GiB (100.00%) used: 22.7
GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 297.79 GiB size: 297.79 GiB (100.00%) used: 22.7
GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 6.73 GiB used: 47.8 MiB (0.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.0 C mobo: N/A gpu: nouveau temp: 50.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 205 Uptime: 1h 45m wakeups: 0 Memory: 6.73 GiB used: 1.91 GiB
(28.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1841 libs: 519
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.21
Garuda (2.6.8-1):
System install date:     2022-08-08
Last full system update: 2022-10-02 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units: ~~~

is this the one?

sir can u help me
?

There seem to be a couple of packages in the AUR repository, as suggested in this topic.
You'll need ethernet or phone tethering connection.
To install from AUR use paru <package name>

4 Likes

it look like you need to install 8192eu-dkms from the aur

2 Likes

how do i do it

can u pls guide me

Unfortunately, in any Arch-based distribution, "guiding" is the wrong approach. It may work once but a few hours later you may need more help.
As for paru, the only advice is that it will show you a preview of the PKGBUILD. Press q to exit and confirm to proceed with the installation.

3 Likes

As filo instructed use

paru <package name
in the terminal and use octupi to find the package you need

3 Likes

no no thats not what i meant i dont know how to do it

dkms install 8188fu/${1%%-*}
}

pre_upgrade() {
pre_remove ${2%%-*}
}

post_upgrade() {
post_install ${1%%-*}
}

pre_remove() {
dkms remove 8188fu/${1%%-*} --all
} ~~~ should i type anything?

See above.

3 Likes

Careful here.
You correctly updated your system but have not rebooted.
This is important in this case, due to the new kernel you'll have now.

3 Likes
-> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
==> Image generation successful
(4/8) Foreign/AUR package notification
=> No foreign/AUR packages found.
(5/8) Orphaned package notification...
lib32-json-glib 1.6.6-2
lib32-pcre 8.45-3
lib32-rest 0.8.1-4
python-nspektr 0.4.0-2
(6/8) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/locale.gen.pacnew
Please check and merge
(7/8) Performing snapper post snapshots for the following configurations...
==> root: 14
(8/8) Syncing all file systems... ~~~

what should i do after this

It should be finished. You should have the terminal prompt ready after that.
If there were no error messages, try rebooting.

2 Likes