Using 2nd GPU with monitor causes system to become slow or blank screen

Hello there!
I'm not used to linux yet. Garuda is my first distro since I ditched Windows as my primary. Please be gentle :slight_smile:

I'm having an issue that looks like I cannot google-fu myself out of. When trying to use a GPU card I recently installed (it's the Device-1: AMD Juniper XT [Radeon HD 5770]) the system becomes unusable. Either it is extremely slow that it's not countable in FPS but more in seconds per frame (cursor movement seems unaffected funnily enough) or it just has blank output and I need to reboot with cable plugged back in integrated GPU (Device-3: AMD Raphael).

The card itself is sitting happily in the computer, as long as it doesn't have an output connected it seems to not cause any issues.

I tried updating the OS and toggled the preferred graphics output from iGPU to eGPU in BIOS. No improvement. Also, switched the 5770 with another AMD card but it had the exact same behavior.

There is a Nvidia plugged in (Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB]) but it is used as pass-through IOMMU card and doesn't load / initialize with Garuda, I think it can be safely ignored for now. I've also tested booting up with the 1060 removed from the computer and it didn't change anything. In case it helps:

nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA
driver is installed and running.

that's fine I think since I'm trying to use an AMD GPU.

As far as I can tell it seems like the drivers for AMD are being used...
Here's the garuda-inxi:

System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=40fa0984-99cd-4310-a32f-915584c29f3a rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a36614fb-3d88-49e3-9062-fede76fac01d loglevel=3 amd_iommu=on
iommu=pt vfio-pci.ids=10de:1c03,10de:10f1 video=efib:off ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B650-PLUS WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 0613
date: 09/22/2022
CPU:
Info: model: AMD Ryzen 7 7700X bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022 process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 2266 high: 5539 min/max: 400/5573 boost: enabled
scaling: driver: amd-pstate governor: schedutil cores: 1: 5539 2: 5151
3: 400 4: 400 5: 400 6: 400 7: 5539 8: 400 9: 5376 10: 400 11: 400 12: 400
13: 2757 14: 2769 15: 400 16: 5539 bogomips: 143728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Juniper XT [Radeon HD 5770] driver: radeon v: kernel
alternate: amdgpu arch: TeraScale-2 code: Evergreen process: TSMC 32-40nm
built: 2009-15 pcie: gen: 2 speed: 5 GT/s lanes: 16 ports: active: none
empty: DP-1, DVI-I-1, DVI-I-2, HDMI-A-1 bus-ID: 01:00.0 chip-ID: 1002:68b8
class-ID: 0300 temp: 36.0 C
Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte
driver: vfio-pci v: N/A alternate: nouveau,nvidia_drm,nvidia
non-free: 525.xx+ status: current (as of 2022-12) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.0
chip-ID: 10de:1c03 class-ID: 0300
Device-3: AMD Raphael driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: DP-2 empty: HDMI-A-2 bus-ID: 0d:00.0 chip-ID: 1002:164e
class-ID: 0300 temp: 36.0 C
Display: x11 server: X.Org v: 21.1.5 with: Xwayland v: 22.1.6
compositor: kwin_x11 driver: X: loaded: radeon unloaded: amdgpu,modesetting
alternate: fbdev,vesa dri: radeonsi,r600 gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
s-diag: 581mm (22.86")
Monitor-1: DP-2 mapped: DisplayPort-1 model: Samsung C49RG9x
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 41 gamma: 1.2
size: 1190x340mm (46.85x13.39") diag: 1239mm (48.8") modes: max: 1920x1080
min: 720x400
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon Graphics (gfx1036
LLVM 14.0.6 DRM 3.48 6.0.12-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Juniper HDMI Audio [Radeon HD 5700 Series]
driver: snd_hda_intel v: kernel pcie: bus-ID: 1-6:3 gen: 2
chip-ID: 045e:070f speed: 5 GT/s class-ID: 0300 lanes: 16 bus-ID: 01:00.1
chip-ID: 1002:aa58 class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte
driver: vfio-pci alternate: snd_hda_intel pcie: gen: 1 speed: 2.5 GT/s
lanes: 4 link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.1
chip-ID: 10de:10f1 class-ID: 0403
Device-3: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0d:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-5: Microsoft LifeChat LX-3000 Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: c000 bus-ID: 08:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 09:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp9s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-5:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 88.68 GiB (4.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 5B2QGXA7 temp: 34.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 5B2QGXA7 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 863.06 GiB size: 863.06 GiB (100.00%)
used: 88.68 GiB (10.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:6
ID-3: /home raw-size: 863.06 GiB size: 863.06 GiB (100.00%)
used: 88.68 GiB (10.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-4: /var/log raw-size: 863.06 GiB size: 863.06 GiB (100.00%)
used: 88.68 GiB (10.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-5: /var/tmp raw-size: 863.06 GiB size: 863.06 GiB (100.00%)
used: 88.68 GiB (10.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 68.15 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:8
ID-2: swap-2 type: zram size: 61.96 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.0 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: amdgpu temp: 36.0 C device: radeon temp: 36.0 C
Info:
Processes: 344 Uptime: 2h 13m wakeups: 0 Memory: 61.96 GiB
used: 5.01 GiB (8.1%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1393
libs: 419 tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.10-1):
System install date:     2022-12-04
Last full system update: 2022-12-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Let me know if you need more info. Thanks in advance for your time :v:

Update: It might just be me and very bad luck, but it seems I cannot even get to BIOS using the 5770 (nor the other AMD card I tried). Either my mobo hates AMD or I just have 2 dead cards somehow ???
I'll try testing some more tomorrow.

Just to start at the bottom of the stack: are you relatively certain your PSU is up to the task? Adding a new graphics card can add another few hundred watts to the power draw, depending on the model.

If you're not sure, build up your PC on PC parts picker or similar and see where they ballpark your wattage, then double-check how your PSU is rated. If you are cutting it close, I would upgrade the PSU before using the new card.

1 Like

Hi @BluishHumility , yes the PSU should be strong enough to feed everything: it's a 1050w from Rosewill. Both the 1060 and the 5770 are only 6-pin power cards. PC part picker build estimates 491w.

Also, I tried to boot without the 1060 in (leaving only the 5770) and still same result.

[Update] Seems the problem might not be entirely OS related.
After testing, my observation is that the motherboard cannot POST or get to BIOS using only the discrete GPU (tested multiple cards, powered and non-powered). If I have a display-cable connected in the motherboard video-out it behaves normally but if I simply unplug the cable or connect it to the GPU and try to boot ... no go. I dunno were to go from here. :sweat:

Hey, partially good news, I can now boot over Displayport using the 1060GPU (which is not what I want because it's my IOMMU GPU) but I can now see the BIOS and POST using a DP on 1 of the GPUs.

To get the 1060 to work I had to use the Nvidia firmware update tool for DP 1.3/1.4 NVIDIA Graphics Firmware Update Tool for DisplayPort 1.3 and 1.4 Displays

I now notice the following, the GPU I actually wanted to use for Garuda, the 5770, is not cooperating. Here's what I see with lspci -nnk

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770] [
1002:68b8]
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:2543]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

however it seems only Nvidia stuff in able to be installed in Garuda?
Screenshot_10

Is that the issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.