Usb freezes my msi laptop

Hello.
I have usb freezes after a while. i mostly type in allacrity with heavily customized neovim
Freezes happen always, when I use allacritty, Konsole or just browsing.

I upgraded system on 2021-09-23

My laptop it MSI 7RG Apache Pro 32GB RAM 256GB SSD Drive nvidia GTX 1070

Garuda user around a year
Steps I took:

  • upgrade of bios
  • detached external monitor, mouse and keyboard
  • pacman -Syyu
  • reboot

Boot from older kernel - no freeze, but some graphic artifacts in alacritty and slower experience

Post your terminal/konsole in- and output as text (no pictures) from:

System:    Kernel: 5.14.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=42030acc-70ad-4a54-b325-a8b55e2725e2 rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Console: tty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Micro-Star product: GE72MVR 7RG v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Micro-Star model: MS-179C v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E179CIMS.30E
           date: 03/15/2018
Battery:   ID-1: BAT1 charge: 44.2 Wh (100.0%) condition: 44.2/53.4 Wh (82.7%) volts: 12.2 min: 10.9 model: MSI Corp. MS-179C
           type: Li-ion serial: N/A status: Full
CPU:       Info: Quad Core model: Intel Core i7-7700HQ socket: U3E1 bits: 64 type: MT MCP arch: Kaby Lake family: 6
           model-id: 9E (158) stepping: 9 microcode: EA cache: L1: 256 KiB L2: 6 MiB L3: 6 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44798
           Speed: 1400 MHz min/max: 800/3800 MHz base/boost: 2700/8300 volts: 0.9 V ext-clock: 100 MHz Core speeds (MHz):
           1: 1400 2: 1400 3: 1559 4: 2703 5: 3544 6: 3601 7: 3688 8: 2146
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:591b
           class-ID: 0300
           Device-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] vendor: Micro-Star MSI driver: nvidia v: 470.74
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1ba1 class-ID: 0300
           Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: DP-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
           OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes
Audio:     Device-1: Intel CM238 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:a171 class-ID: 0403
           Device-2: Plantronics Plantronics C320-M type: USB driver: plantronics,snd-usb-audio,usbhid bus-ID: 1-4.4:8
           chip-ID: 047f:c025 class-ID: 0300 serial: <filter>
           Sound Server-1: ALSA v: k5.14.7-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.37 running: no
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Rivet Networks driver: ath10k_pci
           v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280
           IF: wlp2s0 state: up mac: <filter>
           Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000
           bus-ID: 03:00.0 chip-ID: 1969:e0b1 class-ID: 0200
           IF: enp3s0 state: down mac: <filter>
           IF-ID-1: br-4ea8cab7f2cb state: up speed: 10000 Mbps duplex: unknown mac: <filter>
           IF-ID-2: br-93daac64b09f state: up speed: 10000 Mbps duplex: unknown mac: <filter>
           IF-ID-3: br-9a1fcbc684ff state: up speed: 10000 Mbps duplex: unknown mac: <filter>
           IF-ID-4: docker0 state: down mac: <filter>
           IF-ID-5: veth0e38c59 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-6: veth1235d0c state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-7: veth3fbfbae state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-8: veth6f2190c state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-9: veth7a8935d state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-10: vethe020ec7 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-11: vethfad7641 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-12: vethfc796e9 state: up speed: 10000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-10:5 chip-ID: 0cf3:e300
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:    Local Storage: total: 1.14 TiB used: 206.75 GiB (17.7%)
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: RBU-SNS8152S3256GG5 size: 238.47 GiB block-size:
           physical: 512 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter> rev: 01.R temp: 52 C
           scheme: GPT
           SMART: yes state: enabled health: PASSED on: 147d 15h cycles: 1675 read: 37.77 TiB written: 8.53 TiB
           ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS721010A9E630 family: Travelstar 7K1000
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD rpm: 7200
           serial: <filter> rev: A3U0 temp: 32 C scheme: GPT
           SMART: yes state: enabled health: PASSED on: 117d 13h cycles: 1670
Partition: ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 206.75 GiB (86.8%) fs: btrfs block-size: 4096 B
           dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat block-size: 512 B
           dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 206.75 GiB (86.8%) fs: btrfs block-size: 4096 B
           dev: /dev/sda2 maj-min: 8:2
           ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 206.75 GiB (86.8%) fs: btrfs
           block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
           ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%) used: 206.75 GiB (86.8%) fs: btrfs
           block-size: 4096 B dev: /dev/sda2 maj-min: 8:2
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 60.5 C mobo: 27.8 C gpu: nvidia temp: 55 C
           Fan Speeds (RPM): N/A
Info:      Processes: 311 Uptime: 2m wakeups: 1 Memory: 15.51 GiB used: 3.48 GiB (22.4%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 alt: 10 clang: 12.0.1 Packages: pacman: 1413 lib: 349 flatpak: 0 Shell: fish (sudo) v: 3.3.1
           default: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.06

Thanks in advance!
Tom

1 Like

I'm not a Nvidia expert (I never had one), but I see nvidia v: 470.74 is recent and is maybe causing troubles, e.g.:
https://bugs.archlinux.org/task/72197
and fixes (470.74-2 from yesterday):
https://archlinux.org/packages/extra/x86_64/nvidia/
My suggestion would be to install the linux kernel (I don't know if the zen kernel might play a role in this) and update the system.

2 Likes

Thank a lot!
You directed me to the right path.
It's nvidia issue
I switched to hybrid mode and nomodeset
Allacritty is horribly slow but Konsole is super fast
I plan to test various settings and let you know

I will look into driver nexl
Tom

1 Like

I think it's nvidia driver...

Now I have

ā•°ā”€>$ nvidia-smi 
Sat Sep 25 13:31:31 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 465.31       Driver Version: 465.31       CUDA Version: 11.3     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| N/A   52C    P0    38W /  N/A |    207MiB /  8119MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       671      G   /usr/lib/Xorg                     116MiB |
|    0   N/A  N/A      1442      G   /usr/bin/kwin_x11                   1MiB |
|    0   N/A  N/A      1541      G   /usr/bin/plasmashell               44MiB |
|    0   N/A  N/A      1949      G   /usr/bin/krunner                    8MiB |
|    0   N/A  N/A      2769      G   /usr/bin/latte-dock                26MiB |
|    0   N/A  N/A      6291      G   /usr/lib/firefox/firefox            1MiB |
+-----------------------------------------------------------------------------+

Stopped freezing
Freezes occured at the nvidia driver 170.xx

Tom

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.