USB fails to boot

I'm a longtime arch user and have been using linux for over 20 years, but this one has me a little stumped. I created a bootable USB using etcher in an Arch installation, all was reported well. Image is the i3 one as I am installing on an older laptop and would like the low memory usage. This machine boots arch by default, and has a Pop_OS installation, both of which boot. I've disable secure boot and it defaults to UEFI. This is a Lenovo ThinkPad X1 Carbon (2nd gen I think). So, boot menu comes up, options are:
GRUB
Syslinux
Syslinux
Pop_OS!
Grub boots the arch installation. Pop_OS boot that fine. The other two options produce a flash on the screen and then return to the menu. So I can't seem to book the live USB.

Suggestions? Would love to try out Garuda.

Take Ventoy, check the sha256sum.

Please, post inxi -Faz from this laptop or garuda-inxi from live ISO.
I am correct, installation work?

BTW, welcome :slight_smile:

2 Likes

Disable CSM / Legacy Mode on your firmware.

1 Like

It is already in UEFI-only mode. I've followed all the installation/download page instructions.

inxi -Faz :

System:
  Kernel: 5.18.16-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/vmlinuz-linux
    root=UUID=50983af5-fe5a-40f7-9267-4838ccbb0882 rw
    resume=UUID=54e8de87-dec2-4bde-8494-c29a70453024 loglevel=3 quiet
  Desktop: N/A vt: 1 dm: startx Distro: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 3444FEU v: ThinkPad X1 Carbon
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 3444FEU v: Win8 Pro DPK TPG
    serial: <superuser required> UEFI: LENOVO v: G6ETA3WW (2.63 )
    date: 02/19/2014
Battery:
  ID-1: BAT0 charge: 21.4 Wh (99.1%) condition: 21.6/46.0 Wh (46.9%)
    volts: 16.3 min: 14.8 model: SMP 45N1071 type: Li-poly serial: <filter>
    status: charging
CPU:
  Info: model: Intel Core i7-3667U bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1477 high: 2993 min/max: 800/3200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1041 2: 839 3: 1036
    4: 2993 bogomips: 19960
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-1.6:6 chip-ID: 5986:0266 class-ID: 0e02
  Display: server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: LVDS-1 mapped: LVDS1 model: LG Display 0x0382 built: 2012
    res: 1600x900 hz: 60 dpi: 131 gamma: 1.2 size: 310x170mm (12.2x6.69")
    diag: 355mm (14") ratio: 16:9 modes: 1600x900
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.16-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: no
Network:
  Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702 Bluetooth 4.0 [ThinkPad] type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.4:5 chip-ID: 0a5c:21e6 class-ID: fe01
    serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 242.15 GiB used: 183.44 GiB (75.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD5SG2256G1052E
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4.01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Lexar model: USB Flash
    Drive size: 3.67 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 0100 scheme: MBR
Partition:
  ID-1: / raw-size: 198.7 GiB size: 194.53 GiB (97.90%) used: 183.14 GiB
    (94.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot raw-size: 512 MiB size: 511 MiB (99.80%) used: 307 MiB
    (60.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 9.97 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 65535 fan-1: 0 fan-2:
Info:
  Processes: 148 Uptime: 2h 40m wakeups: 1 Memory: 7.59 GiB used: 1.12 GiB
  (14.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1289 lib: 264
  Shell: Bash v: 5.1.16 running-in: urxvt inxi: 3.3.20

Will try Ventoy now.

Also, this is just to boot the live USB. Haven't booted that to get to installation yet.

No luck with Ventoy. No option for USB drive to boot. Still the same 4. Should I maybe edit the GRUB menu that boots Arch?

If you are getting to the GRUB menu (or the systemd-boot menu for Pop_OS), you are going too far.

Every BIOS menu is a little bit different and has different settings, etc so it's hard to know exactly what you need to change. This page here offers a clue: How to change the boot order in BIOS for Windows 7, 8, 8.1, 10, and 11 - Lenovo Support US

  1. Note: The steps listed below are for the example BIOS only; your computer's BIOS may be slightly different.

BIOS example
2. To change which device to boot from first, follow the directions on the BIOS setup utility screen to change the boot order.

BIOS screen
3. In this example the boot order can be changed using the + and - keys. Remember, your BIOS may have different instructions.
4. By using the + and - keys the example changes the CD-ROM Drive to the top of the Boot Order**.**
5. Using F10, Save and Exit, saves all actions and exits, or navigate to the Exit tab and save changes.

Note: USB drive does not appear as an option in the list, even though the computer has USB ports. If a USB device is connected to the computer before starting the computer and accessing this screen, the USB drive option will show in the list. Some computers display the USB drive option even when a drive is not connected.

According to that, the USB drive needs to be connected when you enter the BIOS menu, then you can go to the boot options and push it to the first item in the boot order. Then save and exit, and it should boot to Ventoy.

1 Like

That's what I figured I would see, but my "BIOS" doesn't look like that. It's Setup Utility that looks like this:

And then the Startup menu looks like this:

The UEFI/Legacy boot item allows UEFI only, Legacy only, or Both options. Suffice it to say I've tried all configurations. I also tried a different USB. So I'm a bit stumped.

You might want to check and see if there is a BIOS update available, as this one is rather long in the tooth.

  • Boot Order Lock - if you disable this, does it expose any options for manipulating the boot order?
  • Boot device List F12 Option - what are the options if you hit F12?

:point_up_2: Maybe a combination of both? :thinking:

In your Arch or Pop installation, what is the output of

efibootmgr

(run as root or sudo)?

7 Likes

Try using F12 button. Pressing it multiple times as soon as you boot the machine (before getting into the menu you described).

3 Likes

If you really cannot make it with the USB, since you have GRUB for Arch, you could add a menu entry for the ISO file in your /boot/grub/custom.cfg taking the cue from this (I've learned this trick from @SGS and I must say it's very handy :blush:):

3 Likes

By the way, no sudo update-grub is required when creating or modifying this file. It is automatically read by grub at boot time.

3 Likes

F12 yields the list of options as described in original post.

Have you tried a different usb stick as it should show up?

3 Likes

In Ventoy, if GPT doesn't work, try MBR. If it still doesn't work with MBR, enable CSM in BIOS and try again. Enabling CSM doesn't explicitly disable the ability to go UEFI, but it can make some boot devices viable. Another [not great] option is Rufus on WIndows (try GPT first!). You can choose advanced options, and select 'add fixes for old BIOSes (extra partition, align, etc.)'.

What are the options for 'boot mode' that is currently set to 'diagnostics'? Have you confirmed the BIOS is up to date? What about the result of sudo efibootmgr per BluishHumility?

2 Likes

Thanks @BluishHumaity for the efibootmgr suggestion. I had the GRUB set as the first thing to boot. Changed it to USB HDD and all booted fine.

I installed into an existing partition, now trying to figure out how to get Garuda into the GRUB menu, but that should be a different post. But does the btrfs mess with GRUB?

Thanks again everyone, great community, looking forward to using Garuda.

3 Likes

I mark the solution, tell me if I am wrong. :smiley:

Oh that's how you do that! That's the closest to the solution, I added my addition to that which is the actual description.

1 Like

OS not installed to BTRFS cannot detect OS installed to BTRFS.

Do the other way around: Add other OS to Garuda GRUB.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.