US International keyboard layout suddenly changed?

Hi everybody.
I'm an Italian user, but I feel more comfortable with US International keyboard layout
Some weeks ago I noticed a change in my keyboard layout behavior:

  • before: to get the apostrophe ' I had to hit the single quote key then space
  • now: the same combo give me a single quote ´ and to get the apostrophe I have to use Option/Alt + single quote key

keyb

since in Italian apostrophe is often used, it's a bit unpleasant
I have several linux distros on my computer, all of them affected by this change at the same time; so I tend to exclude I messed up anything on settings; in windows partition, same layout but all works as before
I tried to search on the web, nothing about this
I use an Apple Magic Keyboard, but I think it's not relevant: always worked well

any suggestion? what should I check?

Seems you do not check the history which files changed.

Seems you use arch not Garuda, do you ask in arch forum?
Do you search in arch wiki?
Did you ask in every other forum too?

What was your search term?

1 Like

sorry SGS, but if I were able to solve by myself I wouldn't have asked..
and no, I'm not using Arch - I actually use Garuda 'cause I like it, so of course I started asking here; different distros are fallback options, sometimes
yes, of course, after some time spent on the web searching for any change in us international keyboard layout on linux; but I found many pages about different us international trouble/questions, nothing about this
what is wrong?
I asked for a hint about where I can start to check.. if somebody can

Add the suffix arch linux to the search term.
Otherwise you'll end up at Ubuntu, Mint, or anywhere else.

2 Likes

I saw this :

https://discuss.getsol.us/d/6697-problem-rendering-apostrophe-after-update
hopefully helps

and also

https://discuss.getsol.us/d/6711-modify-keyboard-layout-after-physical-remapping
not sure if either is directly helpful to you but perhaps a start?

2 Likes

Maybe you 've got it wrong.

The combinations you mention do not refer to the printed symbol. Do you know about the similar symbols, like apostroph, backtick, single quote, double quote?
In English layout (mine, at least), the highlighted key in your image still prints a single quote (no Alt or space required).
Alt + key and space prints nothing but a space (it is usually assigned to keyboard shortcuts), but AltGr (Composition key) + key and space might print whatever your layout has (Greek polytonic has several combinations using "Composition" key).

Now, if you think that the behavior has changed, my mind can only go to Apple (firmware/driver?), as it can not be confirmed/reproduced in other systems.

If there was a change on the keys layout, it would have been noticed from someone, because a lot of users globally use those keys/symbols.

And, of course, it could be a HW problem :man_shrugging:

I suggest you do some more digging (read about keyboard layouts, the combinations can be found into some system files) and testing.

1 Like

thanks to everybody for your hints
I found the issue: it was related to an update in gtk3 package (version 3.24.28) which broke the previous behavior
here discussion and solution: Regression: Can no longer type apostrophes / single quotes (#3807) · Issues · GNOME / gtk · GitLab
hard to discover because ultra-specific: it was affecting neither us intl layout nor dead keys, but only the apostrophe
so, as I was thinking before, remapping keys would have been a temporary solution
at the time I was writing the first post, the solution was in progress, and now gtk3 new version (3.24.29) reverted back the layout behavior, and it's working fine again
thank you again!

6 Likes

Nice detective work.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.