Updated Garuda Linux and Elden Ring's EAC won't let me play now. Reinstalled game and lost save files because didn't backup

So yesterday I had updated my pc using the konsole command garuda-update. System wise there was no issue. But, then I tried to launch "Elden Ring" as I am like 2 bosses away and 93 hours in the game. I get the Easy Anti Cheat splash screen for when it loads and it stated that "Easy anticheat failed to launch". So i tried to go around looking to see if anyone else had this issue and the only thing I saw was some guy on Proton DB's website saying that he deleted the folder for "Elden Ring" and it resolved the issue. For me it did not. I not only tried that but also uninstalled and reinstalled the game. So i used snapper instead to revert before the update and the game did launch just fine and without issues, BUT my dumb ass dint make a copy off site of my PC for that file for "Elden Ring" that had its save file so i think either the revision or the EAC not launching deleted my save file. To make it worse my steam cloud version UPDATED to not having a save file and i was totally screwed.

For those out there reading here's today's quote: "Bro it's been 100 hours of this game I just want to update my PC"

Oh and uh I was used to time-shift before but when i did a clean install was using snapper and didn't realize the nuances of how it differed and thought it was like a full on ISO snapshot but no it just saves some things but not others so my foolishness caused like 5 points of failure. So for anyone close to beating the game and that want to update their system...watch out or the EAC will give you the most brutal of game deaths....

PS. I used multiple proton Ge variants and the experimental one as well and that didnt fix the EAC failing to load.

If you are on an HDD it may be possible to recover the files.

If you are on an internal SDD you're screwed.

DRM sucks, it screws over the the people that bought the game more than pirates.

Same with things like EAC. Screws over legit players more than cheaters.

1 Like

Try reinstalling Proton EAC Runtime from Steam. If it doesn't work, use gamemoderun to launch Elden Ring.

1 Like

It was on a Samsung SSD drive. Oh well guess in a few years when my anger over this subsides i can do another 100 hours lol.

1 Like

If Garuda doesn't support the TRIM command (I highly doubt it doesn't have TRIM) then recovery is still possible if it didn't get overwritten. HDDs don't have TRIM because overwriting blank space is the same as overwriting non empty space. For SSDs this is not the case, that's why TRIM was invented. Very early SSDs also don't support TRIM.

TRIM is essential for good performance anyway.

Is what it seems to be.

5 Likes

i solve this for now by restoring a snapshot, it was the binutils update for me that update the glibc.

So downgrading only binutils resolves the issue? That is important info, you should post your findings to the link Ataboi posted.

Relevant:

2 Likes

I just noticed TKG created a "fixed" glibc PKGBUILD, trying to compile it right now :eyes:

4 Likes

Oh snap I hope it works out well lol