Update proplem, Super Noob, New to Garuda Linux as of 1 hour ago

Hello wonderful people, absolute noob here.

Just fus-ro-dah’d Windows 10 for Garuda Linux, after watching a few YouTube videos,
it is my first time booting straight after clicking install on the boot manager, now i am in the deep end with this update error.

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

I have searched up my issue an i have to do this pacman -Syu jdk-openjdk but have no idea how to do this as i am very new to all of this.

Also when i went to create this topic it suggested i do this command “garuda-inxi” to give a text file i can upload here of details needed in order to get assistance however i have no idea do to either can someone please help me cheers.

In the terminal. Honestly, if you don’t even know where you run Linux commands then you should go and learn the basics of Linux before.

type that into the terminal and copy pasta the output according to the instructions in the template you deleted before you made this post.

also search the forums here before asking for help, you may usually find what you need without assistance =-)

1 Like

be gentle with newbs lol, they’re coming from an environment where Bill Gates holds everyone by the [mod edit] after holding their hand.

1 Like

Thank you mate, I hope i have done the right thing, this is a lot of text.

[🔴] × garuda-inxi
Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f21e46d0-1088-433f-af7d-ca435bd6386d rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: X570 AORUS XTREME v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS XTREME serial: <superuser required>
UEFI: American Megatrends LLC. v: F37f date: 09/20/2023
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA20102B
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3416 high: 3927 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3400
3: 3400 4: 3400 5: 3400 6: 3400 7: 3400 8: 3400 9: 3400 10: 3927 11: 3400
12: 3400 13: 3400 14: 3400 15: 3400 16: 3400 17: 3400 18: 3400 19: 3400
20: 3400 21: 3400 22: 3400 23: 3400 24: 3400 25: 3400 26: 3400 27: 3400
28: 3400 29: 3400 30: 3400 31: 3400 32: 3400 bogomips: 217606
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Navi 21 [Radeon RX 6900 XT] vendor: Tul / PowerColor
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-3
empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0c:00.0 chip-ID: 1002:73af
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
s-diag: 1165mm (45.88")
Monitor-1: DP-3 mapped: DisplayPort-2 model: Philips PHL BDM4350
serial: <filter> built: 2019 res: 3840x2160 hz: 60 dpi: 102 gamma: 1.2
size: 953x543mm (37.52x21.38") diag: 1097mm (43.2") ratio: 16:9 modes:
max: 3840x2160 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6900 XT (navi21 LLVM
16.0.6 DRM 3.54 6.5.9-zen2-1-zen) device-ID: 1002:73af memory: 15.62 GiB
unified: no
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: discrete-gpu name: AMD
Radeon RX 6900 XT (RADV NAVI21) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:73af surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion]
vendor: Gigabyte driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 2 link-max: lanes: 4 port: N/A bus-ID: 04:00.0 chip-ID: 1d6a:d107
class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp6s0 state: down mac: <filter>
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:4 chip-ID: 8087:0029
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 946.51 GiB used: 7.42 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QGXA7 temp: 34.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 model: SRT USB 3.0 JET 16G size: 15 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s
lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: 1100
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 7.42 GiB (0.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 7.42 GiB (0.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 7.42 GiB (0.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 7.42 GiB (0.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
System Temperatures: cpu: 40.5 C mobo: N/A gpu: amdgpu temp: 35.0 C
mem: 36.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Processes: 560 Uptime: 49m wakeups: 0 Memory: total: 32 GiB
available: 31.26 GiB used: 3.66 GiB (11.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1772 libs: 522 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-11-10
Last full system update: 2023-11-10
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:            systemd-vconsole-setup.service

Yes it is, just remember that when pasting terminal text on forum wrap it in
terminal text here
like this
it makes it appear like this,

terminal text here

I did it for you on your previous post. :smiley: This just makes terminal text easier to read for us all.

Btw, gotta mention, to update your system always use the command


from terminal. Use pacman or any other GUI software as per your convenience to install new software.


that’s the info, thank you.
it looks like someone corrected the format, using 3 grave symbols before and again after the body of text so it looks contained and is easier to read and deal with.

1 Like

Gentle with what? Someone asking where commands are executed on Linux is simply because hasn’t made any effort to search in Google.

Ok, now go and run the command to resolve your problem in the terminal, that’s it.

Thank you mate, i appreciate the assistance, i have run the command


run in to the problem i am posting about, applied the fix

pacman -Syu jdk-openjdk

It gives me another error: you cannot perform this operation unless you are root.

How do i do this cheers.

Run it as root, go and read in Google how you run commands as root.


Take a look at the already opened posts here and see if they help you,

btw, eduard as rude as he is, is right on this one. He is the more rude version of try to google it. To run commands as root you append sudo before them, → sudo - How do I run a command as the system administrator (root) - Unix & Linux Stack Exchange

1 Like

You said it, an assistance thread, not a babysitter thread.


That seems to have escalated quickly. I agree we should be more friendly to people, especially since it seems this particular human seems to have tried. It doesn’t fit our philosophy to be a second Arch forum (though there are of course certain limits) :face_with_monocle:

Seeing that we seem to struggle to find new contributors made me think about what’s the reason for a while :frowning:


Yeah, I could probably be kinder & gentler, myself. Which does not fit into the philosophy of the person who initially gave me of his knowledge and experience in learning Linux. Mostly he reminded me that I was the student, not the teacher, and if I wanted his help I needed to do the work–all of it, not just the initial footwork–he didn’t have the time to mess around (he passed 2 years later). So I did, he did, then we did.

But I’m of an older generation–there were so many of us Boomers–and perhaps things are different now. I do know two things.

  1. If someone has fire in their belly to learn, I’m there, just like my mentor was for me.
  2. If they want to be spoonfed, they’re going to have to feed themselves. Now I’m the one short on time.

I love Linux. I love Linux learners more. But, God, I love Linux. :heart:


Well, the person didn’t make at least one effort.

  1. Asking where you should run a command on Linux? Seriously? That’s like the first thing that you learn about Linux, where you run a command.
  2. So, he was able to run garuda-inxi and then I sent him to run it on the same terminal. The terminal tells clearly: you cannot perform this operation unless you are root., can’t you do a quick google search?

People that come here with this kind of questions and problems, showing the least effort to learn by itself will simply end up filling the forum with meaningful “issues” simply by no reading a clear message error or not taking the time to, yes, Google it.

And, additionally insulting people because they are sent to read? Let’s no feed help vampires, thanks.