Jdk-openjdk and jre-openjdk are in conflict with each other

have just received an update
conflict message
and cannot solve the problem

via terminal: sudo pacman -Syu
jdk-openjdk and jre-openjdk are in conflict with each other

What options do I have - where can I find
a solution ?

ps. have been using garuda successfully for > 1.5 years -
do not use games,
only in the office area, some multimedia, databases

Many thanks for possible solutions


Welcome :slight_smile:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Syu jdk-openjdk and this removes the JRE related packages.

When I try doing that it says you cannot perform this operation unless you are the root, and when I find fixes online like it says to do sudo Pac-Man -Syu but it still doesn’t work, I’m a admin and this is the only user on my pc

You must use sudo when adding or removing programs with Pacman, even if you are the only user.

If you are trying the instructions in this thread but still can’t get it working, paste the full terminal input and output into the thread so we can see what is going wrong.

1 Like

Using sudo and doing that only made the root problem better but besides that it basically just repeated the same thing and gave me the same error. I found a fix however, instead of using -Syu use -Sy. sudo pacman -Sy jdk-openjdk which then it actually asks you if you want to delete the other files and everything works fine now


Many thanks

the input of -Sy jdk-openjdk

I uninstalled jdownloader and after the
update and reinstalled jdownloader.
Probably the cause of the conflict ? ( java-problem)

best regards


This helped, I’ve been on this for days now. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.