Update: Poppler conflict

Hi! When trying to update my system, the process gets as far the error message ' poppler-git and poppler are in conflict. Remove poppler? Regardless of wether I respond with Y or,N, I get unresolvable package conflict and failed to prepare transaction. Which is the end of the update process.
Manual intervention?

Which system?
garuda-inxi missing.

No problem here

Just remove installed and install after what you need.

4 Likes

This post neither includes a garuda-inxi nor does it include the terminal output logs.

Sorry, but, what do you expect to get from this forum post?

4 Likes

What actually is this poppler? I didn't install it. Is it a necessary system app?

pacman -Qi poppler

Ok ok, I know. I was writing this question on my smartphone, quoting the output I got on my computer. And I thought the quotes of the output I saw while running the updates were clear enough .....

So after googling, I understand that it is a tool that is used by a number of programs that work with PDFs. Means I will break those when I uninstall it....
The conflict is between poppler and poppler-git. So maybe I will uninstall the latter?

maybe I will uninstall

One of the two has to go, though I'm not sure which one. I think you'd keep the poppler one.
But:

I get unresolvable package conflict

Can you copy paste the exact message? It should say what conflicts with what else.

Ok. Will do later. At the moment there is big download running which consumes most of my bandwidth.

Well. Now I have a bigger problem. Updating to the 5.1.5.86-1-lts Kernel broke my install completely. Will post this as new problem (again from smartphone, I cannot access my Garuda system anymore....

Restore a snapshot and actually provide the info we have asked for.

Restoring snapshot not possible.
The inxi was provided in the other post. Playing around with poppler deleted my Dolphin. Got that reinstalled.
But my system is still a wreck. See the other post....

Then quit wrecking it.

Hi, please search forum for solution before posting.

This problem have been solved a lot of times. See, for example

3 Likes

Thanks for the encouragement. Just as a recap: All I did was do a system update. Order for that to work I uninstalled poppler. Is that wrecking the system? I thought not

You've got a point there. If only I had found that post yesterday. Too bad. But thanks anyway.

No problem.
I am marking this thread as solved now.
Have a good day!

Pretty much. Not taking a moment to wonder what Poppler is or provides, is questionable.

Screwing up and learning from it has kept me running Linux for a while.

Please pardon me.

2 Likes

:+1::grin::+1::grin:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.