Update package manager

yay: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory.

anybody else ?

same error with paru

Same error using garuda-update

error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.1.0-3) breaks dependency ‘libalpm.so=13-64’ required by libpamac-aur
:: installing pacman (6.1.0-3) breaks dependency ‘pacman<6.1’ required by libpamac-aur

https://aur.archlinux.org/packages/yay#comment-961131

The current release of paru works with the new pacman. The aur package still points to the previous release because current release won’t work with old pacman.

The options are use paru-git. Bump the paru pkgbuild yourself, or wait for me to finish walking home.

Nice :grinning:
Paru should be ok now
https://aur.archlinux.org/cgit/aur.git/commit/?h=paru&id=2bfa586c9fbf08144257c1e5c013481d43760e1a

5 Likes

It has been fixed in Testing. Allan got a bit ahead of himself. :wink:

2 Likes

Paru should be fixed, but going back to yay, it can be fixed like here, uninstalling it and building manually (if not using another working helper)

git clone https://aur.archlinux.org/yay.git
cd yay
makepkg -si

https://aur.archlinux.org/packages/yay#comment-961552

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.