Unwanted login screen from Kodi

I just did a system update for the second time. When I reboot I get a full screen Kodi login screen. The only options are ‘Power Options’. There is no way to exit this Kodi program. I have an image.

I’ve been using Garuda for years. Nothing like this has ever happened before. What gives???

You might be loging into the kodi session, as kodi features it’s own session.

You can change it on log in screen, see whether you have log in session as kodi

If yes , then change it !!

Also please give out put of your garuda-inxi for further assistant

5 Likes

Yea this is a know issue of Kodi where it takes over the the login. If you have Kodi installed and don’t have auto-logon enabled and reboot or logoff / on it will go into Kodi. They refuse to correct the behavior.

Amour I cannot exit Kodi from the Kodi login screen . I haven’t used Kodi in years. I can access Kodi options like system and profile. How do I exit Kodi or change my login settings in Kodi to login to my system instead?

Locusts how do I enable /disable auto login from the Kodi app? Do you mean auto login set in the Kodi app?

Use live ISO, than chroot from welcome app, remove kodi.

1 Like

It’s been awhile since I installed Kodi but I do believe when you reboot and haven’t changed the setting in SDDM and you see the Kodi screen during boot or login you can select the default there just like you would on the normal SDDM screen. Then to play it safe under System Settings, SDDM set it to x11 or Wayland as the default.

How do I change the settings in SDDM?

On login screen …


There would might be Kodi as an option in your login screen
chose any other option instead of it !!

I can’t explain any better than this …

1 Like

System Settings, Appearance & Style, Colors & Themes, Login Screen (SDDM), Then click Behavior on the top.

Thank you everyone.
It turns out the control of which system to boot into when using the dragonized theme is a tiny little menu at the bottom left of the login window.