Unstable and slow wifi connection problem

Hello,

here is the output of garuda-inxi

System:
  Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f9bca527-d148-4e99-8b54-d2f186d91b80 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: GNOME v: 42.3.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM
    v: 42.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: F2A68HM-H v: x.x serial: N/A
    UEFI: American Megatrends v: FB date: 04/22/2015
CPU:
  Info: model: AMD A8-7600 Radeon R7 10 Compute Cores 4C+6G socket: FM2 (P0)
    note: check bits: 64 type: MT MCP arch: Steamroller built: 2014
    process: GF 28nm family: 0x15 (21) model-id: 0x30 (48) stepping: 1
    microcode: 0x6003106
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
    desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 1400 min/max: 1400/3100 boost: enabled
    base/boost: 3100/3100 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1400 2: 1400 3: 1400 4: 1400
    bogomips: 24755
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: Gigabyte driver: radeon
    v: kernel alternate: amdgpu arch: GCN 2 process: GF/TSMC 16-28nm
    built: 2013-17 ports: active: VGA-1 empty: DVI-D-1,HDMI-A-1
    bus-ID: 00:01.0 chip-ID: 1002:1313 class-ID: 0300
  Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Micro-Star MSI
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Maxwell process: TSMC 28nm
    built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1401 class-ID: 0300
  Display: server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: nvidia,radeon
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: radeon
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.00x11.26")
    s-diag: 1055mm (41.55")
  Monitor-1: HDMI-0 pos: primary,right res: 1920x1080 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: VGA-1-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 96
    size: 510x287mm (20.08x11.3") diag: 585mm (23.04") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Kaveri HDMI/DP Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Device-3: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fba
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
    driver: r8188eu bus-ID: 2-3:6 chip-ID: 0bda:8179 class-ID: 0000
    serial: <filter>
  IF: wlan0 state: down mac: <filter>
Drives:
  Local Storage: total: 2.04 TiB used: 8.6 GiB (0.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC25 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: GPT
Partition:
  ID-1: / raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 8.6 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 8.6 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-4: /var/log raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 8.6 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-5: /var/tmp raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 8.6 GiB (4.1%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 14.59 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 10.9 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: nvidia screen: :0.0 temp: 54 C fan: 0% device: radeon
    temp: 13.0 C
Info:
  Processes: 221 Uptime: 3m wakeups: 0 Memory: 14.59 GiB
  used: 1.18 GiB (8.1%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1149 lib: 321
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.19
Garuda (2.6.5-1):
  System install date:     2022-07-18
  Last full system update: 2022-07-18
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:   

So, the problem im currently having is that my internet connection only works for couple of seconds when i restart wifi module with garuda network manager or when i boot into garuda, then it just doesnt work, it says that its connected but nothing works, no data being sent when i ping anything. I dual boot windows and the wifi works fine and its where im currently typing this out. Im using a usb wifi adapter since my computer doesn't have a wifi card.

I have tried a bunch of things and ive been searching all day yesterday on the forums how to fix this issue but nothing fixed it. I can't install any packages or anything else because, well, my wifi isnt working. Here are the things i have tried, ive tried disabling wifi power save and mac address randomization, i tried adding nameserver 1.1.1.1 line to a file, i forgot the name of it tho, didnt work, tried changing dns to 8.8.8.8 and 8.8.4.4, didnt work, i have added garuda to my router mac address filtering, didnt work. And now i am just completely lost, im pretty new to linux so i dont have much knowledge on how to do much stuff. Please help!

Welcome :slight_smile:

That's bad.

This too, did you check, disable fast and secure boot.
Sometimes M$ block hardware for other OS.

Moved from #issues-assistance:newbies to #issues-assistance:wifi-ethernet-bt

3 Likes

Thing is, i can't do system updates due to the wifi problem im having and i can't use ethernet

Yes, fast and secure boot is disabled.

You can update via cellphone tethering?

6 Likes

Would you need cellular data for that? I don't have data

Thank you! I didnt even know that it was a thing and its working perfectly fine, now im gonna try and see what i can install like for example drivers for my wifi usb to see if it can fix the problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.