Unresolvable dependencies when downloading


So when I try to install hedgewars I get this error

╭─[email protected] in ~/Downloads took 13s
╰─λ sudo pacman -S hedgewars
resolving dependencies...
warning: cannot resolve "libx264.so=164-64", a dependency of "ffmpeg4.4"
warning: cannot resolve "ffmpeg4.4", a dependency of "hedgewars"
:: The following package cannot be upgraded due to unresolvable dependencies:
hedgewars

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libx264.so=164-64' required by ffmpeg4.4
:: unable to satisfy dependency 'ffmpeg4.4' required by hedgewars

I have done a pacman -Syy and I've refreshed my mirrors but nothing. I have this problem in manjaro as well so it might be something with arch. I am able to download other applications but none that uses the libx364.so=164-164 or ffmpeg4.4.
Any help is appreciated.

No.

Why?

Use last working snapshot, and wait until ffmpeg is fixed.

Please edit your post.
If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.

I move it from #issues-assistance to #issues-assistance:aur-snaps-flatpaks-other

2 Likes

As competent Linux users, one of the first steps we take when encountering situations such as yours is to look for bug reports.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.