Unreal Engine 5.4.2 on Garuda/ archlinux


I’ve installed Garuda with the intent to use steam and unreal-engine. I had one minor issue with the install, where I was unable to use Wayland with my nvidia card due to flickering and other errors, so I changed to X11, other than that my system is a standard “KDE Dragonized Gaming Edition”.

The issue that I have is in regards to unreal-engine.

After fiddling about, i decided to go with AUR (en) - unreal-engine-bin
AUR (en) - visual-studio-code-bin

My issue is that the packages install fine, however the modules for the engine don’t seem to be recognised. Unreal engine linux version support is mostly for Ubuntu 22, and I can’t find any archlinux information.

Due to being a new user I can’t upload images.

The errors that I’m getting is an infinite rebuild loop.

I start the c++ project, I then get a window saying that the modules are missing or built with a different engine version, followed by a list of modules (plugins and main game file), and a Question, if I wish to rebuilt them.

After selecting Yes, then unreal-engine uses the Unreal Build Tool to compile everything from source, after a while I get the error “ could not be compiled. Try rebuilding from source manually”, so I proceed to compile from source, in VScode, which compiles succesfully, after opening the project again, it says same error with modules not compiled.

I have run

sudo chmod -R a+rwX /opt/unreal-engine/Engine
sudo chmod -R a+rwX /home/<unreal-engine projects folder>

So all that I can definitely rule out is that read/write permissions are working.

Compilation wise, Unreal Engine fails to rebuild the project files with Unreal Build Tool, files are being created, and they look to me as being the correct files, however it always says that it has been build for a different engine and need a rebuild.

Hope you can help, as I’m stumped, as I can’t figure out how to progress on this issue other than moving to Ubuntu.


Kernel: 6.9.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=968e428b-61fd-4e31-84b2-b117d8fca139 rw rootflags=subvol=@
quiet resume=UUID=a214afd2-d8f3-4727-96af-7278bfec9680 loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop System: Gigabyte product: Z370M DS3H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: Z370M DS3H-CF v: x.x serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends v: F13 date: 08/13/2019
ID-1: hidpp_battery_0 charge: 57% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
Info: model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF6
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2134 high: 3804 min/max: 800/4600 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 3800 3: 800
4: 3804 5: 3800 6: 800 7: 3800 8: 1815 9: 800 10: 800 11: 3797 12: 800
bogomips: 76799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: Micro-Star MSI
driver: nvidia v: 550.40.63 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 3 speed: 8 GT/s
lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0 chip-ID: 10de:2204
class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
s-diag: 554mm (21.82")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: AOC 2260WG5
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.40.63
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
memory: 23.44 GiB
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 550.40.63
device-ID: 10de:2204 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
chip-ID: 8086:a2f0 class-ID: 0403
Device-2: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:1aef
class-ID: 0403
API: ALSA v: k6.9.5-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Local Storage: total: 3.86 TiB used: 385.48 GiB (9.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 211210WD temp: 38.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: Ultra II 240GB
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00RL scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A750 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT2000BX500SSD1
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 061 scheme: GPT
ID-1: / raw-size: 862.2 GiB size: 862.2 GiB (100.00%)
used: 221.65 GiB (25.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 862.2 GiB size: 862.2 GiB (100.00%)
used: 221.65 GiB (25.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 862.2 GiB size: 862.2 GiB (100.00%)
used: 221.65 GiB (25.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 862.2 GiB size: 862.2 GiB (100.00%)
used: 221.65 GiB (25.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.74 GiB used: 37.5 MiB (0.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
ID-2: swap-2 type: partition size: 69.02 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 59.0 C mobo: 39.0 C gpu: nvidia temp: 48 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Memory: total: 64 GiB note: est. available: 62.74 GiB used: 2.79 GiB (4.4%)
Processes: 375 Power: uptime: 0m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 25.05 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: 2049 pm: pacman pkgs: 2043 libs: 589 tools: octopi,pamac,paru
pm: flatpak pkgs: 6 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-06-05
Last full system update: 2024-06-18
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

I still can’t get this to compile plugins.

I’ve done several rebuilds from the github source.


followed the 4.4 Troubleshooting " Engine modules are out of date, and cannot be compiled while the engine is running. Please build through your IDE" and it didn’t work.

I still get an infinite UE engine rebuild loop.

I’ve run all major VScode rebuilds for the code, Development, Game, Debug, Clean, Rebuild none of them worked.

I’ve run a full recompile of the project and plugins with command

./RunUAT.sh -ScriptsForProject="/<project folder>/test.uproject" BuildCookRun -project="/<project folder>/test.uproject" -noP4 -clientconfig=Development -serverconfig=Development -utf8output -platform=Linux -targetplatform=Linux -build -cook -allmaps -compressed -stage -pak -archive -unversionedcookedcontent -archivedirectory="/<project folder>/"

I’ve created new C++ project, then manually added C++ class into the project, saved then added my own code.

At this point, the only options that I can think of, is either running a virt-manager with windows OS, or outright change OS. The VM option seems to be a hassle since I can’t do GPU passthought readily and makes me think that I will lack performance.

I’ve done installs from unreal-engine-bin, unreal-engine aur’s and github source installs.

Any suggestions or ideas? I really am trying to make this work somehow.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.