Unity Editor not working on kde

Hello.

inxi -Faz
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ef15347e-a4da-4628-afc3-2bff20cbb710 rw
           [email protected] quiet nvidia-drm.modeset=1 splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=e7745511-30a0-4b3d-93c1-4bc3daa8b2b8 loglevel=3
           sysrq_always_enabled=1
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X470 Taichi serial: <filter> UEFI: American Megatrends v: P3.50 date: 07/18/2019
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
           microcode: 800820D cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86395
           Speed: 4025 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 4025 2: 4043 3: 4049 4: 4045 5: 4001
           6: 4041 7: 4050 8: 4012 9: 4027 10: 4047 11: 4001 12: 4024
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia v: 470.63.01
           alternate: nouveau,nvidia_drm bus-ID: 0e:00.0 chip-ID: 10de:1b80 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 6400x2160 s-dpi: 101 s-size: 1608x543mm (63.3x21.4") s-diag: 1697mm (66.8")
           Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 52 size: 1872x1053mm (73.7x41.5") diag: 2148mm (84.6")
           Monitor-2: DP-0 res: 2560x1080 dpi: 81 size: 798x334mm (31.4x13.1") diag: 865mm (34.1")
           OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 0e:00.1
           chip-ID: 10de:10f0 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.34 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus-ID: 08:00.0
           chip-ID: 8086:24fb class-ID: 0280
           IF: wlp8s0 state: down mac: <filter>
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: d000 bus-ID: 0a:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:6 chip-ID: 8087:0aa7
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 619.93 GiB (26.6%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 45.9 C
           scheme: GPT
           ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3B7QCXE7 temp: 31.9 C
           scheme: GPT
           ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
Partition: ID-1: / raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 131.26 GiB (60.9%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:3
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:2
           ID-3: /home raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 131.26 GiB (60.9%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:3
           ID-4: /var/log raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 131.26 GiB (60.9%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:3
           ID-5: /var/tmp raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 131.26 GiB (60.9%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:3
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:4
           ID-2: swap-2 type: zram size: 15.55 GiB used: 4.94 GiB (31.8%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.6 C mobo: 38.0 C gpu: nvidia temp: 51 C
           Fan Speeds (RPM): fan-1: 0 fan-2: 1248 fan-3: 1248 fan-4: 1249 fan-5: 1235 gpu: nvidia fan: 25%
           Power: 12v: N/A 5v: N/A 3.3v: 3.30 vbat: 3.28
Info:      Processes: 523 Uptime: 2h 47m wakeups: 8 Memory: 15.55 GiB used: 10.5 GiB (67.5%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 2101 note: see --pkg apt: 0 pacman: 2096 lib: 551
           flatpak: 5 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.06

Most menu options are grayed out this does not happen on windows or other DE seems to be this issue

https://forum.unity.com/threads/unity-not-interacting-well-with-kdes-global-menu-most-options-greyed-out.818682/

UPDATE: Seems that the unity global menu works as expected on Kubuntu

Apparently I didn't search well enough as there is actually another post on the unity forms with a workaround https://forum.unity.com/threads/unity-toolbar-greyed-out-using-kde-global-menus.638155/

basically you need to edit the dconf so that unity doesn't use kde global menu

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.