Ungoogled-chromium broken after update

I just updated via upd. I then rebooted. When I run ungoogled-chromium I get the following error.

chromium %U
/usr/lib/chromium/chromium: symbol lookup error: /usr/lib/chromium/chromium: undefined symbol: hb_subset_input_set_retain_gids

I reinstalled ungoogled-chromium. However this did not make a difference, as it resulted in same error.

sudo pacman -S ungoogled-chromium
inxi -Faz

System: Kernel: 5.14.6-1-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule
root=UUID=00b33177-335b-466d-8a5b-e5bad5669f19 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: Micro-Star product: GL65 9SE v: REV:1.0 serial: Chassis: type: 10
serial:
Mobo: Micro-Star model: MS-16U5 v: REV:1.0 serial: UEFI: American Megatrends
v: E16U5IMS.101 date: 07/02/2019
Battery: ID-1: BAT1 charge: 23.9 Wh (60.1%) condition: 39.8/51.6 Wh (77.1%) volts: 11.1 min: 10.9
model: MSI BIF0_9 type: Li-ion serial: N/A status: Unknown
CPU: Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62469
Speed: 2600 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 2600 2: 2600 3: 2600 4: 2601
5: 2600 6: 2601 7: 2600 8: 2601 9: 2600 10: 2600 11: 2600 12: 2600
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI driver: nvidia
v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f11 class-ID: 0300
Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:3 chip-ID: 04f2:b695
class-ID: 0e02
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 120 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.14.6-1-cacule running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.35 running: yes
Network: Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus-ID: 00:14.3
chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac:
IF-ID-1: virbr0 state: down mac:
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8
bus-ID: 1-14:4 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address:
Drives: Local Storage: total: 1.38 TiB used: 266.55 GiB (18.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1032
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: rev: 20140000 temp: 55.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-60JC3T0 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: rev: 1A01 scheme: GPT
Partition: ID-1: / raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 36.06 GiB (49.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 36.06 GiB (49.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 36.06 GiB (49.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 73.24 GiB size: 73.24 GiB (100.00%) used: 36.06 GiB (49.2%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors: System Temperatures: cpu: 66.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 388 Uptime: 1m wakeups: 1 Memory: 15.47 GiB used: 2.35 GiB (15.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1741 lib: 534
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.06

EDIT: These are the packages that were upgraded

Packages (41) cantarell-fonts-1:0.303-1  garuda-gamer-1.0.4-1  glib2-2.70.0-1  gobject-introspection-1.70.0-1  gobject-introspection-runtime-1.70.0-1  gtk3-1:3.24.30+62+g8d04980f38-2
harfbuzz-3.0.0-1  harfbuzz-icu-3.0.0-1  hblock-3.2.3-1  inotify-tools-3.21.9.0-1  ldb-2:2.4.0-1  lib32-glib2-2.70.0-1  lib32-harfbuzz-3.0.0-1  lib32-libcap-2.58-1
lib32-libffi-3.3-4.1  lib32-libxcrypt-4.4.26-1  lib32-nvidia-utils-470.74-1  lib32-opencl-nvidia-470.74-1  lib32-vulkan-icd-loader-1.2.191-1  libcap-2.58-1
libimagequant-2.16.0-1  libxcrypt-4.4.26-1  libxnvctrl-470.74-1  mhwd-nvidia-470.74-1  nvidia-dkms-470.74-1  nvidia-settings-470.74-1  nvidia-utils-470.74-1
opencl-nvidia-470.74-1  perl-libwww-6.57-1  plymouth-git-0.9.5.r86.g8ff8a78-1  qemu-6.1.0-2  qemu-arch-extra-6.1.0-2  qt5-webengine-5.15.6-2  samba-4.15.0-1
sdl-1.2.15+387+gfbfcca32-1  smbclient-4.15.0-1  telegram-desktop-3.1.0-1  thunderbird-appmenu-91.1.1-2  tracker3-3.2.0-1  vulkan-icd-loader-1.2.191-1
xdg-desktop-portal-1.10.1-1
1 Like

https://bbs.archlinux.org/viewtopic.php?id=269739

sudo pacman -Syuu

downgraded 'harfbuzz', and now chromium launches.

4 Likes

funny thing afer a timeshift rollback and running

sudo pacman -Syyu

These same updates are no longer listed.

Chromium (which shared the same problem) has been updated and now works with

harfbuzz-3.0.0-1  harfbuzz-icu-3.0.0-1

I guess Ungoogled-chromium has done or will do shortly the same.
So, you could try to update everything again if you want...

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.