Unable to login with correct password after sleep or lid closing

Hello! I'm loving Garuda, for so many reasons. However, an issue I've noticed on every installation I've used across multiple systems all have the same problem with waking up from a sleep state/ laptop lid being closed.

The OS shows a login screen with the correct user name displayed, I enter the correct password and it says it's the incorrect password. I am certain of the password. I literally have to restart the system to get back to the desktop.

This happens after a fresh install.

Things, I've checked:
The keyboard locale using

locale

Output:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

localectl

Output:

System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
grep "=" /etc/locale.conf
grep "=" $HOME/.config/plasma-localerc
grep "=" $HOME/.config/kxkbrc
cat /etc/X11/xorg.conf.d/00-keyboard.conf

Output:

LANG=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_TIME=en_US.UTF-8
LANG=en_US.UTF-8
update_info=kxkb_variants.upd:split-variants,kxkb.upd:remove-empty-lists,kxkb.upd:add-back-resetoptions
File: /etc/X11/xorg.conf.d/00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "us"
EndSection

What I've had to resort to:
Turning off all of the sleep settings, power plans, etc to prevent the PC from going to sleep.

System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=a051bbb7-fa31-4679-bbd8-14389a8e61e6 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82B5 v: Lenovo Legion 5 15ARH05
serial: <superuser required> Chassis: type: 10 v: Lenovo Legion 5 15ARH05
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
serial: <superuser required> UEFI: LENOVO v: EUCN31WW date: 01/01/2021
Battery:
ID-1: BAT0 charge: 54.1 Wh (96.1%) condition: 56.3/60.0 Wh (93.8%)
volts: 17.1 min: 15.4 model: Celxpert L19C4PC0 type: Li-poly
serial: <filter> status: N/A cycles: 10
CPU:
Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600106
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1924 high: 3989 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1947 2: 3989
3: 1513 4: 2080 5: 1397 6: 2736 7: 1919 8: 1393 9: 1405 10: 1887 11: 1401
12: 1425 bogomips: 71868
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 510.60.02
alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max:
gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f99
class-ID: 0300
Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:2
chip-ID: 5986:212b class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 143 s-size: 341x191mm (13.43x7.52")
s-diag: 391mm (15.39")
Monitor-1: DP-2 res: 1920x1080 hz: 120 dpi: 142
size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Audio:
Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_sof_amd_renoir
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-3:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.2 TiB used: 46.36 GiB (3.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB256HBHQ-000L2 size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3L1QEXH7 temp: 39.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPSX-08A6W
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: 1A01
scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 type: USB model: USB DISK 3.0 size: 57.7 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 46.36 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 46.36 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 46.36 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 46.36 GiB (19.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.49 GiB used: 4.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 42 C
Fan Speeds (RPM): N/A
Info:
Processes: 364 Uptime: 16h 0m wakeups: 1 Memory: 15.49 GiB
used: 7.33 GiB (47.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1773 lib: 507 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.8-1):
System install date:     2022-02-21
Last full system update: 2022-04-06 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
1 Like

:slight_smile:

It works OOTB for my Lenovo notebooks.
So maybe help in
https://wiki.archlinux.org/title/Lenovo_IdeaPad_5_15are05
?

Before installing, disable Secure Boot and fastboot in the BIOS. You can access the BIOS by pressing F2 at the Splash screen. The boot menu can also be accessed by pressing F12.

2 Likes

Did you try logging in using the (OSK) On Screen Keyboard?

Does it come out of sleep properly, if you enable auto-login?

This for troubleshooting purposes only, (not a solution).

Welcome to the Garuda community.

3 Likes

Are you using LUKS?

1 Like

I tried to use onboard to no avail unfortunately, auto login is enabled. If I do Windows Key + L the login screens look different but the password works on neither.

I don't believe so.

Can you try temporarily changing your password to something very basic and see if the issue persists? Try ten characters or less, A-Z 0-9 only (no symbols). Just to rule out the password itself.

IDk, just a thought, is there a difference between en_US and us keybords?

So the simple password, only numbers, not from numpad, could help like BluishHumility wrote.

2 Likes

I changed the password to to a 10 digit, A-Z 0-9, none of the numbers are from the kaypad, gave a restart and then tried the log in again to no avail.

Hmm, what do you mean by that?

Are you using the laptop's native keyboard?

Watch logs while trying firstly, super+l (lock screen)...

journacltl -f

Now keep that terminal open and lock the screen

ok, I was hoping you could get back in from a screen lock to check the terminal output. check your last boot logs...

journalctl -b -1 -r

Look for the timestamp/section in journalctl where your laptop went to sleep / you locked it / login attempt(s). You should find some hints.

1 Like

Sorry, I meant they are all from the top row and none are from the 10-key on the right.

That looks like a PEBKAC issue to me...
Make sure there is no broken key on your keyboard.
Then, while logged in your session,

  • go to a new TTY (Ctrl_Alt+F4)
  • At the login prompt, enter your supposedly correct password instead of your user name, so you can verify it is printed correctly. (don't login,... of course :scream: )
  • Delete all characters and try login with user name and password
  • If it fails, the password is just wrong.
  • If it succeeds, it may be a keyboard/locale configuration problem.

The wisest thing to do is disable autologin, so even if you are totally blocked out of your system, you will at least know for certain that the password is wrong.

Do whatever you like more... :smile:

5 Likes