Unable to locate printer

I've been having this weird issue when trying to use my printer:

For those who don't speak portuguese it translates closely to "unable to locate printer 'HP9457A5C2B0D7.local".
I tried reconfiguring it in every way I could find online and nothing seemed to work. Already updated everything CUPS related including the systemctl stuff (had issues with that before).

I'd like to know if anyone had a similar issue and know how to solve it.

Printer is "On"?
Cable or Wireless?
Cable are connected?
You changed USB connection?
You try maybe other USB ports?

Work sometimes before (except M$ :wink: )?

inxi -Fxxxza

Oh sorry, I didn't give enough information to be helpful. It's a wireless printer but it's being acting weird. Plasma settings can detect it and see it as configured and ready to go, CUPS Web Interface does the same, but HP Device Manager doesn't detect it even when it's plugged via USB. It used to work perfectly on other distros and W10, but I didn't need to use it on Garuda until now, which is why I didn't noticed this problem before.

inxi -Fxxxza gives me:

inxi -Fxxxza
System:
  Kernel: 5.9.13-98-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0
  parameters: intel_pstate=passive
  BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq-skylake
  root=UUID=5a5a9fdd-3013-4a23-8eae-41aa9903e2c0 rw [email protected] quiet
  rd.udev.log_priority=3 vt.global_cursor_default=0
  systemd.unified_cgroup_hierarchy=1 loglevel=3 mitigations=off
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
  Distro: Garuda Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 15 7000 Gaming v: N/A
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0P84C9 v: A01 serial: <filter> UEFI: Dell v: 1.11.0
  date: 12/04/2019
Battery:
  ID-1: BAT0 charge: 53.1 Wh condition: 55.7/74.0 Wh (75%) volts: 12.3/11.1
  model: Samsung SDI DELL 0GFJ681 type: Li-ion serial: <filter> status: Unknown
CPU:
  Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: DE
  L2 cache: 6144 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44840
  Speed: 3386 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3429 2: 3438
  3: 3406 4: 3366 5: 3414 6: 3417 7: 3411 8: 3412
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
  Type: mds status: Vulnerable; SMT vulnerable
  Type: meltdown status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy
  barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
  Type: srbds status: Vulnerable
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:591b
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0
  chip ID: 10de:1c8c
  Device-3: Sunplus Innovation Integrated Webcam type: USB driver: uvcvideo
  bus ID: 1-12:5 chip ID: 1bcf:2c01
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel,nvidia
  unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display ID: :0
  screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2")
  s-diag: 1052mm (41.4")
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5")
  diag: 389mm (15.3")
  Monitor-2: HDMI-1-0 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6")
  diag: 547mm (21.5")
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01
  direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel
  bus ID: 00:1f.3 chip ID: 8086:a171
  Sound Server: ALSA v: k5.9.13-98-tkg-bmq
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell
  driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8168
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
  vendor: Dell driver: ath10k_pci v: kernel port: d000 bus ID: 03:00.0
  chip ID: 168c:003e
  IF: wlp3s0 state: up mac: <filter>
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:4
  chip ID: 0cf3:e007
Drives:
  Local Storage: total: 1.13 TiB used: 179.84 GiB (15.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0B-00EPW0
  size: 223.58 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  serial: <filter> rev: 0000 scheme: GPT
  ID-2: /dev/sdb vendor: Toshiba model: MQ02ABD100H size: 931.51 GiB block size:
  physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm
  serial: <filter> rev: 1D scheme: GPT
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0
  port: f060 bus ID: 00:17.0 chip ID: 8086.282a rev: 31
Partition:
  ID-1: / raw size: 223.28 GiB size: 1.13 TiB (517.19%) used: 179.84 GiB (15.6%)
  fs: btrfs dev: /dev/sda2
  ID-2: /home raw size: 223.28 GiB size: 1.13 TiB (517.19%)
  used: 179.84 GiB (15.6%) fs: btrfs dev: /dev/sda2
  ID-3: /var/log raw size: 223.28 GiB size: 1.13 TiB (517.19%)
  used: 179.84 GiB (15.6%) fs: btrfs dev: /dev/sda2
  ID-4: /var/tmp raw size: 223.28 GiB size: 1.13 TiB (517.19%)
  used: 179.84 GiB (15.6%) fs: btrfs dev: /dev/sda2
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
  ID-1: swap-1 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram0
  ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram1
  ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram2
  ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram3
  ID-5: swap-5 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram4
  ID-6: swap-6 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram5
  ID-7: swap-7 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram6
  ID-8: swap-8 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram7
Sensors:
  System Temperatures: cpu: 68.0 C mobo: 53.0 C sodimm: 54.0 C
  Fan Speeds (RPM): cpu: 4207
Info:
  Processes: 265 Uptime: 42m wakeups: 1 Memory: 15.38 GiB used: 6.54 GiB (42.5%)
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 1531 pacman: 1520
  lib: 445 flatpak: 11 Shell: Zsh v: 5.8 running in: alacritty inxi: 3.1.09

Seems HP dos not work nice with Arch Linux on Dell :wink: ?
Or it works on debian distros well?

Something special on/in KDE settings / autostart?

I don't think there's anything to do with not working well with Arch exactly, before coming to Garuda I used Manjaro (I know it's not exactly Arch) and it worked flawlessly there, just like in Pop_OS.

Nothing remarkably special with my settings, the only things I have in autostart are libinput-gestures and AutoKey for my macros. Also tried reinstalling the printer with different driver options and none worked, all of them gave me the same issue. Checked my firewall as well, both on and off, nothing changes.

My last try :wink:

hplip and hplip-plugin are installed, some systemctl enable (cups,IDK).services???

It seemed the firewall had something to do with it after all.

I turned it off again to test one more time, and in CUPS Web it picked up the same printer a third time, and in this new option (the middle one in "Discovered Network Printers") it just worked. As soon as I turn the firewall again the middle option disappears.

HP Device Manager still doesn't locate it but at least I'm able to use CUPS to print what I need.

3 Likes

Firewalls will block network traffic, so that's understandable.

1 Like

The weird thing is all it blocked was the process of connecting to it.
I already had created a filter for CUPS before, so now that it's connected everything works just fine. The main problem was to be able connect to the printer the right way, which for me ended up being by socket://IP

1 Like